virt-manager can't open Linux VM's under Xen

Bug #338283 reported by Simeon Walker on 2009-03-05
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libvirt (Ubuntu)
Low
Unassigned
virt-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: virt-manager

Setup:

System is Ubuntu Jaunty as of 5/03/2009.
virt-manager 0.6.1-1ubuntu4
Remote server is Ubuntu 8.04.2, Xen 3.2 kernel 2.6.24-17-xen, libvirt0 0.4.0-2ubuntu8.2
Remote Linux VM's are 2.6.24-23-xen
Access via ssh is configured and working.

Last worked a few weeks ago before Jaunty updates to virt-manager. Sorry I can't say exactly when it broke. Still works fine under Intrepid.

What happens:

I open 'Virtual Machine Manager' and a list of VM's on the remote machine is shown. CPU and memory usage is shown as expected. I can double-click on a Windows or Mikrotik VM and the console/properties etc window is show as usual. However if I try to open one of the Linux VM's I get this error:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 272, in show_details
    details = vmmDetails(self.get_config(), con.get_vm(uuid), self)
  File "/usr/share/virt-manager/virtManager/details.py", line 332, in __init__
    self.prepare_hw_list()
  File "/usr/share/virt-manager/virtManager/details.py", line 1504, in prepare_hw_list
    self.populate_hw_list()
  File "/usr/share/virt-manager/virtManager/details.py", line 1526, in populate_hw_list
    self.repopulate_hw_list()
  File "/usr/share/virt-manager/virtManager/details.py", line 1618, in repopulate_hw_list
    for charinfo in self.vm.get_char_devices():
  File "/usr/share/virt-manager/virtManager/domain.py", line 806, in get_char_devices
    return self._parse_device_xml(_parse_char_devs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 913, in _parse_device_xml
    raise RuntimeError(_("Error parsing domain xml: %s") % str(e))
RuntimeError: Error parsing domain xml: 'NoneType' object is not iterable

agent 8131 (agent-8131) wrote :

I can confirm this bug as I just ran across it in testing.

Changed in libvirt (Ubuntu):
status: New → Confirmed
Changed in virt-manager (Ubuntu):
status: New → Confirmed
agent 8131 (agent-8131) wrote :

Given the rapid pace of development of libvirt as well as virt-manager and no stable API I wonder if the best solution to this bug might be to backport libvirt 0.6.1 to hardy as opposed to trying to patch virt-manager. Any thoughts?

biotecs (biotecs) wrote :

I can confirm this bug for my enviroment:
System is Ubuntu Jaunty
virt-manager: 0.6.1-1ubuntu5
Remote server: SLES 10 SP2, Xen 3.2 Kernel 2.6.16.60-0.39.3-xen, libvirt-0.3.3-18.15.1
Remote Linux VM's have also 2.6.16.60-0.39.3-xen
Access via ssh is configured and working.

With SLES 11 it works fine.
Remote server: SLES 11, Xen 3.3 Kernel 2.6.27.19-5-xen, libvirt-0.4.6-14.56
Remote Linux VM's are 2.6.27.21-0.1-xen

Cal (cal-fbsdata) wrote :

I have this exact same error. Trying to get the VNC console window on any Linux SSH pipe sessions fails with the error message listed. I also downloaded the latest virt-manager 0.7.0 and have the same error.

Would be nice to see this fixed because it's quite handy!

Cal (cal-fbsdata) wrote :

Correction: The error is slightly different in virt-manager 0.7.0:

raceback (most recent call last):
  File "/usr/local/share/virt-manager/virtManager/engine.py", line 272, in show_details
    details = vmmDetails(self.get_config(), con.get_vm(uuid), self)
  File "/usr/local/share/virt-manager/virtManager/details.py", line 337, in __init__
    self.update_widget_states(self.vm, self.vm.status())
  File "/usr/local/share/virt-manager/virtManager/details.py", line 837, in update_widget_states
    self.try_login()
  File "/usr/local/share/virt-manager/virtManager/details.py", line 1266, in try_login
    protocol, host, port, trans, username = self.vm.get_graphics_console()
  File "/usr/local/share/virt-manager/virtManager/domain.py", line 638, in get_graphics_console
    self.update_xml()
  File "/usr/local/share/virt-manager/virtManager/domain.py", line 89, in update_xml
    self._xml = self.vm.XMLDesc(libvirt.VIR_DOMAIN_XML_SECURE)
  File "/usr/lib/python2.6/dist-packages/libvirt.py", line 231, in XMLDesc
    if ret is None: raise libvirtError ('virDomainGetXMLDesc() failed', dom=self)
libvirtError: Unknown failure

This is paired with libvirt in Jaunty, version 0.6.1-0ubuntu5

Using my VNC viewer to the Domain-0 machine works fine.

Changed in libvirt (Ubuntu):
importance: Undecided → Wishlist
importance: Wishlist → Low
Changed in virt-manager (Ubuntu):
importance: Undecided → Wishlist
importance: Wishlist → Low
Brent Thomson (diepiapaopolopo) wrote :

Here's a patch against 0.6.1 on 9.04.

Dustin Kirkland  (kirkland) wrote :

Hi there, thanks for the report.

I see lots of people reproducing this bug against Jaunty...

Can anyone reproduce it against Lucid?

Changed in libvirt (Ubuntu):
status: Confirmed → Incomplete
Changed in virt-manager (Ubuntu):
status: Confirmed → Incomplete
Simeon Walker (simeon-walker) wrote :

I can confirm that virt-manager 0.8.2-2ubuntu8 in lucid can connect to the Xen machine I mention in this bug report.

Marc Deslauriers (mdeslaur) wrote :

Great! I'm marking this bug as fixed.

Changed in libvirt (Ubuntu):
status: Incomplete → Fix Released
Changed in virt-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers