virt-manager reboot action is non-functional

Bug #337763 reported by Jamie Strandboge
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
virt-manager
Fix Released
Medium
virt-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: virt-manager

Start a machine, go to Virtual Machine/Shutdown/Reboot:
Error shutting down domain: this function is not supported by the hypervisor: virDomainReboot

Details:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 528, in reboot_domain
    vm.reboot()
  File "/usr/share/virt-manager/virtManager/domain.py", line 504, in reboot
    self.vm.reboot(0)
  File "/usr/lib/python2.6/dist-packages/libvirt.py", line 392, in reboot
    if ret == -1: raise libvirtError ('virDomainReboot() failed', dom=self)
libvirtError: this function is not supported by the hypervisor: virDomainReboot

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: virt-manager 0.6.1-1ubuntu4
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: virt-manager
Uname: Linux 2.6.28-8-generic x86_64

Revision history for this message
Jamie Strandboge (jdstrand) wrote :
Steve Beattie (sbeattie)
Changed in virt-manager:
assignee: nobody → canonical-server
importance: Undecided → Medium
Rick Clark (dendrobates)
Changed in virt-manager (Ubuntu):
assignee: canonical-server → soren
Revision history for this message
Dustin Kirkland  (kirkland) wrote : Re: [jaunty] regression: virt-manager reboot action is non-functional

I can confirm that the "reboot" action is non-functional.

I cannot yet confirm that this is a regression.

:-Dustin

Changed in virt-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
Dustin Kirkland  (kirkland) wrote :

Okay, I don't think this is a regression from Intrepid.

In my Intrepid virt-manager, I do not have a "reboot" action available, that I can find. I do have a "shutdown" button, which, like jaunty, does not work.

Perhaps Jamie meant that this has regressed from earlier in the Jaunty cycle?

In any case, while it's highly annoying and unpolished that we have non-working shutdown/reboot buttons, it's not release critical, IMHO.

:-Dustin

Revision history for this message
In , Itamar (itamar-redhat-bugs) wrote :

Description of problem:

I receive this error when I press shutdown button

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 523, in reboot_domain
    vm.reboot()
  File "/usr/share/virt-manager/virtManager/domain.py", line 569, in reboot
    self.vm.reboot(0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 392, in reboot
    if ret == -1: raise libvirtError ('virDomainReboot() failed', dom=self)
libvirtError: this function is not supported by the hypervisor: virDomainReboot

Version-Release number of selected component (if applicable):

qemu-0.10-8.fc11.x86_64
virt-manager-0.7.0-4.fc11.x86_64

Expected results:

I like to be able to power off and reset a virtual machine using shutdown button, without receiving error message.

Revision history for this message
In , Mark (mark-redhat-bugs) wrote :

Yep, this is a known issue:

http://www.redhat.com/archives/libvir-list/2008-October/msg00168.html

Moving to upstream bugtracker

Revision history for this message
Steve Beattie (sbeattie) wrote :

Based on Dustin's comment, I've removed the regression-potential tag.

tags: removed: regression-potential
Revision history for this message
In , Mark (mark-redhat-bugs) wrote :

Ryan Harper posted a patch to add the qemu side of this:

  http://lists.gnu.org/archive/html/qemu-devel/2009-05/msg00450.html

Revision history for this message
In , Mark (mark-redhat-bugs) wrote :

Okay, moving back to Fedora/rawhide and putting on F12VirtTarget

Revision history for this message
In , Daniel (daniel-redhat-bugs) wrote :

*** Bug 505719 has been marked as a duplicate of this bug. ***

Changed in virt-manager:
status: Unknown → In Progress
Revision history for this message
In , Mark (mark-redhat-bugs) wrote :

AFAICT, the conclusion from upstream was that libvirt should do system_powerdown followed by polling via info status followed by system_reset

Soren Hansen (soren)
Changed in virt-manager (Ubuntu):
assignee: Soren Hansen (soren) → nobody
summary: - [jaunty] regression: virt-manager reboot action is non-functional
+ virt-manager reboot action is non-functional
Revision history for this message
In , Mark (mark-redhat-bugs) wrote :

*** Bug 524779 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Dustin (dustin-redhat-bugs) wrote :

Any update on the status of this bug? The discussion on the Ubuntu dupe [1] of this bug has been lively, lately.

We're curious if libvirt might simply implement "reboot" by sending "ctrl-alt-delete" to the guest. It seems that most Linux and Windows operating systems will handle ctrl-alt-delete as a warm reboot fairly consistently.

Revision history for this message
In , Dustin (dustin-redhat-bugs) wrote :

Any update on the status of this bug? The discussion on the Ubuntu dupe [1] of this bug has been lively, lately.

We're curious if libvirt might simply implement "reboot" by sending "ctrl-alt-delete" to the guest. It seems that most Linux and Windows operating systems will handle ctrl-alt-delete as a warm reboot fairly consistently.

[1] https://bugs.launchpad.net/bugs/368962

Revision history for this message
In , Daniel (daniel-redhat-bugs) wrote :

I most/many Windows, Ctrl-Alt-Delete is a shortcut to bring up the login dialog, not reboot, so its not really viable.

Revision history for this message
In , Dustin (dustin-redhat-bugs) wrote :

Bummer. I guess it's really been that long since I used Windows. I swear ctrl-alt-delete used to reboot Windows...

Revision history for this message
In , Daniel (daniel-redhat-bugs) wrote :

Win 3.1 & Win 95/98/XP derivatives treat it as a reboot. Win NT and 2k, 2k3, 2k8, Vista, 7, derivatives treat it as a logon signal.

http://en.wikipedia.org/wiki/Control-Alt-Delete#Windows

Revision history for this message
zoolook (nbensa) wrote :

This is fixed in Maverick.

Revision history for this message
Joel Duckworth (joel-jpd) wrote :

Running Lucid & qemu-kvm you can get the shutdown feature to work by installing acpid on the linux guest, but this doesn't fix the reboot option. Just FYI

Revision history for this message
Fiodor Kupchik (ferimy) wrote :

this is not fixed in Maverick as I can't reboot or shutdown VMs
very annoying

Revision history for this message
Serge Hallyn (serge-hallyn) wrote :

Fyodor,

please file a new bug with more details about your host and guest setups, and
exactly what you did. Given confirmation from others that the bug was fixed in
maverick, if you are finding it broken again then it is likely a regression.

Revision history for this message
Andreas Ntaflos (daff) wrote :

Serge,

why do you think this bug has been fixed? Nowhere is it confirmed that a fix has been released, not even the associated Red Hat bug has seen any activity in months.

Revision history for this message
Serge Hallyn (serge-hallyn) wrote :

Hm. Comment #5. Sounds like that one is simply wrong.

Revision history for this message
Fiodor Kupchik (ferimy) wrote :

Serge,

I think there's some misunderstanding. When I say - I can't reboot - I mean that it cannot be done despite the state of the VM and the fact of loaded OS or not. Every time I need to shutdown or reboot VM which does not support ACPI or just hasn't loaded OS I have to use kill program to send SIGTERM to the KVM process. I don't think this is the bug in Ubuntu package - this issue should go to upstream.

But saying that this issue fixed is wrong as the title states that by pressing button I should expect reboot or shutdown and don't care how it was done in code - via invoking kill prog via ssh or by the way of managing guest ACPI functions.

I think that there is no big problem to add two more buttons in GUI - force shutdown (kill specific KVM process) or reboot (kill and re-run).

Revision history for this message
Philippe Coval (rzr) wrote :

I also faced this message on lucid using :

  virt-manager 0.8.2-2ubuntu8

--
http://rzr.online.fr/q/kvm

Revision history for this message
Thomas Güttler (hv-tbz-pariv) wrote :

Thank you Joel Duckworth. After installing acpid in the guest shutdown works.

Revision history for this message
In , Daniel (daniel-redhat-bugs) wrote :

commit 42f43592be3045bed5dabdaea65718f6d2c706e4
Author: Daniel P. Berrange <email address hidden>
Date: Wed Jun 15 17:49:58 2011 +0100

    Support reboots with the QEMU driver

    For controlled shutdown we issue a 'system_powerdown' command
    to the QEMU monitor. This triggers an ACPI event which (most)
    guest OS wire up to a controlled shutdown. There is no equiv
    ACPI event to trigger a controlled reboot. This patch attempts
    to fake a reboot.

Changed in virt-manager:
importance: Unknown → Medium
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.