CPU performance tip inconsistency: logical vs. physical

Bug #251067 reported by Richard Laager on 2008-07-23
4
Affects Status Importance Assigned to Milestone
virt-manager
Won't Fix
Low
virt-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

When creating a new VM, the wizard says (on the "Allocate memory and CPU" page): "Tip: For best performance, the number of virtual CPUs should be less than (or equal to) the number of logical CPUs on the host system."

On the VM details -> Hardware tab -> Processor section, it says "physical CPUs" instead of "logical CPUs".

I'd imagine that "physical" is what is really intended here. I'd further recommend that either way, this tip be hidden unless the VCPUs is > the (physical or logical, as decided) host CPUs. I'd also be nice if both of those dialogs showed physical vs. logical host CPU counts.

Changed in virt-manager:
importance: Undecided → Wishlist

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4

When creating a new VM, the wizard says (on the "Allocate memory and CPU" page): "Tip: For best performance, the number of virtual CPUs should be less than (or equal to) the number of logical CPUs on the host system."

On the VM details -> Hardware tab -> Processor section, it says "physical CPUs" instead of "logical CPUs".

I'd imagine that "physical" is what is really intended here. I'd further recommend that either way, this tip be hidden unless the VCPUs is > the (physical or logical, as decided) host CPUs. I'd also be nice if both of those dialogs showed physical vs. logical host CPU counts.

Reproducible: Always

Dan Bass (dbass) on 2008-12-09
Changed in virt-manager:
importance: Undecided → Unknown
status: New → Unknown
Changed in virt-manager:
status: Unknown → Confirmed
Richard Laager (rlaager) wrote :

The wording has been fixed upstream (by committing a patch from me), but the other suggestions haven't been implemented yet.

Changed in virt-manager:
status: New → Confirmed

The create wizard is and CPU details views are quite different now, and no longer contain the offending text. Closing as UPSTREAM.

Changed in virt-manager:
status: Confirmed → Fix Released
Marc Deslauriers (mdeslaur) wrote :

This is fixed in the new virt-manager version currently in Lucid. Closing bug.

Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released
Changed in virt-manager:
importance: Unknown → Low
status: Fix Released → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.