Physical Device Required error dialog nitpick

Bug #251054 reported by Richard Laager on 2008-07-23
4
Affects Status Importance Assigned to Milestone
virt-manager
Won't Fix
Low
virt-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

If you try to setup networking with a physical device, but don't select a physical device (because the list is empty), you get an error. It says, "You must select one of the physical devices".

1. This should have a period at the end, as it's a sentence. (This seems to be a common error in virt-manager and the various error messages should all be checked and corrected as needed.)

2. This wording assumes there was a device, which there wasn't. Instead of "...select one of the physical...", it should say, "...select a physical...". Alternatively, if the first item in the list is always selected (making it impossible to select nothing if the list is non-empty), then the physical device radio button could be greyed out when the list is empty; this would make this error message entirely unnecessary.

Perhaps this dialog (or the wizard) should mention installing hal if the list is empty (which was the reason the list was empty for me).

Changed in virt-manager:
importance: Undecided → Wishlist

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in virt-manager:
status: New → Incomplete

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5

If you try to setup networking with a physical device, but don't select a physical device (because the list is empty), you get an error. It says, "You must select one of the physical devices".

1. This should have a period at the end, as it's a sentence. (This seems to be a common error in virt-manager and the various error messages should all be checked and corrected as needed.)

2. This wording assumes there was a device, which there wasn't. Instead of "...select one of the physical...", it should say, "...select a physical...". Alternatively, if the first item in the list is always selected (making it impossible to select nothing if the list is non-empty), then the physical device radio button could be greyed out when the list is empty; this would make this error message entirely unnecessary.

Perhaps this dialog (or the wizard) should mention installing hal if the list is empty (which was the reason the list was empty for me).

Reproducible: Always

Dan Bass (dbass) on 2008-12-29
Changed in virt-manager:
importance: Undecided → Unknown
status: New → Unknown
Changed in virt-manager:
status: Unknown → Confirmed

The text changes were applied here: http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/e2056d9074e5

Cole Robinson had this to say on the et-mgmt-tools list:
> > Alternatively, if the first item in the list is always selected (making it
> > impossible to select nothing if the list is non-empty), then the physical
> > device radio button could be greyed out when the list is empty; this would
> > make this error message entirely unnecessary.
>
> Yes, this is a reasonable change.
>
> >
> > Perhaps this dialog (or the wizard) should mention installing hal if the list
> > is empty (which was the reason the list was empty for me).
>
> Maybe if any hal calls fail, we disable the drop down and put up add a
> tooltip or something like that.

Richard Laager (rlaager) wrote :

The wording has been fixed upstream (by committing a patch from me), but the other suggestions haven't been implemented yet. Upstream thinks they're acceptable.

Changed in virt-manager:
status: Incomplete → Confirmed
Changed in virt-manager:
status: Confirmed → Triaged

This UI has been completely redesigned upstream, and the above suggestions no longer apply. Thanks for following up with this nonetheless.

(If you wiktel folk wanted to check out the new designs and file another slew of bugs, I'd be psyched. You guys have good eyes for this stuff!)

Closing as UPSTREAM.

Changed in virt-manager:
status: Confirmed → Fix Released

Last comment from redhat bugzilla:
>>>
This UI has been completely redesigned upstream, and the above suggestions no
longer apply. Thanks for following up with this nonetheless.

(If you wiktel folk wanted to check out the new designs and file another slew
of bugs, I'd be psyched. You guys have good eyes for this stuff!)
<<<
Can we now close this bug based on the date?

Changed in virt-manager (Ubuntu):
status: Triaged → Incomplete

Closing the bug as no further information has been provided.

Changed in virt-manager (Ubuntu):
status: Incomplete → Fix Released
Changed in virt-manager:
importance: Unknown → Low
status: Fix Released → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.