SSH errors not presented to user

Bug #251036 reported by Richard Laager on 2008-07-23
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
virt-manager
Won't Fix
Medium
virt-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

If SSH fails due to a key mismatch, the user is not notified that SSH is the problem. Instead, virt-manager presents a generic dialog about libvirtd problems.

Marcus Asshauer (mcas) wrote :

Thank you for reporting this bug. Please add your ubuntu version and the version of virt-manager.

Changed in virt-manager:
status: New → Incomplete
Richard Laager (rlaager) wrote :

I'm running virt-manager 0.5.3-0ubuntu10 on Hardy.

Changed in virt-manager:
status: Incomplete → New
Changed in virt-manager:
importance: Undecided → Wishlist

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4

If SSH fails due to a key mismatch, the user is not notified that SSH is the problem. Instead, virt-manager presents a generic dialog about libvirtd problems.

Reproducible: Always

virt-manager 0.5.4-2ubuntu1

Dan Bass (dbass) on 2008-12-10
Changed in virt-manager:
importance: Undecided → Unknown
status: New → Unknown
Changed in virt-manager:
status: Unknown → Confirmed

This was a mix of libvirt and virt-manager: both weren't returning SSH errors properly. This is now fixed upstream in both packages, so closing.

Marc Deslauriers (mdeslaur) wrote :

This is fixed in the new virt-manager version currently in Lucid. Closing bug.

Changed in virt-manager (Ubuntu):
status: New → Fix Released
Changed in virt-manager:
importance: Unknown → Medium
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.