[patch?] alt-gr does not work inside kvm debian terminal

Bug #238684 reported by Michael Vogt on 2008-06-09
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
kvm (Ubuntu)
Medium
Unassigned
qemu (Debian)
Fix Released
Unknown
virt-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kvm

Hi,

I had issues with the alt-gr key (and with caps-lock that I remapped) inside a kvm that runs a debian virtual console. I stumbled upon debian bug #441068 and tried the patch and that made the key work. It also made console-setup correctly honor "ctrl:nocaps". I attach the debdiff for the diff I used, some of the patch is probably nose (e.g. keymaps/es), if you want, I'm happy to isolate the changes that are really required (but its late now).

Cheers,
 Michael

Michael Vogt (mvo) wrote :
Changed in qemu:
status: Unknown → New

Hi,

I can confirm, Alt-Gr key does not work in German, too. I did not try the patch yet.

The bug occurs in a Linux gueast as well as in Win-XP.

Checking with xev in the Linux guest, you can recognize, there is no event on the key.

Christian

Changed in kvm:
importance: Undecided → Medium
status: New → Triaged
Dustin Kirkland  (kirkland) wrote :

Hey Michael, Christian-

kvm-84 has a lot of foreign keyboard fixes. Can you guys reproduce this problem in Jaunty?

:-Dustin

Dustin Kirkland  (kirkland) wrote :

Upstream believes that this is fixed in modern kvm. They took a look at your patch and it's not really the best way to solve this. Please try the new kvm and see if alt-gr works :-)

:-Dustin

Changed in kvm:
status: Triaged → Incomplete
Dustin Kirkland  (kirkland) wrote :

If you're running Hardy, could you please test this using the kvm-84 package in this PPA:
 * https://launchpad.net/~ubuntu-virt/+archive/ppa

Does this solve the issue, or is it reproducible?

:-Dustin

Thierry Carrez (ttx) wrote :

I can reproduce the issue with Jaunty guest / Jaunty host.

AltGR is basically ignored. You can test by booting a Jaunty livecd (with a display forcing keymap=fr), select "French / French alternative" as the keyboard and try in the test textbox using your qwerty keyboard:
Typing "Q" correctly yields a "A", however:
AltGR+3 should yield "#" instead of "
AltGR+6 should yield "|" instead of -

I will try to check out the patch to see if it's still fit for kvm-84.

Changed in kvm (Ubuntu):
status: Incomplete → Confirmed
Thierry Carrez (ttx) wrote :

I can confirm that the patch from Michael still applies (with minor adaptations, see the attached debdiff) and fixes the issue for Jaunty guest / Jaunty host.

Thierry-

Can you try running kvm without a -k option? Does it still have that problem?

:-Dustin

Thierry Carrez (ttx) wrote :

Hmmm...
It works perfectly using the QEMU console you get by running "kvm" directly.
If I put "-k fr" or I run without a "-k" option, AltGR key combinations work as intended.

What doesn't work is typing AltGR combinations inside virt-manager viewer. So I guess it introduces a difference... There doesn't seem to be a simple way of forcing virt-manager to run kvm without a "-k" option, so I can't really test that. Note that the above kvm patch works around the libvirt viewer bug (but that may not be the appropriate way of fixing this bug).

Dustin Kirkland  (kirkland) wrote :

Thierry-

I think you're confirming that this is a virt-manager bug, not a kvm bug.

In general, if it works from the kvm command line, but exists in
virt-manager, then the bug is either in virt-manager or libvirt.

:-Dustin

Changed in virt-manager (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in kvm (Ubuntu):
status: Confirmed → Invalid
schnittchen (schnittchen) wrote :

It might be interesting to know that the problem also occurs when using gvncviewer (on jaunty). I started my vm using virt-manager and verified (in /proc/../cmdline) that kvm is spawned with "-k de".

Eventually, both gvncviewer and virt-manager use libgtk-vnc, which might be the place to look for.

Linux tp-intrepid 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

virt-manager: Version: 0.6.1-1ubuntu4
kvm: Version: 1:84+dfsg-0ubuntu11
libvirt0: Version: 0.6.1-0ubuntu5
gvncviewer: Version: 0.3.8-2ubuntu2

Jay (jerome-avond-free) wrote :

Someone told here that there is a solution :
http://qemu-forum.ipi.fi/viewtopic.php?f=4&t=3978

Adding {"ISO_Level3_Shift", 0xfe03}, /* ISO_Level3 in the vnc_keysym.h file.

Hope you could check that.

Dustin Kirkland  (kirkland) wrote :

On Thu, Sep 10, 2009 at 3:59 AM, Jay <email address hidden> wrote:
> Adding {"ISO_Level3_Shift", 0xfe03}, /* ISO_Level3 in the vnc_keysym.h
> file.
>
> Hope you could check that.

This is in karmic's qemu-kvm package already.

Can you test this please?

:-Dustin

lequeux1 (elequeux) wrote :

Patch cited in #12 was also integrated in Jaunty's qemu, but not kvm.

A more complete version is available in http://patches.ubuntu.com/by-release/ubuntu/k/kvm/kvm_1:84+dfsg-0ubuntu10.slipped-patch (look for altgr-dead-keys-vnc.diff); Works for me.

E\

Jay (jerome-avond-free) wrote :

Apparently, on some vnc client Alt-Gr works (directvnc for example vnc via framebuffer), maybe it's a probleme from the vnc client not the vnc server.

lequeux1 (elequeux) wrote :

... Maybe, but:
 * vinagre, vncviewer, virt-viewer, all use alt-gr.
 * directvnc fails to connect kvm local domains
 * if this patch doesnt make sense, why is it integrated in jaunty qemu ( but not in kvm ) package ?
 * Really annoying for a french user (and probably other non US users, too). with no { [ @ \ # ~ | ] } life is so complicated...

E\

Olivier Berger (olivierberger) wrote :

I'm not sure this is purely virt-manager problem, as it seems to happen also when using libvirt's virsh.

So may need to be reassigned to libvirt actually.

hron84 (hrgy) wrote :

#17: I don't think this is related just libvirt. I use pure qemu (on Gentoo, but this isn't important) and qemu has this issue too.

Marc Deslauriers (mdeslaur) wrote :

The version of virt-manager in lucid doesn't pass the -k parameter when starting kvm anymore, as recent kvm shouldn't require specifying a keyboard. This issue should therefore be fixed in virt-manager.

Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released
Changed in qemu (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.