Virt-Manager results in "Floating point exception (core dumped)" when connecting to xen local

Bug #223993 reported by Thiago Martins on 2008-04-29
44
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager (Suse)
Fix Released
Unknown
virt-manager (Ubuntu)
Medium
Thiago Martins

Bug Description

Binary package hint: virt-manager

I have a fresh Ubuntu 8.04 installed with proposed activated on sources.list (latest upgrade), my kernel is 2.6.22-14-xen from Gutsy because of the networking BIGBUG on 2.6.24 kernel (vide https://bugs.launchpad.net/ubuntu/+source/xen-3.2/+bug/204010)

I have two domUs running in production environment, created via xen-tools package, let me show my system:

administrativo@srv44:~$ id
uid=1000(administrativo) gid=1000(administrativo) groups=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),106(fuse),110(lpadmin),111(admin),113(libvirtd),1000(administrativo)

root@srv44:~# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"

root@srv44:~# uname -a
Linux srv44 2.6.22-14-xen #1 SMP Tue Feb 12 04:26:15 UTC 2008 x86_64 GNU/Linux

root@srv44:~# xm li
Name ID Mem VCPUs State Time(s)
Domain-0 0 512 1 r----- 2463.3
vsrv64 1 1024 1 ------ 6754.9
vsrv66 3 1024 1 r----- 5841.5

root@srv44:~# virsh -c xen:///system
Connecting to uri: xen:///system
Welcome to virsh, the virtualization interactive terminal.

Type: 'help' for help with commands
       'quit' to quit

virsh # list
 Id Name State
----------------------------------
  0 Domain-0 running
  1 vsrv64 blocked
  3 vsrv66 running

 The error:

 Login with normal user (administrativo), created during install of Ubuntu, startx (gnome-session) and in a gnome-terminal, I tried this:

administrativo@srv44:~$ sudo virt-manager --no-fork

  On virt-manager: File -> Open connection... -> Xen / local -> Connect <ENTER>...

  ... and on shell:

administrativo@srv44:~$ sudo virt-manager --no-fork
Floating point exception (core dumped)
administrativo@srv44:~$ ;-(

 But, if I try to connect via "Remote tunnel over SSH" using my local sshd, virt-manager works! But I cannot create New VMs remotely due to software limitations.

 Look my screenshot attached...

Best regards,
Thiago

Thiago Martins (martinx) wrote :
Aaron Brady (bradya) wrote :

I am also having this bug.

It's doing a GET /xend/node/ over a Unix socket, and the response (from strace) is:

read(18, "(node (system Linux) (host xen) (release 2.6.19-4-generic-amd64) (version \'#2 SMP Thu Apr 5 05:57:13 UTC 2007\') (machine x86_64) (nr_cpus 2) (nr_nodes 1) (cores_per_socket 2) (threads_per_core 1) (cpu_mhz 1800) (hw_caps 178bf3ff:ebd3fbff:00000000:00000010:00002001:00000000:0000001f) (total_memory 4094) (free_memory 2) (max_free_memory 747) (max_para_memory 743) (max_hvm_memory 733) (node_to_cpu node0:0-1) (xen_major 3) (xen_minor 2) (xen_extra .1-rc1-pre) (xen_caps \'xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x86_32 hvm-3.0-x86_32p hvm-3.0-x86_64 \') (xen_scheduler credit) (xen_pagesize 4096) (platform_params \'virt_start=0xffff800000000000\') (xen_changeset unavailable) (cc_compiler \'gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)\') (cc_compile_by buildd) (cc_compile_domain buildd) (cc_compile_date \'Fri Apr 11 01:13:51 UTC 2008\') (xend_config_format 4))", 852) = 852
close(18) = 0
--- SIGFPE (Floating point exception) @ 0 (0) ---
+++ killed by SIGFPE +++
Process 13794 detached

Aaron Brady (bradya) wrote :

root@xen:/etc/xen# dpkg -l | grep xen
ii libxen3 3.2.0-0ubuntu10 library interface for Xen, a Virtual Machine
ii libxen3.1 3.1.0-0ubuntu19 library interface for Xen, a Virtual Machine
ii linux-image-2.6.22-14-xen 2.6.22-14.52 Linux kernel image for version 2.6.22 on Thi
ii python-xen-3.2 3.2.0-0ubuntu10 python bindings for Xen, a Virtual Machine M
ii xen-docs-3.2 3.2.0-0ubuntu10 documentation for XEN, a Virtual Machine Mon
ii xen-hypervisor-3.2 3.2.0-0ubuntu10 The Xen Hypervisor for i386 and amd64.
ii xen-image-2.6.19-4-generic-amd64 2.6.19-2ubuntu7 Linux kernel image for version 2.6.19 on x86
ii xen-tools 3.8-4ubuntu4 Tools to manage debian XEN virtual servers
pc xen-utils-3.0 3.0.3-0ubuntu10 XEN administrative tools
pc xen-utils-3.1 3.1.0-0ubuntu19 XEN administrative tools
ii xen-utils-3.2 3.2.0-0ubuntu10 XEN administrative tools
ii xenman 0.6-1ubuntu2 A graphical Xen management tool

I'm running the 3.2 hypervisor. Sorry for the double comment.

root@xen:/etc/xen# uname -a
Linux xen 2.6.19-4-generic-amd64 #2 SMP Thu Apr 5 05:57:13 UTC 2007 x86_64 GNU/Linux

This machine is an "apt-get dist-upgrade" from gutsy.

Same problem with a fresh Ubuntu server 8.04 AMD64 install.

I tried to compile 0.5.4, 0.5.3 and 0.4.0 from sources, and I got the same problem. I suppose the problem comes from one of the used library ?

Same problem with Debian Etch + backported Libvirt 0.4.0. I suppose the problem comes from Libvirt...

Sorry for the multiples posts but I can confirm the problem comes from libvirt.

On a fresh Ubuntu Server 8.04 (64 bits), where there was the problem, I simply installed the libvirt0 package from Intrepid repository (0.4.2). Now Virt-manager works great with local connections to Xen.

Thiago Martins (martinx) wrote :

Can someone make a backport to Hardy of libvirt0 from Intrepid?

Tessa (unit3) wrote :

I think what Laurent meant was you could just install libvirt0 from intrepid without backporting. Which you can. However, after I did this, I couldn't create a VM, as it would never let me progress past the disk setup stage. I'm doing a full backport of all the libvirt stuff using prevu at the moment, so we'll see if that makes a difference, but I'm starting to think that the whole libvirt/virt-manager thing isn't very reliable.

Tessa (unit3) wrote :

Nope, even with all the virt related packages backported from Intrepid, I can't actually create a virtual machine for Xen.

After installing libvirt from Intrepid, the connection step is OK, but at the end of the wizard for a VM creation, I get this error message :
https://bugs.launchpad.net/ubuntu/+source/virt-manager/+bug/239802

Do you experience the same problem ?

Tessa (unit3) wrote :

I'll answer on the new bug you created, since it's outside the scope of this bug.

What about a Libvirt > 0.4.0 backport for Hardy ?

Tessa (unit3) wrote :

Well, like I said, I used prevu and did that. However, it resulted in further problems, which leads me to believe that an official backport isn't likely.

When I say "backport", I think to use Libvirt > 0.4.0 into Hardy instead of the 0.4.0 to correct this problem. The further problems should be reported and resolved...

Thiago Martins (martinx) wrote :

Yeah!

Just recompile "libvirt0 0.4.2-5ubuntu2" for Hardy and put it on apt-enabled repository:
deb http://archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse

...so I can get it on Hardy running a standard update/upgrade.

About the problem "never let me progress past the disk setup stage." inicially on Hardy, we have this problem too,
but after upgrading to "libvirt0 0.4.0-2ubuntu8" from proposed, I can go forward this step, but... there is this BUG we talking about. I guess I'm not wrong with this...

Traceman (hflor) wrote :

Hello,

the version "libvirt0 0.4.2-5ubuntu2" is not found in hardy-backports.
I have loaded the source code package "libvirt0 0.4.4-0ubuntu1" from intrepid and built it under hardy.
After that I got the following error message:

virsh -c xen:///
Connecting to uri: qemu:///system
libvir: error : could not connect to xen:///
error: failed to connect to the hypervisor

Where can I find the source for "libvirt0 0.4.2-5ubuntu2" and what can I do
to build the installation package?

Why don't use Libvirt 0.4.4 deb package from Intrepid repository into Hardy ?

For your problem, check if the line "(xend-unix-server yes)" is correctly uncommented in /etc/xen/xend-config.sxp.

Traceman (hflor) wrote :

> Why don't use Libvirt 0.4.4 deb package from Intrepid repository into Hardy ?

libvirt-bin from intrepid requied libc6 >= 2.8 and into hardy is libc6 = 2.7

> For your problem, check if the line "(xend-unix-server yes)" is correctly uncommented in /etc/xen/xend-config.sxp.

Yes, this line correct.

With the version 0.4.0... from hardy I have the error message "floating point exception"

Libvirt 0.4.0 is also used in OpenSUSE 11.0, but this bug is now corrected, see the patches here : https://bugzilla.novell.com/show_bug.cgi?id=398932

It should be interesting to apply it to Hardy's Libvirt...

Traceman (hflor) wrote :

The source package "libvirt0 0.4.0-2ubuntu8" with patch from novell works.

Many thanks

Changed in virt-manager:
importance: Undecided → Medium
status: New → Confirmed
Changed in virt-manager:
status: Unknown → Fix Released
Thiago Martins (martinx) wrote :

Hi Traceman,

 I have installed the version 0.4.0-2ubuntu8 of libvirt0 but the BUG still there...

Regards,
Thiago

Soren Hansen (soren) wrote :

This patch should allegedly fix it. I'll whip up a version with it applied, and if it works, I'll get it SRU'ed.

http://git.et.redhat.com/?p=libvirt.git;a=commitdiff;h=55ba990568ce4c2658fabe48804b1187cca037e4;hp=0abb3c58e8fec49283cb55ce42b64568215f96e0

Timo (timohirt) wrote :

The same bug here!

root@host # uname -a
Linux openvztest 2.6.24-21-xen #1 SMP Wed Oct 22 01:07:57 UTC 2008 x86_64 GNU/Linux

dahias (wengahias) wrote :

Updating the Package "libvirt-bin" like suggested in Comment #16 fixed the Problem for me. Thanks

Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting this issue.
Do you still have it?
Are you able to reproduce this with a recent version of Ubuntu, such as Karmic or Lucid?

Changed in virt-manager (Ubuntu):
assignee: nobody → Thiago Martins (martinx)
status: Confirmed → Incomplete

This issue is solved for a long time. You can close the bug report.

Changed in virt-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.