Help -> About gives application name of 'virt-manager.py' rather than Virtual Machine Manager

Bug #206891 reported by Mike MacCana on 2008-03-26
6
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Wishlist
Soren Hansen
Hardy
Undecided
Unassigned
Intrepid
Wishlist
Soren Hansen

Bug Description

Binary package hint: virt-manager

Clicking Help -> About gives application name of 'virt-manager.py' rather than Virtual Machine Manager, as used in its menu entry and documentation.

Kees Cook (kees) on 2008-04-07
Changed in virt-manager:
importance: Undecided → Wishlist
status: New → Confirmed
Mike MacCana (lovekudu) wrote :

This error is marked 'wishlist'. Please correct.

A fix is provided below. The problem comes about due GtkAboutDialog "name" property being deprecated - see http://bugzilla.gnome.org/show_bug.cgi?id=496689

The fix is to modify line 9 of /usr/share/virt-manager/vmm-about.glade from the deprecated:
   <property name="name" translatable="yes">Virtual Machine Manager</property>
to:
   <property name="program-name" translatable="yes">Virtual Machine Manager</property>

Please remove the incorrect wishlist tag and apply the fix above.

Soren Hansen (soren) wrote :

I'm not sure what is "incorrect" about the bug being marked wishlist?

At any rate, I've fixed this locally, it'll be in the next upload.

Changed in virt-manager:
status: Confirmed → Fix Committed
  • unnamed Edit (1.1 KiB, text/html; charset=ISO-8859-1)

Thanks.

Wishlist, as I understand it, means an improvement that's not a bug fix -
this was clearly a fix.

On Thu, Apr 24, 2008 at 8:05 PM, Soren Hansen <email address hidden> wrote:

> I'm not sure what is "incorrect" about the bug being marked wishlist?
>
> At any rate, I've fixed this locally, it'll be in the next upload.
>
> ** Changed in: virt-manager (Ubuntu)
> Status: Confirmed => Fix Committed
>
> --
> Help -> About gives application name of 'virt-manager.py' rather than
> Virtual Machine Manager
> https://bugs.launchpad.net/bugs/206891
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Soren Hansen (soren) wrote :

Included in SRU 0.5.3-0ubuntu10

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in virt-manager:
status: New → Fix Committed

Test for hardy-proposed passed.

Testing with virt-manager version 0.5.3-0ubuntu9, clicking Help->About shows 'virt-manager.py'

Testing with virt-manager version 0.5.3-0ubuntu10 from hardy-proposed, clicking Help->About shows "Virtual Machine Manager"

Martin Pitt (pitti) wrote :

Copied to hardy-updates. Please upload to intrepid ASAP.

Changed in virt-manager:
status: Fix Committed → Fix Released
assignee: nobody → soren
Dustin Kirkland  (kirkland) wrote :

Tested in Intrepid, fixed.

:-Dustin

Changed in virt-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.