Ubuntu

kvm does not ungrab mouse

Reported by Adam Klobukowski on 2008-02-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Low
Adam Klobukowski

Bug Description

Binary package hint: virt-manager

Whet I'm running a virtual machine in virt-manager, and the mouse is grabbed, if a window (of another app) pops up, the maouse stays grabbed in virtual-machine, but I can't ungrab it, because keyboard input goes to new window. I have to switch to console, kill the app of new window, ant then I can ungrab mouse.

virt-manager should do ungrab in a case it is not topmost window.

Soren Hansen (soren) wrote :

Another good reason why everyone should have focus follow mouse :)

Ungrab in case it's not the topmost window is not the right solution. Lots and lots of folks are using focus-follows-mouse, and in that case, it's just plain wrong.

virt-manager should probably notice if it loses focus (for whatever reason) and release the grab if that happens.

Changed in virt-manager:
importance: Undecided → Low
Jamin W. Collins (jcollins) wrote :

I'm seeing a very similar problem. The mouse pointer within a VM will become stuck. If I move the mouse far enough so that actual OS pointer leaves the VM window, I get the OS pointer but it is effectively useless. It can not click on anything, nor does application focus follow the mouse as it normally does (and is configured to).

I'm not entirely certain of the cause, but have noticed that it consistently happens if the mouse is in a VM console (display through virt-manager's interface) and another application takes focus or the screen saver activates.

Jamin W. Collins (jcollins) wrote :

Should probably also be noted that this problem has not yet occurred when viewing the VM's display through a normal VNC client (using a KVM provided VNC display, not a VNC server running in the guest OS).

Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting this issue.
Do you still have it?
Are you able to reproduce this with a recent version of Ubuntu, such as Karmic or Lucid?

Changed in virt-manager (Ubuntu):
assignee: nobody → Adam Klobukowski (adamklobukowski)
status: New → Incomplete
Marc Deslauriers (mdeslaur) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to 'New'. Thanks again!

Changed in virt-manager (Ubuntu):
status: Incomplete → Invalid
Fyodor Kupchik (ferimy) wrote :

please do not close this bug since it is not fixed
what information do you need exactly?

Changed in virt-manager (Ubuntu):
status: Invalid → New
Fyodor Kupchik (ferimy) wrote :

ok, I'm using Natty x64
libvirt-bin 0.8.8-1ubuntu6
virt-manager 0.8.6-1ubuntu8
virtinst 0.500.5-1ubuntu4

guest OS is windows server 2008 R2 x64
host system is Natty x64

please tell me what info would be useful to find the solution

thanks.

Changed in virt-manager (Ubuntu):
status: New → Confirmed
Serge Hallyn (serge-hallyn) wrote :

@Fyodor,

which window manager are you using? How exactly are you trying to ungrab the mouse, using control-alt? What sort of window pops up? Would doing 'sleep 1m; xterm &' in another terminal, then letting the VM window take the mouse suffice?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers