18.04: virt-image no longer included

Bug #1784424 reported by TJ on 2018-07-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Low
Unassigned

Bug Description

Package description claims virt-image is included but it no longer is.

$ apt-file list virtinst | grep image | wc -l
0

$ apt-cache show virtinst
Package: virtinst
Architecture: all
Version: 1:1.5.1-0ubuntu1
Priority: extra
Section: universe/admin
Source: virt-manager
Origin: Ubuntu
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Debian Libvirt Maintainers <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 826
Depends: python2.7, python:any (>= 2.7.5-5~), python-libvirt (>= 0.4.6), python-gi, python-ipaddr, python-libxml2, python-requests, gir1.2-libosinfo-1.0, genisoimage
Recommends: virt-viewer, qemu-utils
Filename: pool/universe/v/virt-manager/virtinst_1.5.1-0ubuntu1_all.deb
Size: 177772
MD5sum: c4956ce8275bf5dda2ad6ab18465fea8
SHA1: c6933142bd3850ef05d90d4929c3482961c1f415
SHA256: d5eb163f080e33278c8907b124217311519632e84d831c8112cbb041e3827f91
Homepage: http://virt-manager.org/
Description-en_GB: Programs to create and clone virtual machines
 Virtinst is a set of commandline tools to create virtual machines using
 libvirt:
 .
 virt-install: provision new virtual machines virt-clone: clone existing
 virtual machines virt-image: create virtual machines from an image
 description virt-convert: convert virtual machines between formats
Description-md5: c31098728b9b7faac6968bd65393f582

affects: virtinst (Ubuntu) → virt-manager (Ubuntu)
tags: added: bionic

Confirmed, but the sev is really low IMHO.
Thanks for the report thou - those things are missed too easily and for too long.

Changed in virt-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

This affects Debian as well and we should not take Delta for such a low prio issue.
I've created a PR for them to take which once merged will be picked up automatically on the next Ubuntu Release.

=> https://salsa.debian.org/libvirt-team/virt-manager/merge_requests/1

Unfortunately those can't be remote-tracked in LP yet :-/

FYI: This is in the 2.0 version that recently appeared in Debian and will be fixed by the next merge

Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package virt-manager - 1:2.0.0-3ubuntu1

---------------
virt-manager (1:2.0.0-3ubuntu1) disco; urgency=medium

  * Merge with Debian unstable (LP: #1784424). Remaining changes:
    - Depend on gir1.2-appindicator3-0.1 for appindicator support.
    - d/p/mark-libvirt-lxc: Clearly mark the LXC connections as being
      libvirt-lxc, to avoid confusion due to differing features and
      configurations.
    - d/p/add_qemu_binaries.patch: add the actual binary name from the qemu
      packages so default hypervisor detection works properly on first run.
    - d/p/prefer-qemu.patch: Prefer QEMU as the default URI, even if it's
      not installed.
  * Dropped changes:
    - d/control: virtinst needs isoinfo to introspect images. To fix that
      add a dependency to genisoimage to virtinst (LP: 1763609)
      [accepted in Debian]
    - Merge with latest upstream stable release (LP: 1763618):
      - Fixes potential crash with libxml2 error callbacks
      - Fixes disk/net/mem VM graphs
      [part of upstream 2.0.0 release]
    - d/p/lp-1794315-connection-avoid-failing-on-NoneType.patch: fix a race
      (worse on slow remote connections) that would break connecting to a
      remote (LP: 1794315)
      [accepted upstream]
    - d/p/lp-1796932-tests-osdict-fix-ordering-issue-with-new-osinfo.patch:
      fix FTBFS due to self-tests failing with new osinfo (LP: 1796932)
      [accepted upstream]
    - d/p/virtinst/9006_fix_path_to_qemu-dm.patch: drop the full path from
      qemu-dm as already done for hvmloader and pygrub. The Xen tools will
      handle this and add the missing path.
      [no more needed as pygrub and hvmloader aren't hardcoded anymore]
    - d/rules: Set qemu user to libvirt-qemu so appropriate permissions get set.
      [now fetched as libvirt capability]
    - Add lsb-release to Build-Depends so we can detect whether we're running
      on Ubuntu or Debian.
      [no more needed]
    - d/rules: Set the preferred distro so we appear first in the list.
      [upstream dropped the option to prefer, due to the search based OS list]

virt-manager (1:2.0.0-3) unstable; urgency=medium

  * Mark autopkgtest scripts executable
  * d/control: Depend on python3-distutils.
    (Closes: #919527, #919713)

virt-manager (1:2.0.0-2) unstable; urgency=medium

  * Disable internal test suite.
    The tests pass in pbuilder but not on the buildds. Let's disable it until
    one has time to investigate. (Closes: #918557)

virt-manager (1:2.0.0-1) unstable; urgency=medium

  * New upstream version 2.0.0 (Closes: #916904)
  * Builds here without testsuit failures (Closes: #917673)
  * Rediff patches.
    Drop Xen related patches synce pygrub and hvmloader aren't hardcoded
    anymore.
  * Switch to python3
  * Don't ship gconf conversion anymore.
    We've done so for two releases.
  * virtinst: We don't ship virt-image anymore (Closes: #883789)
  * Depend on genisoimage.
    Thanks to Christian Ehrhardt (Closes: #895594)

virt-manager (1:1.5.1-1) unstable; urgency=medium

  * Depend on e2fsprogs (Closes: #887285)
  * New upstream version 1.5.1
  * Rediff patches
  * d/control: Switch URLs to salsa
  * d/rules: Honor DEB_...

Read more...

Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers