virt-manager: Light grey menu items on light grey background are barely readable

Bug #1758841 reported by Jean-Baptiste Lallement on 2018-03-26
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-themes (Ubuntu)
Medium
Marco Trevisan (Treviño)
Nominated for Bionic by Marco Trevisan (Treviño)
Bionic
Undecided
Unassigned
virt-manager (Ubuntu)
Low
Unassigned
Nominated for Bionic by Marco Trevisan (Treviño)

Bug Description

[ Impact ]

With latest update of ubuntu-theme (16.10+18.04.20180322.3-0ubuntu1) menu items in the toolbar are barely readable (cf screenshot)
Background should be dark. virt-manager is the only application I found with this issue so far.

[ Test case ]

1. Open virt-manager
2. Run a virtual machine
3. Click on the toolbar menu that can be opened from the power button
4. The items should be readable and have proper color

[ Regression potential ]

Menu items could not be visible in other dark menus

---

ProblemType: BugDistroRelease: Ubuntu 18.04
Package: virt-manager 1:1.5.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Mar 26 09:50:17 2018
InstallationDate: Installed on 2014-07-15 (1349 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
PackageArchitecture: allSourcePackage: virt-manager
UpgradeStatus: Upgraded to bionic on 2018-03-24 (1 days ago)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
summary: - Grey menu items on grey background are barely readable
+ Light grey menu items on light grey background are barely readable
tags: added: visual-quality
summary: - Light grey menu items on light grey background are barely readable
+ virt-manager: Light grey menu items on light grey background are barely
+ readable
Daniel van Vugt (vanvugt) wrote :

Setting to Medium. I think only virt-manager is affected.

GTK2 combos in other apps are correctly showing as dark grey menus with light text. And GTK3 combos in other apps are correctly showing as light grey menus with dark text.

This problem seems to be confined to virt-manager so far.

tags: added: regression
Changed in ubuntu-themes:
importance: Undecided → Medium
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Medium
Changed in virt-manager (Ubuntu):
importance: Undecided → Medium

I (for virt-manager) are not GTKxperienced enough to even know what to try :-/
If I understand you correctly it is picking up the change to the font color but not the background color - is that right?

virt-manager mostly uses gir from "Source: gtk+3.0" for display.
But that should be working.

If there are experienced desktop tips what should be tried please let me know.

At least I can confirm the issue with a KVM install of http://cdimage.ubuntu.com/daily-live/current/bionic-desktop-amd64.iso

Tried virt-manager in there, and see the reported readbility issue.

But I installed gnome-tweaks and ALL themes except ambience work juts fine.
So the default of Adwaita, good, any as I said all else good.

For I'd much more consider it an issue in the latest "Ambience" Theme than virt-manager.
It might use a more uncommon thing, but since all others work it should be the theme right?

Changed in virt-manager (Ubuntu):
status: New → Confirmed
importance: Medium → Low

Setting virt-manager low, until we have a reason to assume that a fix it would be better than a fix in the Theme (that would also fix anything else that is affected).

This is too deep in /usr/share/themes/Ambiance for me to spot all the right and wrong entries.

And sorry, the theme I meant obviously is Ambiance (with an a).

Since this is part of ubuntu-themes and a task already is filed against that we can wait for the Desktop/Theme folks to comment.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Changed in ubuntu-themes:
status: New → Confirmed
tags: added: triage
Changed in virt-manager (Ubuntu):
status: Confirmed → Invalid
no longer affects: ubuntu-themes
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in virt-manager (Ubuntu):
status: Invalid → Won't Fix
status: Won't Fix → Invalid
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+18.10.20181005-0ubuntu1

---------------
ubuntu-themes (16.10+18.10.20181005-0ubuntu1) cosmic; urgency=medium

  [ Khurshid Alam ]
  * Remove nonexistent gnome-builder.css (LP: #1773045)

  [ Marco Trevisan (Treviño) ]
  * Radiance: fix typo in assets link for focused buttons (LP: #1781736)
  * Radiance: Use scaled image for buttons border (LP: #1781736)
  * Ambiance, Radiance: don't use padding on window buttons for chromium
    (LP: #1782038)
  * Ambiance: use default foreground color for toolbar menus (LP:
    #1758841)
  * Ambiance, Radiance: show proper arrow in combobox (LP: #1743373)
  * Ambiance, Radiance: use default disabled color for actions headerbar
    buttons (LP: #1785699)
  * Ambiace, Radiance: use headerbar destructive-action definition for
    buttons
  * Ambiance, Radiance: fix list selected color for gnome-boxes (LP:
    #1761684)
  * Ambiance, Radiance: properly theme disabled and hovered accelerators
    (LP: #1795895)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 05 Oct 2018 00:13:07 +0000

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Released

Hello Jean-Baptiste, or anyone else affected,

Accepted ubuntu-themes into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-themes/16.10+18.04.20181005-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-themes (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Pedro Côrte-Real (pedrocr) wrote :

I tested this package:

$ sha1sum light-themes_16.10+18.04.20181005-0ubuntu1_all.deb
d05d75088b41c7594bf3e4e32879d8950983caec light-themes_16.10+18.04.20181005-0ubuntu1_all.deb

And the bug is indeed fixed for me in virt-manager.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers