Dependency to gir1.2-spice-client-gtk-3.0 needs to update

Bug #1741861 reported by Christian Ehrhardt  on 2018-01-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
High
Unassigned

Bug Description

Xenial: gir1.2-spice-client-gtk-3.0 (so the original report here likely is a different thing)
Artful: gir1.2-spice-client-gtk-3.0
Bionic: gir1.2-spice-client-gtk-3.0 & gir1.2-spiceclientgtk-3.0

The first of it is virtual.

The reason in Bionic is that spice-gtk is synced from Debian already, but virt-manager needs a merge that waits for libvirt & qemu to be complete before that.

Spotted by debugging for 1613264

This shall be fixed by the next merge of virt-manager.
We should have no custom depends for spice and make sure on the merge that the new dependencies are correct again.

Tagging it up that way.

tags: added: virt-manager-18.04

Until the merge happened solved as workaround by
 $ sudo apt install gir1.2-spiceclientgtk-3.0

Changed in virt-manager (Ubuntu):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package virt-manager - 1:1.5.0-0ubuntu1

---------------
virt-manager (1:1.5.0-0ubuntu1) bionic; urgency=medium

  * Merge with Debian unstable 1:1.4.3-1 (LP: #1747907 LP: #1741861)
    and latest upstream 1.5.0 (Closes: #888133); Remaining changes:
    - Depend on gir1.2-appindicator3-0.1 for appindicator support.
    - Add lsb-release to Build-Depends so we can detect whether we're running
      on Ubuntu or Debian.
    - d/rules: Set the preferred distro so we appear first in the list.
    - d/rules: Set qemu user to libvirt-qemu so appropriate permissions get set.
    - d/p/virtinst/9006_fix_path_to_qemu-dm.patch: drop the full path from
      qemu-dm as already done for hvmloader and pygrub. The Xen tools will
      handle this and add the missing path.
    - d/p/mark-libvirt-lxc: Clearly mark the LXC connections as being
      libvirt-lxc, to avoid confusion due to differing features and
      configurations.
    - d/p/add_qemu_binaries.patch: add the actual binary name from the qemu
      packages so default hypervisor detection works properly on first run.
    - d/p/prefer-qemu.patch: Prefer QEMU as the default URI, even if it's
      not installed.
  * Dropped changes (upstream)
    - d/p/use_qxl_for_ubuntu.patch: use qxl by default for Ubuntu VMs, it
      seems to work better than vmvga now.
    - Fix virt-install so that it can install 16.04 and newer images.
      Error message is 'Couldn't find hvm kernel for Ubuntu tree
      Closes (LP 1634304)
    - d/p/virt-manager-generates-invalid-guest-XML.patch: fix generation of
      invalid xml when a spapr-vio SCSI model controller is changed to a
      virtio-scsi model controller (LP 1649520).
    - Fix window size issues under Wayland
    - d/p/virtinst-adjust-media-paths-for-s390x.patch: fix virtinst on
      s390x (LP 1713990)
  * Added Changes:
    - refresh d/p/mark-libvirt-lxc.patch to match 1.4.3

virt-manager (1:1.4.3-1) unstable; urgency=medium

  * Depend on gir1.2-spiceclientglib-2.0 (Closes: #873597)
  * Update homepage URL (Closes: #874036)
  * README.Debian: fix libvirt reference (Closes: #877868)
  * New upstream version 1.4.3
  * Drop patches c-p'ed from upstream
    virtinst-adjust-media-paths-for-s390x.patch
    Drop virtinst-connection-Fix-error-caching-new-pool.patch
  * Bump standards version

virt-manager (1:1.4.2-1) unstable; urgency=medium

  * [194c3e4] New upstream version 1.4.2
  * [4ce9023] Rediff patches
  * [be8dfed] Cherry-pick some ustream patches.
      Add virtinst-connection-Fix-error-caching-new-pool.patch
      Add virtinst-adjust-media-paths-for-s390x.patch (Closes: #873714)
  * [8b6eb23] Re-enable Italian translation.
    This reverts commit 0d743f25dcde50e043b1d4d8a7606125873a5911.
  * [d4a2240] Adjust pygrub path in tests too
  * [f643d51] Run test during build

virt-manager (1:1.4.1-1) unstable; urgency=medium

  * [2f34677] Drop obsolete gnome-icon-theme recommends (Closes: #869685)
  * [4d6092c] Update uscan URL
  * [2c530bc] New upstream version 1.4.1
  * [6d547b1] Drop patches, fixed upstream:
      Mark-Jessie-as-having-qemu-guest-agent.patch
      domain-add-support-to-rename-domain-with-nvram-vars-file.patch...

Read more...

Changed in virt-manager (Ubuntu):
status: Triaged → Fix Released
TJ (tj) wrote :

This is still a problem on 18.04.

tj  /  tmp  apt list virt-* --installed
Listing... Done
virt-manager/bionic,bionic,now 1:1.5.0-0ubuntu1 all [installed]
virt-viewer/bionic,now 6.0-2 amd64 [installed,automatic]
 tj  /  tmp  apt list *spice* --installed
Listing... Done
libspice-client-glib-2.0-8/bionic,now 0.34-1.1build1 amd64 [installed,automatic]
libspice-client-gtk-3.0-5/bionic,now 0.34-1.1build1 amd64 [installed,automatic]
libspice-server1/bionic,now 0.14.0-1ubuntu2 amd64 [installed]
spice-client-glib-usb-acl-helper/bionic,now 0.34-1.1build1 amd64 [installed,automatic]
spice-client-gtk/bionic,now 0.34-1.1build1 amd64 [installed]
spice-vdagent/bionic,now 0.17.0-1ubuntu2 amd64 [installed,automatic]

I suspect because the packages are Recommends: not Depends:

  Recommends: gir1.2-spiceclientglib-2.0
  Recommends: gir1.2-spiceclientgtk-3.0

so if --no-install-recommends is used or is set as the default those packages won't be installed.

Changelog says these are Depends.

Changed in virt-manager (Ubuntu):
status: Fix Released → Confirmed
TJ (tj) wrote :

It turns out when using:

apt-get install --reinstall --install-recommends virt-manager

the --install-recommends is ignored!

Reporting this as a possible bug in apt.

Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released

It is only a recommends in Debian intentionally, and a recommends is the correct dependency.
It can work without it, and adding it enhances the functionality [1].

root@b2:~# apt install virt-manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
[...]
 gir1.2-spiceclientglib-2.0 gir1.2-spiceclientgtk-3.0
Suggested packages:
[...]
The following NEW packages will be installed:
[...]
  gir1.2-pango-1.0 gir1.2-spiceclientglib-2.0 gir1.2-spiceclientgtk-3.0
[...]
0 upgraded, 236 newly installed, 0 to remove and 0 not upgraded.
Need to get 51.4 MB of archives.
After this operation, 226 MB of additional disk space will be used.
Do you want to continue? [Y/n]

AFAIK: --install-recommends is the default, maybe it does not work together with --reinstall?
This is [2] IMHO - might be a feature bug for apt to discuss there if it is really wanted/needed.

[1]: https://www.debian.org/doc/debian-policy/#binary-dependencies-depends-recommends-suggests-enhances-pre-depends
[2]: https://askubuntu.com/questions/409573/apt-get-install-reinstall-install-recommends-not-installing-a-recommended-pa

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments