Merge 1:1.4.0-5 from Debian unstable to zesty

Bug #1667114 reported by Bryan Quigley on 2017-02-22
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Undecided
Unassigned

Bug Description

A new major release of virt-manager has been released and is in debian unstable/testing.

I'll go through all the Ubuntu changes to confirm what's still needed.

Still to check:
  * Merge from Debian. Remaining changes: (LP: #1556671)
    - debian/control:
        + Add lsb-release to Build-Depends so we can detect whether we're running on Ubuntu or Debian.
    - debian/rules:
        + Set qemu user to libvirt-qemu so appropriate permissions get set.
        + Set the preferred distro so we appear first in the list.
    - d/p/virtinst/9006_fix_path_to_qemu-dm.patch: drop the full path from qemu-dm as already done for hvmloader and pygrub. The Xen tools will handle this and add the missing path.
    - d/p/add_qemu_binaries.patch: add the actual binary name from the qemu packages so default hypervisor detection works properly on first run.

In-progress investigation:
        + Depend on gir1.2-appindicator3-0.1 for appindicator support. - AFAICT I have fine "systray" support in Lxde with the stock Debian package

Just landed upstream (not in 1.4.0 release):
    - d/p/use_qxl_for_ubuntu.patch: use qxl by default for Ubuntu VMs, it seems to work better than vmvga now. Laneded - https://github.com/virt-manager/virt-manager/pull/23

No Longer Needed
* debian/patches/0001-details-Fix-screenshot-on-F24-rawhide-bz-1297988.patch:
    Cherry-pick from upstream. Fix screenshot capture with newer
    gdk-pixbuf/pygobject. (LP: #1571702) - Upstream

 Fix virt-install so that it can install 16.04 and newer images.
    Error message is 'Couldn't find hvm kernel for Ubuntu tree
    Closes (LP: #1634304) - urlfetcher_Fix_ubuntu_location.patch - upsteam

  * debian/patches/use_virtio_for_pseries_disks.patch: virtinst: Use
    virtio bus type for disks on pSeries machines. Closes LP: #1597610. Upstream

    - d/p/virtinst/dont_disable_vmport.patch: Don't disable vmport even if we're using spice, as this prevents having a seamless mouse when using Ubuntu as a guest. - I have seamless mouse integration without this.

Drop these patches:
- d/p/mark-libvirt-lxc: Clearly mark the LXC connections as being
      libvirt-lxc, to avoid confusion due to differing features and
      configurations.
*Not sure if still needed, doesn't understand what this is avoiding confusion for. Leaning to not needed.

 - d/p/prefer-qemu.patch: Prefer QEMU as the default URI, even if it's not installed.
* The defaults look fine to me, if someone is installing Xen I'm guessing they are likely to actually want it.

- d/p/use_ubuntu_package_names.patch: Suggest installing the packages that are actually available in Ubuntu.
* Most users don't actually want qemu-system, defaults are likely fine

- d/p/more_helpful_error_message.patch: explain to the user why
      connecting to qemu:///system failed and how to fix it. Agree with comment #10.

- d/p/leave-mnemonics-alone-on-focus-change.patch: Leave
      gtk-enable-mnemonics setting alone under Unity when windows change focus. Still needed on unity - no point in upstreaming at this point, let's drop it.

No longer needed (points)
+ Remove data/gschemas.compiled generated by clean. - Done in Debian virt-manager (1:1.3.2-4)
+ Change Recommends to libvirt-bin instead of libvirt-daemon-system which isn't available in Ubuntu. This package is in Ubuntu in 16.04+

Changed in virt-manager (Ubuntu):
assignee: nobody → Bryan Quigley (bryanquigley)
status: New → In Progress
Bryan Quigley (bryanquigley) wrote :

This is blocked by the lack of an apparmor rule in libvirt - described here - https://askubuntu.com/questions/833964/virt-manager-cant-connect-to-graphical-console/853381

Bryan Quigley (bryanquigley) wrote :

Feb 27 14:59:02 desktop libvirtd[990]: internal error: unable to execute QEMU command 'getfd': No file descriptor supplied via SCM_RIGHTS
Feb 27 14:59:02 desktop kernel: audit: type=1400 audit(1488225542.495:888): apparmor="DENIED" operation="file_receive" profile="libvirt-3371aa28-80bc-4268-84a5-2cefb074f5a6" pid=1498 comm="qemu-system-x86" family="unix" sock_type="stream" protocol=0 requested_mask="send receive" denied_mask="send receive" addr=none peer_addr=none peer="/usr/sbin/libvirtd"

Trying to determine if it needs an upstream or Ubuntu specific fix.

Bryan Quigley (bryanquigley) wrote :

Opened bug 1668681 to track the libvirt apparmor issue.

description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Amr Ibrahim (amribrahim1987) wrote :

Ping!

Bryan Quigley (bryanquigley) wrote :

@amribrahim1987
I haven't had as much time to invest in this as originally planned. Also, need to make a decision about dropping Unity specific patches..

ChristianEhrhardt (paelzer) wrote :

Hi Brian,
thanks for working on this!
I wanted to mention two things to be documented in this context as well:

1. the libvirt bug blocking you is resolved a while ago, but I'm sure you've seen it but were just busy.

2. For bug 1694159 I was essentially "dropping old delta". We formerly had a change that said "Change Recommends to libvirt-bin instead of libvirt-daemon-system" in Remaining Changes.
I'd ask you to mind that on your merge and integrate (=drop) it accordingly on the merge.

I'll attach the related diff's here as FYI for you to consider on the merge.

ChristianEhrhardt (paelzer) wrote :

Also I read through your check of droppable changes in the bug description and agree.
I'd even consider "d/p/more_helpful_error_message.patch" droppable as it is a maintenance burden with only low gain.
While not the package names are nice, it is a dependency of virt-manager, so there should be no way to not be installed.
Also the original text being "Verify that the 'libvirtd' daemon is running." is kind of more correct these days as "systemctl status libvirtd" will work.
So if you agree drop that as well.

I can't help you deciding on the Unity specific patches, but the (no) future of that is more clear now - so maybe you can decide now.

ChristianEhrhardt (paelzer) wrote :

Also there are more messages just stating "libvirtd" like the one when connecting to qemu on remote host which is not updated - one more argument to drop that.

tags: added: patch
description: updated
ChristianEhrhardt (paelzer) wrote :

Any updates on this one - this came up in regard to bug 1683747 and we are running short for a merge - so now or newer - which is why I wanted to ask for your status on this.

Bryan Quigley (bryanquigley) wrote :

I haven't had time, will reassign if I can dedicate some more to it.

Changed in virt-manager (Ubuntu):
assignee: Bryan Quigley (bryanquigley) → nobody
status: In Progress → Confirmed
Juerg Haefliger (juergh) wrote :

I can offer to do some testing if somebody provides an updated package.

ChristianEhrhardt (paelzer) wrote :

Hi Jürg,
there is a version of the merge to test available in [1] if you could give it a look (might be still building for some minutes, but I hope it is there later).

https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/2895

Bryan Quigley (bryanquigley) wrote :

Thanks Christian!
PPA works great in my testing so far. Also tested with libvirt from -proposed.

Juerg Haefliger (juergh) wrote :

Every-day usage on Artful is successful so far. And I can confirm that Fedora VMs can now be built properly (i.e. #1683747 is fixed).

ChristianEhrhardt (paelzer) wrote :

Yeah my basic usage test was ok as well.
Furter I sniffed the dep8 tests which were good as well.
Finally today Robie did the formal review and tagged my branch for import.
All checks complete, uploading now via sync from the bileto ticket.

Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package virt-manager - 1:1.4.0-5ubuntu1

---------------
virt-manager (1:1.4.0-5ubuntu1) artful; urgency=medium

  * Merge with Debian unstable (LP: #1667114 LP: #1683747). Remaining changes:
    - Depend on gir1.2-appindicator3-0.1 for appindicator support.
    - Add lsb-release to Build-Depends so we can detect whether we're running
      on Ubuntu or Debian.
    - d/rules: Set the preferred distro so we appear first in the list.
    - d/rules: Set qemu user to libvirt-qemu so appropriate permissions get set.
    - d/p/virtinst/9006_fix_path_to_qemu-dm.patch: drop the full path from
      qemu-dm as already done for hvmloader and pygrub. The Xen tools will
      handle this and add the missing path.
    - d/p/mark-libvirt-lxc: Clearly mark the LXC connections as being
      libvirt-lxc, to avoid confusion due to differing features and
      configurations.
    - d/p/add_qemu_binaries.patch: add the actual binary name from the qemu
      packages so default hypervisor detection works properly on first run.
    - d/p/use_qxl_for_ubuntu.patch: use qxl by default for Ubuntu VMs, it
      seems to work better than vmvga now.
    - d/p/prefer-qemu.patch: Prefer QEMU as the default URI, even if it's
      not installed.
    - Fix virt-install so that it can install 16.04 and newer images.
      Error message is 'Couldn't find hvm kernel for Ubuntu tree
      Closes (LP 1634304)
  * Dropped changes:
    - d/rules: Remove data/gschemas.compiled generated by clean (in Debian).
    - d/p/0001-details-Fix-screenshot-on-F24-rawhide-bz-1297988.patch:
      Cherry-pick from upstream. Fix screenshot capture with newer
      gdk-pixbuf/pygobject. (LP 1571702) (now Upstream)
    - d/p/use_virtio_for_pseries_disks.patch: virtinst: Use virtio bus type for
      disks on pSeries machines. Closes LP 1597610. (now Upstream)
    - Change Recommends to libvirt-bin instead of libvirt-daemon-system
      which isn't available in Ubuntu (Debian and Ubuntu share names again).
    - With package names now matching delta would be wrong, calling kvm
      leads to the right suggestive apt install message. Remaining messages
      are considered good enough (or should be fixed upstream)
      - d/p/more_helpful_error_message.patch: explain to the user why
        connecting to qemu:///system failed and how to fix it.
      - d/p/use_ubuntu_package_names.patch: Suggest installing the packages
        that are actually available in Ubuntu.
    - d/p/virtinst/dont_disable_vmport.patch: Don't disable vmport even if
      we're using spice, as this prevents having a seamless mouse when
      using Ubuntu as a guest (Seamless mouse was reported ok without).
    - d/p/leave-mnemonics-alone-on-focus-change.patch: Leave
      gtk-enable-mnemonics setting alone under Unity when windows change
      focus (No Unity supporte anymore).
  * Added changes:
    - Refreshed patches to match new version:
      - d/p/mark-libvirt-lxc.patch
      - d/p/virtinst/use_qxl_for_ubuntu.patch
    - d/p/virt-manager-generates-invalid-guest-XML.patch: fix generation of
      invalid xml when a spapr-vio SCSI model controller is changed to a
      virtio-scsi model controller...

Read more...

Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers