Unable to complete install: 'Couldn't find hvm kernel for Ubuntu tree

Bug #1634304 reported by zeine77 on 2016-10-17
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Undecided
Tyler Hicks
Xenial
Undecided
Tyler Hicks
Yakkety
Undecided
Tyler Hicks
Zesty
Undecided
Tyler Hicks

Bug Description

[Impact]

 * Users are unable to virt-install using xenial and newer isos.

[Test Case]
 #!/bin/bash
sudo virt-install \
--connect qemu:///system \
--virt-type kvm \
--name labVM2 \
--disk size=10 \
--ram 2048 \
--vcpus=2 \
--graphics vnc \
-l /home/student19s/ubuntu-16.04.1-server-amd64.iso \
--os-variant ubuntu16.04

* Bad output
WARNING Graphics requested but DISPLAY is not set. Not running virt-viewer.
WARNING No console to launch for the guest, defaulting to --wait -1

Starting install...
Retrieving file version.info... | 58 B 00:00:00
ERROR Couldn't find hvm kernel for Ubuntu tree.
Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start labVM2
otherwise, please restart your installation.

* Expected output
Starting install...
Retrieving file version.info... | 58 B 00:00:00
Retrieving file linux... | 6.7 MB 00:00:00
Retrieving file initrd.gz... | 36 MB 00:00:00
Allocating 'labVM2-2.qcow2' | 10 GB 00:00:00
Creating domain... | 0 B 00:00:00
Domain installation still in progress. Waiting for installation to complete.

[Regression Potential]

 * Patch is accepted into upstream virt-install

 * I have run virt-install against both iso's and netinstall trees *(which previously worked and now continue to work).

[Other Info]

+++++++++++++++++++++++++ Original Description ++++++++++++++++++++++++
I am trying to create a new virtual machine with Virtual Machine Manager but keep receiving this error "Unable to complete install: 'Couldn't find hvm kernel for Ubuntu tree". The OS guest I am trying to install on the VM is Ubuntu server 14.04.4, 64 bit. The host OS (where the virtual manager is installed) is KUbuntu 16.04 .

Below is the full message that appears after completing the 5-steps VM creation process and clicking on finish on virt-manager:

Unable to complete install: 'Couldn't find hvm kernel for Ubuntu tree.'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 90, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 2277, in _do_async_install
    guest.start_install(meter=meter)
  File "/usr/share/virt-manager/virtinst/guest.py", line 482, in start_install
    self._prepare_install(meter, dry)
  File "/usr/share/virt-manager/virtinst/guest.py", line 303, in _prepare_install
    self.installer.prepare(self, meter)
  File "/usr/share/virt-manager/virtinst/installer.py", line 200, in prepare
    self._prepare(guest, meter)
  File "/usr/share/virt-manager/virtinst/distroinstaller.py", line 451, in _prepare
    self._prepare_kernel_url(guest, fetcher)
  File "/usr/share/virt-manager/virtinst/distroinstaller.py", line 360, in _prepare_kernel_url
    kernel, initrd, args = store.acquireKernel(guest)
  File "/usr/share/virt-manager/virtinst/urlfetcher.py", line 577, in acquireKernel
    {"distro": self.name, "type" : self.type})
RuntimeError: Couldn't find hvm kernel for Ubuntu tree.

And the package data are

$ dpkg -s virt-manager
Package: virt-manager
Status: install ok installed
Priority: optional
Section: admin
Installed-Size: 7285
Maintainer: Ubuntu Developers <email address hidden>
Architecture: all
Version: 1:1.3.2-3ubuntu1.16.04.2
Depends: dconf-gsettings-backend | gsettings-backend, python:any (>= 2.6.6-7~), python2.7:any, python-gi, python-gi-cairo, python-dbus, python-requests, librsvg2-common, python-libvirt (>= 0.7.1), gir1.2-appindicator3-0.1, gir1.2-libvirt-glib-1.0, gir1.2-gtk-vnc-2.0, gir1.2-gtk-3.0 (>= 3.10), gir1.2-vte-2.91, gir1.2-libosinfo-1.0, virtinst (>= 1:1.3.2-3ubuntu1.16.04.2), gconf2
Recommends: libvirt-bin (>= 1.2.7), gnome-icon-theme, gir1.2-spice-client-gtk-3.0
Suggests: virt-viewer, ssh-askpass, gnome-keyring, python-gnomekeyring, python-guestfs
Description: desktop application for managing virtual machines
 It presents a summary view of running domains and their live performance &
 resource utilization statistics. A detailed view presents graphs showing
 performance & utilization over time. Ultimately it will allow creation of new
 domains, and configuration & adjustment of a domain's resource allocation &
 virtual hardware. Finally an embedded VNC client viewer presents a full
 graphical console to the guest domain.
 .
 NOTE: the GUI is still considered experimental.
Homepage: http://virt-manager.et.redhat.com/
Original-Maintainer: Debian Libvirt Maintainers <email address hidden>

According to this discussion http://askubuntu.com/a/815056 on Askubuntu.com, it is matter of an issue with the installer (virt-install looking for i386 installer but should be looking for amd64 installer). The bug is reportedly fixed on upstream, but not available yet for the packages.

zeine77 (mohamed-eyil) on 2016-10-17
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virt-manager (Ubuntu):
status: New → Confirmed
Dave Chiluk (chiluk) wrote :

Definitely affects xenial. So here's the fix for that. Checking yakkety, and zesty now.

The attachment "lp1634304.xenial.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Dave Chiluk (chiluk) on 2016-11-29
Changed in virt-manager (Ubuntu):
assignee: nobody → Dave Chiluk (chiluk)
Dave Chiluk (chiluk) on 2016-11-29
description: updated
Dave Chiluk (chiluk) wrote :

This patch applies to both yakkety and zesty.

description: updated
Dave Chiluk (chiluk) wrote :

Fixed the yakkety debdiff. I apparently had accidently rebuilt the original sources at some point so the debdiff was against bad originals. Thanks for catching that sarnold.

Dave Chiluk (chiluk) wrote :

Tested trusty. Trusty not affected.

zeine77 (mohamed-eyil) wrote :

@chiluk: Is there a plan to deliver a fix soon to the package in Xenial?

Mattia Rizzolo (mapreri) wrote :

Note that first and foremost it has to be fixed in the current development release (zesty).

Dave Chiluk (chiluk) wrote :

It will be fixed as soon as I can get sponsorship for my debdiffs.

Changed in virt-manager (Ubuntu Xenial):
status: New → Confirmed
Changed in virt-manager (Ubuntu Yakkety):
status: New → Incomplete
status: Incomplete → Confirmed
Dave Chiluk (chiluk) wrote :

Updated changelog entry for debdiffs.

Dave Chiluk (chiluk) wrote :

Updated changelog, and renamed patch so it's obvious that this patch applies to be yakkety and zesty.

tags: added: sts sts-sru
Tyler Hicks (tyhicks) wrote :

I've uploaded to zesty, yakkety, and xenial. I only made one small change to the versioning of the yakkety/zesty debdiffs. Dave even asked me about the proper versioning before I had a chance to notice and we discussed versioning in #ubuntu-devel. In short, yakkety's version needed to be 1:1.3.2-3ubuntu3.1 and zesty's version needed to be 1:1.3.2-3ubuntu4.

I did have one question about the upstream patch and left a commit comment in github:

  https://github.com/virt-manager/virt-manager/commit/3f15a489cda87f8028828d567848193dd2640a43#commitcomment-20111744

I didn't feel like the open question for upstream should block the uploads. If needed, we can address the question later before Zesty releases.

Thanks for the clean debdiffs, Dave!

Changed in virt-manager (Ubuntu Xenial):
assignee: nobody → Tyler Hicks (tyhicks)
Changed in virt-manager (Ubuntu Yakkety):
assignee: nobody → Tyler Hicks (tyhicks)
Changed in virt-manager (Ubuntu Zesty):
assignee: Dave Chiluk (chiluk) → Tyler Hicks (tyhicks)
Changed in virt-manager (Ubuntu Xenial):
status: Confirmed → In Progress
Changed in virt-manager (Ubuntu Yakkety):
status: Confirmed → In Progress
Changed in virt-manager (Ubuntu Zesty):
status: Confirmed → In Progress
Tyler Hicks (tyhicks) on 2016-12-07
Changed in virt-manager (Ubuntu Xenial):
status: In Progress → Fix Committed
Changed in virt-manager (Ubuntu Yakkety):
status: In Progress → Fix Committed
Changed in virt-manager (Ubuntu Zesty):
status: In Progress → Fix Committed
no longer affects: virt-manager (Ubuntu Trusty)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 1:1.3.2-3ubuntu4

---------------
virt-manager (1:1.3.2-3ubuntu4) zesty; urgency=medium

  * Fix virt-install so that it can install 16.04 and newer images.
    Error message is 'Couldn't find hvm kernel for Ubuntu tree
    Closes (LP: #1634304)

 -- Dave Chiluk <email address hidden> Tue, 29 Nov 2016 12:52:23 -0600

Changed in virt-manager (Ubuntu Zesty):
status: Fix Committed → Fix Released
Dave Chiluk (chiluk) on 2016-12-13
tags: added: verification-done-zesty
Tyler Hicks (tyhicks) wrote :

Upstream responded to my question about the default architecture:

 https://github.com/virt-manager/virt-manager/commit/3f15a489cda87f8028828d567848193dd2640a43#commitcomment-20176018

The comment is wrong but, more importantly, the code is considered to be correct. There's no need to update this SRU or the Zesty upload to simply change the comment.

Hello zeine77, or anyone else affected,

Accepted virt-manager into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virt-manager/1:1.3.2-3ubuntu1.16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
zeine77 (mohamed-eyil) wrote :

Fixed in Xenial.
I just installed the package from xenial-proposed, the problem seems to be fixed. It brings Ubuntu Installer GUI and starts the installation process. I used the same host and guest as my original post (Ubuntu server 14.04.4 and KUbuntu 16.04.2 respectively).
Thanks guys :)

Dave Chiluk (chiluk) wrote :

@arges

Looks like the yakkety SRU has been forgotten.

tags: added: verification-done-xenial
removed: verification-needed
Brian Murray (brian-murray) wrote :

Hello zeine77, or anyone else affected,

Accepted virt-manager into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virt-manager/1:1.3.2-3ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Dave Chiluk (chiluk) on 2016-12-23
tags: added: verification-done-yakkety
removed: verification-needed
tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 1:1.3.2-3ubuntu3.1

---------------
virt-manager (1:1.3.2-3ubuntu3.1) yakkety; urgency=medium

  * Fix virt-install so that it can install 16.04 and newer images.
    Error message is 'Couldn't find hvm kernel for Ubuntu tree
    Closes (LP: #1634304)

 -- Dave Chiluk <email address hidden> Tue, 29 Nov 2016 12:52:23 -0600

Changed in virt-manager (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for virt-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 1:1.3.2-3ubuntu1.16.04.3

---------------
virt-manager (1:1.3.2-3ubuntu1.16.04.3) xenial; urgency=medium

  * Fix virt-install so that it can install 16.04 and newer images.
    Error message is 'Couldn't find hvm kernel for Ubuntu tree
    Closes (LP: #1634304)

 -- Dave Chiluk <email address hidden> Tue, 29 Nov 2016 12:52:23 -0600

Changed in virt-manager (Ubuntu Xenial):
status: Fix Committed → Fix Released
Louis Bouchard (louis) on 2017-03-22
tags: added: sts-sru-done
removed: sts-sru
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers