Virt-manager Spice console not working

Bug #1613264 reported by lastpokemon
68
This bug affects 15 people
Affects Status Importance Assigned to Milestone
virt-manager (Debian)
New
Undecided
Unassigned
virt-manager (Ubuntu)
Incomplete
Medium
Unassigned

Bug Description

Description of problem:

When starting Virt-Manager using spice I got error
"Virt-Manager Error Opening Spice console, SpiceClientGtk missing"

Although all the required packages are installed.

It works find on Ubuntu 14.04
But not on 16.04

Version-Release number of selected component (if applicable):

Working Ubuntu 14.04

$ uname -a
Linux nasho-OptiPlex-9010 3.19.0-66-generic #74~14.04.1-Ubuntu SMP Tue Jul 19 19:56:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
 $ sudo dpkg --get-selections |grep spice
[sudo] password for nasho:
libspice-client-glib-2.0-8:amd64 install
libspice-client-gtk-2.0-4:amd64 install
libspice-server1:amd64 install
python-spice-client-gtk install
spice-client-glib-usb-acl-helper install
spice-client-gtk install
spice-vdagent install

NON-Working ubuntu 16.04

 $ uname -a
Linux nasho-ThinkCentre-M900 4.4.0-34-generic #53-Ubuntu SMP Wed Jul 27 16:06:39 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$ sudo dpkg --get-selections |grep spice
libspice-client-glib-2.0-8:amd64 install
libspice-client-gtk-2.0-4:amd64 install
libspice-client-gtk-3.0-4:amd64 install
libspice-server1:amd64 install
python-spice-client-gtk install
spice-client-glib-usb-acl-helper install
spice-client-gtk install
spice-html5 install
spice-vdagent install

* note that I also installed libspice-client-gtk-3.0-4:amd64 but this didn't make any difference.

How reproducible:

Every time

Steps to Reproduce:
1. Installed from software channel
2. deployed a windows vm instaleld spice agents. works fine with vnc but not with spice
3. all the configuration are correct and replicating the working system 14.04

Actual results:

No display

Expected results:

display works as well as copy past and screen resize

Additional info:

NA

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: virt-manager 1:1.3.2-3ubuntu1.16.04.2
ProcVersionSignature: Ubuntu 4.4.0-34.53-generic 4.4.15
Uname: Linux 4.4.0-34-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Aug 15 13:00:45 2016
ExecutablePath: /usr/share/virt-manager/virt-manager
InstallationDate: Installed on 2016-08-12 (3 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_IE:en
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IE.UTF-8
 SHELL=/bin/bash
SourcePackage: virt-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
lastpokemon (lastpokemon) wrote :
Revision history for this message
David Harrigan (dharrigan) wrote :

Hi,

I got it working using this magic incantation:

apt install gir1.2-spice-client-gtk-3.0

Yes, it's still broken, but at least you perhaps get stuff done.

Hope that helps!

-=david=-

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virt-manager (Ubuntu):
status: New → Confirmed
Changed in virt-manager (Ubuntu):
importance: Undecided → Low
importance: Low → Medium
Revision history for this message
Scarabol (scarabol) wrote :

Same issue here. https://bugs.launchpad.net/ubuntu/+source/virt-manager/+bug/1613264/comments/2 fixed it, thanks!

What needs to be done to fix this packaging?

Revision history for this message
Serge Victor (ser) wrote :

bug persists on 17.04

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Hi,
thanks for the ping I didn't see the bug before.
For me things worked right out of the box, but I could reproduce by uninstalling the gir1 package that was mentioned before.
Therefore I can somewhat confirm the issue but IMHO it is not that much a bug, let me explain why.

I went back and checked why it worked for me out of the box and the package was installed at first and it was driven by correct dependencies.

$ aptitude why gir1.2-spice-client-gtk-3.0 --show-summary
Packages requiring gir1.2-spice-client-gtk-3.0:
  virt-manager

So the packaging already has a valid dependency to make this work.
Since many or rather most common virt-manager tasks work I think "recommends" is the right dependency in general.

We would need to check why you had it not installed, as by default recommends are installed.
Maybe you had the packages from the image which can leave out some recommends to keep image size down?

Therefore I wanted to ask how you installed virt-manager?
- was it without recommends intentionally then this is not really a bug
- did it come from other dependencies, images, ... and missed to install the recommends than we should understand and solve that.

Setting incomplete until we know how you got virt-manager without the recommended gir1 package.

Changed in virt-manager (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Mattia (io-mattia98) wrote :

I had this problem too. Basically, I followed the guide on https://help.ubuntu.com/community/KVM/VirtManager and ran the command `sudo apt-get install virt-manager ssh-askpass-gnome --no-install-recommends`. I think OP followed the same guide and therefore bumped into this issue. This is therefore not a bug as this package is not essential for this application to run but rather a very useful add-on. With a quick google you immediately find out what to do if you want this functionality. The wiki page might need an update.

Revision history for this message
Peter Horvath (peterhorvath) wrote :

I experience exactly the same problem.

I didn't committed any doc.

I only installed qemu, and virt-manager, as usual.

* There is no reason for them to not work
* There is no reason for them to enforce a new screen-sharing protocol (spice or whatever) to me
* There is no reason for them to do this with bugs
* There is no reason for them to cause mystical error messages with these bugs
* And there is no reason for them to not fix these bugs years long.

Because I've faced the same problem many years ago.

I can't believe, I am really the only one trying to use virt-manager on debian, or...???

Revision history for this message
Lee Trager (ltrager) wrote :

I ran into this on Bionic but had to install the gir1.2-spiceclientgtk-3.0 package instead to fix it. For me apt locked trying to install virt-manager. While running dpkg --configure -a got virt-manager installed it seemed to of missed this dependency.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Hi Lee,
since virt-manager has:
  Recommends: libvirt-daemon-system (>= 1.2.7), gnome-icon-theme, gir1.2-spice-client-gtk-3.0

I just wanted to ask how you got into the case to not have it installed?
Same question already in comment #6

But then I found this:
Recommends: gir1.2-spice-client-gtk-3.0
But "Package gir1.2-spice-client-gtk-3.0 is not available, but is referred to by another package."
Instead what exists "gir1.2-spiceclientgtk-3.0"
Now please do mind the spaces.
  gir1.2-spice-client-gtk-3.0 vs gir1.2-spiceclientgtk-3.0

It seems the package existed once, but was renamed.
I need to do some checks what exactly changed when in the past and out of that we can derive fixes then.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Xenial: gir1.2-spice-client-gtk-3.0 (so the original report here likely is a different thing)
Artful: gir1.2-spice-client-gtk-3.0
Bionic: gir1.2-spice-client-gtk-3.0 & gir1.2-spiceclientgtk-3.0

The reason in Bionic is that spice-gtk is synced from Debian already, but virt-manager needs a merge that waits for libvirt & qemu to be complete before that.

Thanks Lee for the comment, this helped to spot a new issue in Bionic, I spawned bug 1741861 to cover that.

But for the pre-bionic cases discussed in this bug report here we are back at:
1. how/why have you installed it without the default recommends?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers