Please update to virt-manager 1.2.1 in Wily

Bug #1409309 reported by GizmoChicken on 2015-01-10
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
virt-manager (Debian)
Fix Released
Unknown
virt-manager (Ubuntu)
Medium
Marc Deslauriers

Bug Description

Please update to virt-manager 1.2.1 in Wily.

Upstream changelog https://git.fedorahosted.org/cgit/virt-manager.git/plain/NEWS

Thanks!

tags: added: upgrade-software-version
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virt-manager (Ubuntu):
status: New → Confirmed
tags: added: wily
summary: - Request: Please update to virt-manager 1.1.0 in Vivid
+ Please update to virt-manager 1.2.1 in Wily
description: updated
Changed in virt-manager (Ubuntu):
importance: Undecided → Medium
Changed in virt-manager (Debian):
status: Unknown → New
Changed in virt-manager (Debian):
status: New → Fix Released
tags: added: xenial
Changed in virt-manager (Ubuntu):
assignee: nobody → Marc Deslauriers (mdeslaur)
Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package virt-manager - 1:1.2.1-4ubuntu1

---------------
virt-manager (1:1.2.1-4ubuntu1) xenial; urgency=medium

  * Merge from Debian. Remaining changes: (LP: #1409309)
    - debian/control:
        + Depend on gir1.2-appindicator3-0.1 for appindicator support.
        + Add lsb-release to Build-Depends so we can detect whether we're
          running on Ubuntu or Debian.
        + Change Recommends to libvirt-bin instead of libvirt-daemon-system
          which isn't available in Ubuntu
        + Bump standards version to 3.9.6.
    - debian/rules:
        + Set qemu user to libvirt-qemu so appropriate permissions get set.
        + Set the preferred distro so we appear first in the list.
    - d/p/virtinst/9006_fix_path_to_qemu-dm.patch: drop the full path from
      qemu-dm as already done for hvmloader and pygrub. The Xen tools will
      handle this and add the missing path.
    - d/p/more_helpful_error_message.patch: explain to the user why
      connecting to qemu:///system failed and how to fix it.
    - d/p/use_ubuntu_package_names.patch: Suggest installing the packages
      that are actually available in Ubuntu.
    - d/p/leave-mnemonics-alone-on-focus-change.patch: Leave
      gtk-enable-mnemonics setting alone under Unity when windows change
      focus.
    - d/p/mark-libvirt-lxc: Clearly mark the LXC connections as being
      libvirt-lxc, to avoid confusion due to differing features and
      configurations.
    - d/p/add_qemu_binaries.patch: add the actual binary name from the qemu
      packages so default hypervisor detection works properly on first run.
    - d/p/Make-sure-we-use-a-binary-compatible-version-of-vte.patch: Use
      vte 2.91.
  * Dropped patches included upstream:
    - d/p/0001-serialcon-Drop-use-of-yet-more-removed-API.patch,
    - d/p/0001-serialcon-Remove-some-redundant-VTE-API-calls.patch: Cherry-
      pick two patches from upstream to stop using API removed in VTE 2.91.
    - d/p/dont-force-keyboard-grabs.patch: don't force keyboarb grab before
      widget is realized
    - d/p/prevent-access-to-deleted-objects.patch: prevent access to
      deleted objects
    - d/p/fix_changing_graphics_type.patch: fix changing the graphics type
      in the details dialog.
    - d/p/hook_into_domain_balloon_event.patch: properly hook into hotplug
      events so memory size gets updated.
    - d/p/fix_showing_vcpus.patch: display the right number of vcpus in the
      customize dialog.
    - d/p/fix_whitespace_in_storage_name.patch: Fix using storage when the
      directory name contains whitespace
    - d/p/add-support-for-ppc64le: cherrypick two patches to fix
      virt-install for ppc64le
    - d/p/fix-page-visibilities.patch: fix a page visibility issue
      resulting in stuck grabs.
  * Other dropped patches:
    - d/p/uefi_support.patch: upstream now has built in support.
    - d/p/virtinst/9004_ubuntu_fix_tree_support.patch: this patch is
      broken, needs fixing.
    - d/p/virtinst/9005_ubuntu_releases.patch: virt-manager no longer
      handles release information directly.
  * debian/patches/use_qxl_for_ubuntu.patch: use qxl by default for Ubuntu
    VMs, it seems to work ...

Read more...

Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released
GizmoChicken (gizmochicken) wrote :

Thanks for the version update. Much appreciated!

I hope that I don't seem too ungrateful, but virt-manager is now up to 1.3.1.
Please see https://virt-manager.org/download/

Any chance we can get the most current version into Xenial?

Marc Deslauriers (mdeslaur) wrote :

We typically follow the versions that Debian has. I may bump to 1.3.1 depending on how big the changes are.

GizmoChicken (gizmochicken) wrote :

Thanks, Marc. The "kvm_hidden=on|off" feature in 1.3.1 is reportedly helpful for those attempting to upgrade from Windows 7 to Windows 10. So that alone may be enough to justify the bump.

Although I occasionally install from source, I usually rely on Jacob Zimmermann's ppa (ppa:jacob/virtualisation) for the most recent versions of virt-manager and qemu. And so far, Jacob Zimmermann's ppa has worked pretty well for me.

I know that this is a bit off topic, but...
I do wish that Ubuntu would consider creating an OFFICIAL ppa at which the most recent versions of virt-manager and qemu (and possibly xen) can be found, much like "ppa:graphics-drivers/ppa" provides an official ppa at which the latest nvidia drivers can be found.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.