virt-install dies with 'Cannot find suitable emulator for ppc64le'

Bug #1374558 reported by Scott Moser on 2014-09-26
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
High
Unassigned

Bug Description

$ sudo virt-install --debug --arch=ppc64 --pxe --connect qemu:///system --name whiz-bang --ram 1024 --vcpus 1 --network=bridge:br0,model=e1000 --os-type=linux --disk /var/lib/libvirt/images/p8bv-88,size=10 --noreboot --boot=network
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (cli:187) Launched with command line: /usr/share/virt-manager/virt-install --debug --arch=ppc64 --pxe --connect qemu:///system --name whiz-bang --ram 1024 --vcpus 1 --network=bridge:br0,model=e1000 --os-type=linux --disk /var/lib/libvirt/images/p8bv-88,size=10 --noreboot --boot=network
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (cli:195) Requesting libvirt URI qemu:///system
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (cli:199) Received libvirt URI qemu:///system
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (virt-install:193) Requesting virt method 'default', hv type 'default'.
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (virt-install:432) Received virt method 'kvm'
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (virt-install:433) Hypervisor name is 'hvm'
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (cli:476) DISPLAY is not set: defaulting to nographics.
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (guest:208) Setting Guest.os_variant to 'linux'
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (virt-install:551) Guest.has_install_phase: True

Starting install...
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (cli:234) File "/usr/share/virt-manager/virt-install", line 876, in <module>
    sys.exit(main())
  File "/usr/share/virt-manager/virt-install", line 870, in main
    start_install(guest, continue_inst, options)
  File "/usr/share/virt-manager/virt-install", line 588, in start_install
    fail(e, do_exit=False)
  File "/usr/share/virt-manager/virtinst/cli.py", line 234, in fail
    logging.debug("".join(traceback.format_stack()))

[Fri, 26 Sep 2014 17:49:32 virt-install 33208] ERROR (cli:235) internal error: Cannot find suitable emulator for ppc64le
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (cli:237)
Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-install", line 560, in start_install
    dom = guest.start_install(meter=meter, noboot=options.noreboot)
  File "/usr/share/virt-manager/virtinst/guest.py", line 391, in start_install
    start_xml, final_xml = self._build_xml(is_initial)
  File "/usr/share/virt-manager/virtinst/guest.py", line 444, in _build_xml
    start_xml = self.get_install_xml(install=True, disk_boot=disk_boot)
  File "/usr/share/virt-manager/virtinst/guest.py", line 314, in get_install_xml
    return self._do_get_install_xml(*args, **kwargs)
  File "/usr/share/virt-manager/virtinst/guest.py", line 345, in _do_get_install_xml
    self._set_defaults()
  File "/usr/share/virt-manager/virtinst/guest.py", line 649, in _set_defaults
    self._set_sound_defaults()
  File "/usr/share/virt-manager/virtinst/guest.py", line 877, in _set_sound_defaults
    support.SUPPORT_CONN_SOUND_ICH6):
  File "/usr/share/virt-manager/virtinst/connection.py", line 370, in check_support
    self, feature, data)
  File "/usr/share/virt-manager/virtinst/support.py", line 371, in check_support
    return sobj.check_support(virtconn, data)
  File "/usr/share/virt-manager/virtinst/support.py", line 187, in check_support
    actual_hv_version = conn.conn_version()
  File "/usr/share/virt-manager/virtinst/connection.py", line 290, in conn_version
    self._conn_version = self._libvirtconn.getVersion()
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 3655, in getVersion
    if ret == -1: raise libvirtError ('virConnectGetVersion() failed', conn=self)
libvirtError: internal error: Cannot find suitable emulator for ppc64le
[Fri, 26 Sep 2014 17:49:32 virt-install 33208] DEBUG (cli:248) Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start whiz-bang
otherwise, please restart your installation.
Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start whiz-bang
otherwise, please restart your installation.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: virtinst 1:1.0.1-0ubuntu2
ProcVersionSignature: User Name 3.16.0-17.23-generic 3.16.3
Uname: Linux 3.16.0-17-generic ppc64le
ApportVersion: 2.14.7-0ubuntu2
Architecture: ppc64el
Date: Fri Sep 26 17:45:31 2014
PackageArchitecture: all
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcLoadAvg: 0.02 0.02 0.05 1/1175 30483
ProcLocks:
 1: POSIX ADVISORY WRITE 84870 00:11:478688 0 0
 2: FLOCK ADVISORY WRITE 2515 00:11:45214 0 EOF
 3: POSIX ADVISORY WRITE 2369 00:11:50266 0 EOF
 4: POSIX ADVISORY WRITE 2567 00:11:47202 0 EOF
ProcSwaps:
 Filename Type Size Used Priority
 /swap.img file 8388544 0 -1
ProcVersion: Linux version 3.16.0-17-generic (buildd@fisher03) (gcc version 4.9.1 (User Name 4.9.1-15ubuntu1) ) #23-User Name SMP Fri Sep 19 16:54:14 UTC 2014
SourcePackage: virt-manager
UpgradeStatus: No upgrade log present (probably fresh install)
cpu_cores: Number of cores present = 20
cpu_coreson: Number of cores online = 19
cpu_smt: SMT is off

Related branches

Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :

As a random bit of information, I can get to a crash as described in bug 1374554 by doing:

sudo ln -s qemu-system-ppc64 /usr/bin/qemu-system-ppc64le

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virt-manager (Ubuntu):
status: New → Confirmed
Changed in virt-manager (Ubuntu):
importance: Undecided → High

Hi, any news about it?

Breno Leitão (breno-leitao) wrote :

The patch was made upstream.

https://git.fedorahosted.org/cgit/virt-manager.git/commit/?id=232507b4e911336fa04f54e06e117f3822c11eb9

Canonical, can you cherry-pick this patch?

Thanks for the heads-up.

Cherry-picks ok when preceded by c4162f6708764a3e458baeea16ce7026ed8b0b2c.
I've pushed a candidate package to ppa:serge-hallyn/virt. Provided it
builds and runs ok, I will push to vivid in a bit.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 1:1.0.1-4ubuntu2

---------------
virt-manager (1:1.0.1-4ubuntu2) vivid; urgency=medium

  * cherrypick two patches to fix virt-install for ppc64le (LP: #1374558)
 -- Serge Hallyn <email address hidden> Thu, 05 Feb 2015 15:09:46 -0600

Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers