Cannot find suitable CPU model for given data during VM starting

Bug #1346430 reported by Gannet on 2014-07-21
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
High
Unassigned

Bug Description

Eachtime I'm trying to start VM through Virtual Machine Manager an error window appears:

Error during domain starting: internal error: Cannot find suitable CPU model for given data

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 96, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 117, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1162, in startup
    self._backend.create()
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 866, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error: Cannot find suitable CPU model for given data

The workaround found is to run:

sudo dpkg-reconfigure libvirt-bin
libvirt-bin stop/waiting
libvirt-bin start/running, process 16631
Setting up libvirt-bin dnsmasq configuration.

After this VM starts running. But till next system reboot. After restarting computer I must run dpkg-reconfigure again to make VM starting.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libvirt-bin 1.2.2-0ubuntu13.1.1
ProcVersionSignature: Error: [Errno 2] No such file or directory: '/proc/version_signature'
Uname: Linux 3.15.6-031506-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Jul 21 20:47:56 2014
InstallationDate: Installed on 2014-06-08 (43 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.1)
SourcePackage: libvirt
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.libvirt.qemu.conf: [inaccessible: [Errno 13] Access denied: '/etc/libvirt/qemu.conf']

Gannet (ken20001) wrote :
description: updated
description: updated
Serge Hallyn (serge-hallyn) wrote :

Thanks for reporting this bug.

Please attach /etc/libvirt/qemu.conf.

Also please attach the result of 'virsh dumpxml vmname' both immediately after boot, and after the libvirt reconfigure.

Changed in libvirt (Ubuntu):
status: New → Incomplete
Gannet (ken20001) wrote :
Changed in libvirt (Ubuntu):
status: Incomplete → Confirmed
Gannet (ken20001) wrote :
Serge Hallyn (serge-hallyn) wrote :

Thanks. I would assume this is due to you having qemu run as user and group eugene. Do you have /dev/kvm owned by group eugene? If not, then I'm more surprised that your reconfiguration of libvirt allows the VM to start.

Could you please show the result of 'ls -l /dev/kvm; getfacl /dev/kvm' after a reboot and after a reconfiguration?

Also please attach /var/log/libvirt/qemu/win8.log

Changed in libvirt (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
Gannet (ken20001) wrote :

Before:

ls -l /dev/kvm
crw-rw----+ 1 root kvm 10, 232 лип 31 13:46 /dev/kvm

getfacl /dev/kvm
getfacl: Видалення початкового '/' з абсолютних шляхів
# file: dev/kvm
# owner: root
# group: kvm
user::rw-
user:eugene:rw-
group::rw-
mask::rw-
other::---

After:

ls -l /dev/kvm
crw-rw----+ 1 root kvm 10, 232 лип 31 13:46 /dev/kvm

getfacl /dev/kvm
getfacl: Видалення початкового '/' з абсолютних шляхів
# file: dev/kvm
# owner: root
# group: kvm
user::rw-
user:eugene:rw-
group::rw-
mask::rw-
other::---

Gannet (ken20001) wrote :
Gannet (ken20001) wrote :

Noting: I was need to change win8.log owner to add it as attachment.

Changed in libvirt (Ubuntu):
status: Incomplete → Confirmed
Serge Hallyn (serge-hallyn) wrote :

Does changing the qemu.conf to comment out the user=eugene and group=eugene work around the issue?

Gannet (ken20001) wrote :

No it doesn't.

Changed in libvirt (Ubuntu):
importance: Medium → High
affects: libvirt (Ubuntu) → virt-manager (Ubuntu)
Serge Hallyn (serge-hallyn) wrote :

I don't believe this is a libvirt bug, because I can run VMS fine under libvirt. However, I can reproduce this (in utopic) with virt-manager.

When I manually insert cpu type 'qemu64', it complains about cpu flag svm not being applicable - this is on an intel laptop.

Somehow virt-manager is not getting the right cpu capabilities - this still could boil down to a libvirt bug (i.e. virsh capabilities giving wrong results).

Gannet (ken20001) wrote :

And this started to happen after last package updation. Before it this issue didn't existed.

Gannet (ken20001) wrote :

Now, seems, it works for me. I don't know what changed but now my VM starts without any error messages.

Linux: 3.15.9 x86_64
virt-manager: 0.9.5-1ubuntu3
libvirt-bin: 1.2.2-0ubuntu13.1.2

Dustin Kirkland  (kirkland) wrote :

I'm seeing this on Utopic as well.

adrian (adrianlzt) wrote :

This was fixed by stopping libvirt, removing all files on /var/cache/libvirt/qemu/capabilities/ and starting it again.

https://bugzilla.redhat.com/show_bug.cgi?id=1160318

Works for me in Ubuntu 14.10

Gannet (ken20001) on 2015-08-10
Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.