Missing bios during GPU passthrough with virt-manager

Bug #1323074 reported by mard0 on 2014-05-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Medium
Unassigned

Bug Description

The initialisation of a gpu that is being pass through to a VM created with virt-manager hangs with the error "Radeon xxx:xx:xx.x Expecting atombios for evergreen gpu" where xxx:xx:xx.x is the pci-id of the gpu.

I have tried this with a few AMD cards and I get the same error every time. On the host side the radeon en fglrx modules are blacklisted (my main gpu is a nvidia 750 ti card). From searching for this error on google I understand that this the firmware isn't properly loaded by kvm. Instead the firmware file can be pass through to the VM to solve this problem. However it is impossible at this time to pass through a firmware file with virt-manager.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: virt-manager 0.9.5-1ubuntu3
ProcVersionSignature: Ubuntu 3.13.0-27.50-generic 3.13.11
Uname: Linux 3.13.0-27-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun May 25 22:23:08 2014
PackageArchitecture: all
SourcePackage: virt-manager
UpgradeStatus: No upgrade log present (probably fresh install)

mard0 (martijn-doornbusch-l) wrote :
mard0 (martijn-doornbusch-l) wrote :

Example of dmesg output in a trusty guest:

[ 2.251895] [drm] initializing kernel modesetting (TURKS 0x1002:0x6759 0x174B:0xE193).
[ 2.251909] [drm] register mmio base: 0xFC040000
[ 2.251910] [drm] register mmio size: 131072
[ 2.251999] radeon 0000:00:08.0: Expecting atombios for evergreen GPU
[ 2.252039] radeon 0000:00:08.0: Fatal error during GPU init
[ 2.252382] [drm] radeon: finishing device.
[ 2.252384] [TTM] Memory type 2 has not been initialized
[ 2.264105] radeon: probe of 0000:00:08.0 failed with error -22

mard0 (martijn-doornbusch-l) wrote :

Same error still occurs when trying to pass through the GPU with vfio

Serge Hallyn (serge-hallyn) wrote :

Thanks for submitting this bug. Could you please look through /var/log/audit/audit.log if it exists, else /var/log/syslog, and look for any DENIED messages which seem relevant?

sudo grep DENIED /var/log/audit/audit.log /var/log/syslog | grep libvirt

should show what we need.

Changed in virt-manager (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
mard0 (martijn-doornbusch-l) wrote :

There is no directory /var/log/audit and nothing in syslog. Also when trying to pass through the device with vfio.
I did had to make some changes to the libvirt-aa-helper apparmor profile to give libvirt rw access to /dev/vfio/* to get pass through with vfio to work. After that I didn't encounter any DENIED messages anymore.

After reading https://bugzilla.kernel.org/show_bug.cgi?id=57831 where it was suggested that fglrx might work, I tried installing fglrx in the guest. But, again, I got almost the same error.

Changed in virt-manager (Ubuntu):
status: Incomplete → Confirmed
mard0 (martijn-doornbusch-l) wrote :

Upgrading to Utopic fixed the bug.
I guess this bug can be closed.

Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.