virt-manager does not include the python-spice-client-gtk dependency for Spice

Bug #1268466 reported by CatchesAStar on 2014-01-13
46
This bug affects 12 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Qemu-spice-kvm depends on qemu-kvm in saucy, but python-spice-client-gtk is not a dependency of virt-manager.

Running a spice-enabled VM in virt-manager without python-spice-client-gtk results in an error:
No module named SpiceClientGtk

affects: qemu-kvm (Ubuntu) → qemu-kvm-spice (Ubuntu)
Changed in qemu-kvm-spice (Ubuntu):
importance: Undecided → Medium
Serge Hallyn (serge-hallyn) wrote :

Since qemu is in main and python-spice-client-gtk is in universe, we couldn't make this dependency.

However as this is only for virt-manager use of spice-gtk, we could do it in virt-manager.

affects: qemu-kvm-spice (Ubuntu) → virt-manager (Ubuntu)
Serge Hallyn (serge-hallyn) wrote :

Hm, no. I thought virt-manager was in universe, but now I see it is in main.

Changed in virt-manager (Ubuntu):
importance: Medium → Wishlist
status: New → Confirmed
Serge Hallyn (serge-hallyn) wrote :

So to make this happen, we would need a main inclusion request (MIR) for qemu-kvm-spice.

Amr Ibrahim (amribrahim1987) wrote :

Here's my opinion on this:

- python-spice-client-gtk doesn't need to be a dependency of virt-manager.
- python-spice-client-gtk is suggested by virt-manager in order for spice to work, which is the right thing to do because virt-manager starts and function without spice (if you're fine to work without some nice features).

So if you want to use spice with virt-manager, make sure to check the suggest field first and install python-spice-client-gtk.

summary: - Qemu does not include the python-spice-client-gtk dependency for Spice
+ virt-manager does not include the python-spice-client-gtk dependency for
+ Spice
description: updated

Agreed, I hadn't noticed it is in Suggests.

 status: invalid

Changed in virt-manager (Ubuntu):
status: Confirmed → Invalid
acllos (accountlostin) wrote :

this is ridiculous. Invalid? Whishlist?

a functionality is broken (what if the virtualization host is a remote server? what should the user do, reboot all the vm in order to change them to vnc?) and you refuse to recognize it as something that should work.

Well, PATCH virt-manager and add a meaningfull message informing the user about what he needs to install in order for spice to be working. There are tens of thread with people asking about a solution. Leave them able to figure out what they need to do.

You are refusing to fix bugs (when they are read...) because of *internal* policy reasons. completely ridicolous. FIX the policy then.
Why should someone consider donating or paying for support when the resources are there and no fix gets applied?

Serge Hallyn (serge-hallyn) wrote :

According to the bug description, you are in fact getting a meaningful error message.

Why would a vm need to be rebooted to install the needed dependencies? It's possible there's a more serious case that I'm just not seeing and which would warrant an earlier error message (but I'm not yet seeing it).

Marc Deslauriers (mdeslaur) wrote :

This bug is actually fixed in Ubuntu 14.10 and later. virt-manager was moved to universe, and now recommends python-spice-client-gtk and other universe packages.

Changed in virt-manager (Ubuntu):
status: Invalid → Fix Released
Richard Laager (rlaager) wrote :

This is a problem in Xenial.

Richard Laager (rlaager) wrote :

Well, it's actually slightly different on Xenial. I guess gir1.2-spice-client-gtk-3.0 is required, which is currently a Recommends. So maybe that's okay then.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers