Cant contect to text console of a vitual machine from Virt-Manager

Bug #1057319 reported by gumanoed on 2012-09-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Medium
Unassigned
virt-manager (openSUSE)
Fix Released
Medium

Bug Description

I use Virt-Manager + Xen tu run a little development server for a few LUG projects. The server is trivial i386 PC without Hardware Virtualisation support. Ru run Virtual Machines i use Network install option and unable to finish instalation becouse all NetInstall kernel images from ubuntu repo do not use graphic.

Virt-Manager 0.9.1 have an option "View -> Text Console -> Text Console 1", but when i choose it it says "Error connecting ro text console: Cannot open a device with no alias name".

You can see on Screen Shot that if I execute command "xm console test-server" on the Xen server I able to see output of installing system!

I found exactly tha same problem on Novel's bugzilla. And looks like they solved a problem. May be it'll help:
https://bugzilla.novell.com/show_bug.cgi?id=780859

Thank you. Really Love Ubuntu :)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: virt-manager 0.9.1-1ubuntu5.1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu13
Architecture: i386
Date: Thu Sep 27 10:45:53 2012
ExecutablePath: /usr/share/virt-manager/virt-manager.py
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Release i386 (20120424.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: virt-manager
UpgradeStatus: No upgrade log present (probably fresh install)

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0

I only use xen DomU devices without a graphical interface only a console.
Via virt-manager I cant connect to the console.
The warning I see it:
Error connecting to text console:
Cannot open a device with no alias name

When I connect via:
xm console <name>, there isn't a problem at all.

Reproducible: Always

Steps to Reproduce:
1. Connect to a DomU device with only a console via virt-manager
2. Open the console
3. No screen output is shown. The following warning is displayed.
Error connecting to text console:
Cannot open a device with no alias name

Created an attachment (id=506198)
Fix for the problem

Copy this patch to /usr/share/virt-manager and patch your source with
patch -p0 < virtman-reverse-serialcon.patch

I've tested the patch, this solves the issue.

Thanks for your help!
Closing as fixed.

gumanoed (gumanoed) wrote :
gumanoed (gumanoed) wrote :

Hm .. what does the red circle near ubuntu package means?
Is it possable to fix it in ubuntu repository fo 12.04?

Logan Rosen (logan) wrote :

No need to be concerned about the red circle. It only appeared because I linked the openSUSE bug, which means that you could technically delete the Ubuntu association at this point, which we definitely don't want to do. :)

Changed in virt-manager (openSUSE):
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virt-manager (Ubuntu):
status: New → Confirmed

Please apply patch to virt-manager in ubuntu repos! it still exists in 1.0.1and 0.9.5

sorry were can I get the patch?
karina

Serge Hallyn (serge-hallyn) wrote :

The patch appears to be this one: https://bugzilla.novell.com/attachment.cgi?id=506198&action=diff

which removes the error if 'not name'. However, that check is still upstream:

https://git.fedorahosted.org/cgit/virt-manager.git/tree/virtManager/serialcon.py

so I'm hesitant to apply it.

Changed in virt-manager (Ubuntu):
importance: Undecided → Medium
Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.