Ubuntu

virt-manager over SSH fails after 10.04 - 12.04 upgrade

Reported by Peter Matulis on 2012-07-26
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading a Lucid machine to Precise I can no longer run virt-manager over SSH like I had been doing for the past few years:

$ ssh -X user@host virt-manager

I am uploading data from the server:

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: virt-manager 0.9.1-1ubuntu5.1
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
Date: Thu Jul 26 12:59:02 2012
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, user)
 SHELL=/bin/zsh
 TERM=screen-256colorSourcePackage: virt-manager
UpgradeStatus: Upgraded to precise on 2012-07-26 (0 days ago)

Peter Matulis (petermatulis) wrote :
description: updated
Marc Deslauriers (mdeslaur) wrote :

I can't reproduce this. I can remotely start virt-manager on a precise machine just fine.

Are you able to start virt-manager on the console of the remote machine?

Could you do "apt-get install gedit" and try that? Maybe you're missing some gnome libraries...

Peter Matulis (petermatulis) wrote :

Did you upgrade from 10.04 or use a fresh install?

No, I cannot start it because it is a GTK application and the server does not have GTK libraries installed. I did an strace however and I have attached that.

Yes, the gedit test succeeded.

Marc Deslauriers (mdeslaur) wrote :

I updated a desktop image from lucid to precise.

The only relevant error is:

9873 write(2, "Unable to initialize GTK: could "..., 48) = 48

Which means pygtk couldn't start.

Does this simple pygtk app run on your server?:
http://www.pygtk.org/pygtk2tutorial/examples/helloworld.py

Peter Matulis (petermatulis) wrote :

Yes it does. Over SSH I get a little box displaying 'Hello World'.

Marc Deslauriers (mdeslaur) wrote :

I just successfully done the following:

1- Installed lucid server
2- apt-get install virt-manager
3- tested running virt-manager using ssh -X
4- upgraded to precise
5- tested running virt-manager using ssh -X

Could you please get the list of installed packages from your server? I'll compare with mine, and attempt to see if anything is missing.

Peter Matulis (petermatulis) wrote :

Yes, here it is.

Marc Deslauriers (mdeslaur) wrote :

OK, I don't see any significant missing packages. I'm not quite sure what could be wrong with your environment...

If I think of something, I'll let you know.

Marc Deslauriers (mdeslaur) wrote :

What version of python is default on your machine, if you type "python" on a command line, do you get python 2.7.3?

Peter Matulis (petermatulis) wrote :

Yes,

Python 2.7.3 (default, Apr 20 2012, 22:39:59)

I'll probably be reinstalling next week.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virt-manager (Ubuntu):
status: New → Confirmed
Leonardo Borda (lborda) wrote :

workaroud: ssh -X <server> virt-manager --no-fork

now the question is why does it happen?

I seemed to have reproduced the bug when I deleted ~/.dbus but I am not sure.

Leonardo Borda (lborda) wrote :

It looks like it also works with:

ssh -X <server> virt-manager --debug

Peter Matulis (petermatulis) wrote :

Yes, that w/a is confirmed over here.

Marc Deslauriers (mdeslaur) wrote :

Do you have the "system tray icon" enabled in the preferences?

Could you try with a new user with a fresh profile?

Changed in virt-manager (Ubuntu):
status: Confirmed → Incomplete
Peter Matulis (petermatulis) wrote :

No, I do not have the icon enabled. I'm not sure what you're after. I enabled it and no difference.

I tried from a Desktop virtual guest running Precise (new user) and still the same thing. I also tried connecting to a new user account on the host. Still nothing.

Launchpad Janitor (janitor) wrote :

[Expired for virt-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in virt-manager (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers