Please sync vips 7.12.5-2 from Debian unstable

Bug #161760 reported by Siegfried Gevatter on 2007-11-09
8
Affects Status Importance Assigned to Milestone
vips (Debian)
Fix Released
Unknown
vips (Ubuntu)
Wishlist
Steve Langasek

Bug Description

The remaining change to merge was:
    - debian/python-vipscc.install: change from python2.4 to 2.5

This has been fixed in the last revision.

Changed in vips:
importance: Undecided → Wishlist
Siegfried Gevatter (rainct) wrote :
Changed in vips:
status: New → Confirmed
Cesare Tirabassi (norsetto) wrote :

Thanks for correcting this.
Can you also correct the changelog (still refers to 2.5)?
Can you report this to Debian and link the bug report here?

Changed in vips:
assignee: nobody → rainct
status: Confirmed → Incomplete
Chris Halse Rogers (raof) wrote :

Looks good to me. However, now is probably a good idea to find the "more appropriate" solution that Barry deFreese suggested in the changelog. This is probably going to involve dh_pycentral in some way.

If you want to look into this, I'd be happy to help you. If not, I can do it myself.

Chris Halse Rogers (raof) wrote :

Following up on this: the reason that the .install file needs to exist at all is that debian/rules is broken. It looks like dh_pycentral should be called, but it doesn't.

Fixing this will require someone to navigate the labarynthine logic of CDBS. Or at least check that the target that has the dh_pycentral call should actually be called by CDBS :).

Once someone has figured this out, a bug should be filed in the Debian BTS.

Siegfried Gevatter (rainct) wrote :

Cesare Tirabassi: Sorry, new .debdiff is attached.

Changed in vips:
assignee: rainct → nobody
status: Incomplete → Confirmed
Cesare Tirabassi (norsetto) wrote :

I think that Chris has a point, since with the current package dh_pycentral is not even called.
So far we found the following additional mistakes:

In rules:

binary-install/vipscc-python:

should really be :

binary-install/python-vipscc::

In control:

XS-Python-Version: current

should be in the source stanza.

I would also correct the package in line with the current python policy:

In control, for the binary package python-vipscc:

From:

Depends: ${shlibs:Depends}, python (>= 2.4)

To:

Depends: ${shlibs:Depends}, ${python:Depends}

And for the Build-Depends:

debhelper should be bumped to (>= 5.0.38)
python-all-dev should be removed
python-central should be versioned as (>= 0.5.6)

Can you check how it builds and installs with these modifications?
Can you check if there is any any other error we should correct?

Many thanks.

Changed in vips:
assignee: nobody → rainct
status: Confirmed → In Progress
Siegfried Gevatter (rainct) wrote :

Debian bug about the "binary-install/python-vipscc:" line:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=450863

(Launchpad only accepts one Debian watch)

Cesare Tirabassi (norsetto) wrote :

Thanks Siegfried. Next time you may also want to use the ubuntu usertags when submitting bugs to Debian:

https://wiki.ubuntu.com/Bugs/Debian/Usertagging

Siegfried Gevatter (rainct) wrote :

Okay, added the tags. New debdiff is attached, but it fails to build:

echo 5 >debian/compat
find build-tree -name CVS -print | xargs rm -rf
touch debian/stamp-autotools-files
chmod a+x /home/rainct/WIP/vips/vips-7.12.5/build-tree/vips-7.12.5 move/configure
chmod: no s'ha pogut accedir a «move/configure»: No such file or directory
make: *** [move/config.status] Error 1

Changed in vips:
status: Unknown → New
Cesare Tirabassi (norsetto) wrote :

1) For the target its not just the semi-colon, its the target name too (see my post above).
2) Contrary to Chris, I don't think we should delete the .install file (extensions are not moved automatically by dh_pycentral).
3) In my post above, I was talking about removing python-all-dev from the build-depends, I didn't even noticed it was also in some dependency. You should really ask Jay if these are all needed as dependencies of libvips-dev: python-all-dev, python-central, python-dev (>= 2.4)
4) For the ftbfs, the problem seems to be that the name of the package is taken as "vips-7.12.5 move", see for instance this:

mkdir -p "build-tree/vips-7.12.5 move"

I would say that DEB_BUILDDIR is not constructed correctly, and I suspect that this has to do with tarball.mk, in particular the way DEB_TAR_SRCDIR is defined. If you look in rules you will see that VERSION is the result of a dpkg-parsechangelog call.
It is possible that this is the cause of the failure (please confirm). What happens if you change it with this:

dpkg-parsechangelog | sed 's/^Version: //; t; d'

?

Cesare Tirabassi (norsetto) wrote :

Yes, on second thought it makes sense that this should fail, if we change the version to an ubuntu version if may not detect the right tarball name.
Maybe this:

dpkg-parsechangelog | sed 's/^Version: //; t; d' | cut -d- -f 1

will solve the problem.

Cesare Tirabassi (norsetto) wrote :
Download full text (4.4 KiB)

For testing, I have just compiled thrice without problems, with the original version plus the attached debdiff. Perhaps it is simply a problem with awk, which, afaics, its not part of the base installation (contrary to mawk and sed).
The resulting package contains the following:

drwxr-xr-x root/root 0 2007-11-12 15:00 ./
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/share/
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/share/doc/
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/share/doc/python-vipscc/
-rw-r--r-- root/root 1225 2007-11-12 14:55 ./usr/share/doc/python-vipscc/copyright
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/share/pycentral/
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/
-rw-r--r-- root/root 311114 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/verrormodule.a
-rw-r--r-- root/root 39488 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/VImage.py
-rw-r--r-- root/root 1558 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/verrormodule.la
-rw-r--r-- root/root 2486 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/VDisplay.py
-rw-r--r-- root/root 2477 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/VError.py
-rw-r--r-- root/root 47 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/__init__.py
-rw-r--r-- root/root 1572 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/vdisplaymodule.la
-rw-r--r-- root/root 231202 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/vdisplaymodule.a
-rw-r--r-- root/root 635438 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/vmaskmodule.a
-rw-r--r-- root/root 1558 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/vimagemodule.la
-rw-r--r-- root/root 1551 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/vmaskmodule.la
-rw-r--r-- root/root 6762 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/VMask.py
-rw-r--r-- root/root 6013786 2007-11-12 15:00 ./usr/share/pycentral/python-vipscc/site-packages/vipsCC/vimagemodule.a
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/lib/
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/lib/python2.5/
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/lib/python2.5/site-packages/
drwxr-xr-x root/root 0 2007-11-12 15:00 ./usr/lib/python2.5/site-packages/vipsCC/
-rw-r--r-- root/root 88784 2007-11-12 15:00 ./usr/lib/python2.5/site-packages/vipsCC/vmaskmodule.so
-rw-r--r-- root/root 35088 2007-11-12 15:00 ./usr/lib/python2.5/site-packages/vipsCC/vdisplaymodule.so
-rw-r--r-- root/root 39600 2007-11-12 15:00 ./usr/lib/python2.5/site-packages/vipsCC/verrormodule.s...

Read more...

Jay Berkenbilt (ejb) wrote :

I really appreciate this analysis. I will be uploading 7.15.5-2 momentarily with this patch (except, of course, the maintainer fields). Also, I've used python*.* instead of python?.? in the install file, not that I expect to see python 2.10 or 10.0, but it should be fine anyway...

Changed in vips:
assignee: rainct → ejb
Jay Berkenbilt (ejb) wrote :

Um, I'm not sure what it means for this bug to be assigned to me. I have uploaded 7.15.5-2 into debian, but I wasn't planning on taking any specific action on this bug. Hopefully, whoever does this sort of thing in Ubuntu should be able to merge 7.15.5-2 from debian now without having any custom patches. I'm not really involved with Ubuntu other than that I'd like to make my debian packages work in Ubuntu without any extra hassle. If no specific action is required on my part, then no further comment is necessary.

Cesare Tirabassi (norsetto) wrote :

Sorry for this Jay, its just an oversight from a contributor.
I profit from it to thank you for your support on this and your excellent work on debian, from which we shamelessly profit :-).

Changed in vips:
assignee: ejb → nobody
status: In Progress → Fix Committed
description: updated
Emmet Hikory (persia) wrote :

Please test against 7.12.5-2 in Debian, and if clean, retitle this as a sync request.

Changed in vips:
assignee: nobody → rainct
status: Fix Committed → In Progress
Cesare Tirabassi (norsetto) wrote :

Yes, do you want to issue a sync request yourself?
The simplest would be to transform this merge into a sync request.
If you do that, please mark it as new and subscribe u-u-s.

Siegfried Gevatter (rainct) wrote :

Kmos confirmed that it build fine in Hardy. Thanks!

description: updated
Changed in vips:
assignee: rainct → nobody
status: In Progress → New
Cesare Tirabassi (norsetto) wrote :

Sync request ACK'D to Archive.

Changed in vips:
status: New → Confirmed
Steve Langasek (vorlon) on 2007-12-03
Changed in vips:
assignee: nobody → vorlon
status: Confirmed → In Progress
Steve Langasek (vorlon) wrote :

package synced, thank you for your contribution to Ubuntu.

Changed in vips:
status: In Progress → Fix Released
Changed in vips:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.