Share Desktop with Empathy need before to go to Share your Desktop

Bug #966556 reported by Mozaic on 2012-03-27
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
vino (Ubuntu)
Undecided
Unassigned
Precise
Low
Unassigned

Bug Description

I try to share my Desktop with a XMPP'S contact. On the Contextual's menu Share my Desktop is black. It's means this action is possible.
But it's don't work.

Before i need to go on the Dash, to find Desktop Sharing preference dialog and allow the other to view my Desktop (Allow other users to view your desktop)

Expected: An advertissement like this one: Before you need to allow to share your Desktop. After it works

Sorry for my english.

Franch:
J'essaie de partager mon Bureau avec un contact XMPP. Le menu contextuel donne une écriture noir à Partager votre Bureau: l'action est donc possible. Mais cela ne marche pas.

Il faut avant aller dans Partage de Bureau et cliquer sur Autoriser d'autres utilisateurs à voir votre Bureau. Ensuite, vous pouvez passer par le menu contextuel, vous recevez une notification comme quoi le bureau va être partagé et le correspondant reçoit la notificatio et cela marche.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: empathy 3.3.92-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Tue Mar 27 22:05:56 2012
ExecutablePath: /usr/lib/empathy/empathy-chat
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

Mozaic (mozaic) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Luis Alvarado (luisalvarado) wrote :

As I mentioned here: https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/934394 the problem persists. Very important for this to work since it is both, a learning tool and a help desk tool.

Guillaume Desmottes (cassidy) wrote :
Mozaic (mozaic) wrote :

In 3.4.1 of Vino and in 3.4.1 of Empathy ??
I need test to confirm, someone ??

Guillaume Desmottes (cassidy) wrote :

That's fixed in vino master, not yet released.

Mozaic (mozaic) wrote :

A day when it's come in Ubuntu??

Guillaume Desmottes (cassidy) wrote :

That's Ubuntu's choice. They can backport my fix to the vino package if they want to.

Jorge Castro (jorge) on 2012-05-15
Changed in empathy (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vino (Ubuntu Precise):
status: New → Confirmed
affects: empathy (Ubuntu) → vino (Ubuntu)
Ken VanDine (ken-vandine) wrote :

To verify the fix, open "Desktop Sharing" preferences and ensure sharing of the desktop is disabled (unchecked). Find a contact in the empathy contact list that is available to share your desktop with. To do this, right click on a contact and see if "Share my Desktop" menu item is sensitive. You should be able to activate the menu and the contact on the other end get a sharing request.

Changed in vino (Ubuntu):
status: Confirmed → Fix Released
assignee: Ken VanDine (ken-vandine) → nobody
Changed in vino (Ubuntu Precise):
importance: Undecided → Low
Changed in empathy:
importance: Unknown → Medium
status: Unknown → Fix Released

Hello Mozaic, or anyone else affected,

Accepted vino into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in vino (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Will Thompson (wjt) wrote :

I've verified that 3.4.2-0ubuntu1 fixes this issue.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 3.4.2-0ubuntu1

---------------
vino (3.4.2-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - upstream translation updates
  * debian/patches/00_server_share_tube.patch
    - Backport a fix from 3.5 series that fixes a regression introduced when
      Vino switched to GSettings as it started exiting right away when
      desktop sharing was disabled. This fixes desktop sharing from
      empathy and any other telepathy clients (LP: #966556)
  * debian/patches/12_app-indicators-only.patch
    - refreshed

vino (3.4.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/12_app-indicators-only.patch
    - Removed non-existing property which was only set if using
      the appindicator (LP: #997699)
 -- Ken VanDine <email address hidden> Tue, 15 May 2012 16:44:57 -0400

Changed in vino (Ubuntu Precise):
status: Fix Committed → Fix Released
Mozaic (mozaic) wrote :

I could share my Desktop, but my friend could not. It always grey.
For me, the sharing works always, i choose in vino not share or share.

And i don't allow my friend to move my mouse's curse and he could.

Luis Alvarado (luisalvarado) wrote :

Using vino 3.4.2-0ubuntu1.1 and empathy 3.4.2.3-0ubuntu1 in Ubuntu 12.04.1.

The problem still exists. The options to share desktop are grayed out. Both empathy users have empathy using gmail accounts and both can not share the desktop.

Sebastien Bacher (seb128) wrote :

@Luis: open a new bug if you still get an issue (rather than commenting on a closed ticket)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.