vino-server crashed with SIGABRT in raise()

Bug #854512 reported by pschonmann on 2011-09-20
132
This bug affects 26 people
Affects Status Importance Assigned to Milestone
vino (Ubuntu)
High
Unassigned

Bug Description

Crashed after each start

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: vino 3.1.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Tue Sep 20 10:05:06 2011
ExecutablePath: /usr/lib/vino/vino-server
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110808)
ProcCmdline: /usr/lib/vino/vino-server --sm-disable
ProcEnviron:
 PATH=(custom, no user)
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: vino
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
Title: vino-server crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to oneiric on 2011-09-13 (7 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

pschonmann (pschonmann) wrote :

StacktraceTop:
 __libc_message (do_abort=2, fmt=0x7fbfaa6db0d8 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (action=3, str=0x7fbfaa6d80d2 "corrupted double-linked list", ptr=<optimized out>) at malloc.c:6283
 _int_malloc (av=0x7fbfaa9161c0, bytes=96) at malloc.c:4636
 __GI___libc_malloc (bytes=96) at malloc.c:3660
 GetUPNPUrls () from /tmp/tmp30hKcQ/usr/lib/libminiupnpc.so.5

Changed in vino (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vino (Ubuntu):
status: New → Confirmed
pschonmann (pschonmann) on 2011-09-21
visibility: private → public
affects: vino (Ubuntu) → miniupnpc (Ubuntu)
affects: miniupnpc (Ubuntu) → vino (Ubuntu)
Changed in vino (Ubuntu):
importance: Medium → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 3.3.3-0ubuntu2

---------------
vino (3.3.3-0ubuntu2) precise; urgency=low

  * debian/patches/05_use-system-miniupnpc.patch:
    - update to the current libminiupnpc abi, the previous version was still
      using the source .h copies and the functions prototypes and code were
      different from the runtime (lp: #840696, #841384, #854512, #903879).
 -- Sebastien Bacher <email address hidden> Thu, 26 Jan 2012 16:26:41 +0100

Changed in vino (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers