Ubuntu

vino-server crashed with SIGSEGV in free()

Reported by Mike Baker on 2011-09-04
416
This bug affects 74 people
Affects Status Importance Assigned to Milestone
miniupnpc (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
vino (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

TESTCASE:
- start vino-preferences, check the "use upnp to configure..." box
- stop vino-server if it's running
- run /usr/lib/vino/vino-server

Before the update it would segfault, after the upgrade it should work fine

Mike Baker (odorikakeru) wrote :

StacktraceTop:
 _int_free (av=0x7ff8b20a51c0, p=0x10fb710) at malloc.c:4964
 __GI___libc_free (mem=<optimized out>) at malloc.c:3738
 UPNP_GetValidIGD () from /tmp/tmpt4Y8Ml/usr/lib/libminiupnpc.so.5
 update_upnp_status (upnp=0x10e8650) at server/vino-upnp.c:97
 update_upnp_status (upnp=0x10e8650) at server/vino-upnp.c:79

Changed in vino (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in vino (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

pedro, could you upstream this one?

visibility: private → public
Changed in vino (Ubuntu):
importance: Medium → High
assignee: nobody → Pedro Villavicencio (pvillavi)
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugzilla.gnome.org/show_bug.cgi?id=658550

Changed in vino (Ubuntu):
assignee: Pedro Villavicencio (pvillavi) → nobody
status: Confirmed → Triaged
Changed in vino:
importance: Undecided → Unknown
status: New → Unknown
Changed in vino:
importance: Unknown → Critical
status: Unknown → New
Changed in vino:
status: New → Invalid

Any news or progress on this one? Since Gnome said that it is Debian/Ubuntu miniupnp specific, no one over here seems to care?!

Vino-server worked well on my AMD E350 system as I first upgraded to Oneiric about one month ago. But after some updates, it does not want to start anymore. Since it was running on Natty, but did not redraw the screen, it would be really nice to have it up and running in Oneiric.

Kind regards
Phil

Of got a problem with vino-server not starting anymore as well.

Laurence Jeloudev
<email address hidden>

On 24/09/2011, at 19:05, Philipp Michalschik <email address hidden> wrote:

> Any news or progress on this one? Since Gnome said that it is
> Debian/Ubuntu miniupnp specific, no one over here seems to care?!
>
> Vino-server worked well on my AMD E350 system as I first upgraded to
> Oneiric about one month ago. But after some updates, it does not want to
> start anymore. Since it was running on Natty, but did not redraw the
> screen, it would be really nice to have it up and running in Oneiric.
>
> Kind regards
> Phil
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/840696
>
> Title:
> vino-server crashed with SIGSEGV in free()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/vino/+bug/840696/+subscriptions

igi (igor-cali) on 2011-09-29
description: updated
tags: added: bugpattern-needed
mohdyusuf (mohdyusuf) wrote :

Sorry, it is just me or the bug on https://bugzilla.gnome.org/show_bug.cgi?id=658550 is never going to be resolved?

The bug on bugzilla site says INVALID and status marked as RESOLVED. Is this a stuck-in-limbo case?

bash321 (bash321) wrote :

no that is completely wrong Vino Server still doesn't work on my ubuntu....
its not resolved hopefully someone smart enough will fix it.. I just report bugs where things have gone wrong..
if some one could post an explanation of how to upload logs to find the cause of the problem.. I can assist in providing a log.

bash321 (bash321) wrote :

btw i don't have a gnome bug report account on launchpad if some who has a gnome account can change the status for it.. as Vino Server does not work on Ubuntu 11.10. using the unity 3d interface.

This bug is really frustrating. It is impossible to control the desktop externally which is a must for me when I'm traveling, etc. Is there any way this bug can be really looked at. This has been broken for too long, it feels.

Maybe the bug that the upstream developer refers to should be watched in place of the original bug report filed upstream?

Changed in miniupnpc (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in miniupnpc (Ubuntu):
status: New → Confirmed
no longer affects: miniupnpc (Ubuntu Precise)
no longer affects: vino (Ubuntu Precise)
Changed in miniupnpc (Ubuntu Oneiric):
importance: Undecided → High
Changed in vino (Ubuntu Oneiric):
importance: Undecided → High
Changed in miniupnpc (Ubuntu Oneiric):
status: New → Confirmed
Changed in vino (Ubuntu Oneiric):
status: New → Triaged
Harmon Nine (harmon-nine) wrote :

I was just able to execute vino-server manually, but as a user, i.e. not as root. Specifically, at a shell prompt, I typed

/usr/lib/vino/vino-server

A vnc client can now access the desktop. However, it segfaults after a few seconds when the "Automatically configure UPnP router to open and forward ports" is enabled. When this is disabled, it seems to work ok.

I can confirm that a vnc client can access the desktop now, but I'm still unable to control it. Although the mouse pointer moves, no keyboard input or mouse clicks seem to be sent/received.

Vadim Peretokin (vperetokin) wrote :

I got this crash when I enabled 'Automatically configure UPnP router to open and forward ports' in Desktop Sharing Preferences.

vino version is 3.2.0-0ubuntu1

I can see and control my HTPC again! Thanks a lot.

Monkberry (peter-monkberry) wrote :

WORKAROUND

Apparently this is a timing problem, cart before the horse so to speak. As seen above the suggestions about starting/stopping/enabling/disabling networks and/or desktop sharing, I figured the problem was probably due to the fact that the desktop sharing was enabling BEFORE the network was actually ready, thereby killing the process when the network then became ready. This may or not be but creating a simple script that fires up the vino-server after waiting for 10 seconds after login solves the problem. I created this and added it to my startup applicaitions.

#!/bin/bash
sleep 10
/usr/lib/vino/vino-server

Now all is well. This was on Linux Mint 12 using the MATE desktop.

no longer affects: vino
Changed in miniupnpc (Ubuntu):
status: Confirmed → Invalid
Changed in miniupnpc (Ubuntu Oneiric):
status: Confirmed → Invalid
Shahar Or (mightyiam) wrote :

Does this happen only on GNOME login? Because for me it happens during session as well. I'll report another bug and let others decide.
Reported as Bug #922126.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 3.3.3-0ubuntu2

---------------
vino (3.3.3-0ubuntu2) precise; urgency=low

  * debian/patches/05_use-system-miniupnpc.patch:
    - update to the current libminiupnpc abi, the previous version was still
      using the source .h copies and the functions prototypes and code were
      different from the runtime (lp: #840696, #841384, #854512, #903879).
 -- Sebastien Bacher <email address hidden> Thu, 26 Jan 2012 16:26:41 +0100

Changed in vino (Ubuntu):
status: Triaged → Fix Released

This bug is still not fixed for me (running Ubuntu Oneric, fully updated). I've been reading that there are possible fixes. I Haven't tried them, but I would guess that the relevant packages should be updated with a fix if there is one.

Ah, now I see that there has been a fix released. Will wait for the fix then.

Changed in vino (Ubuntu Oneiric):
status: Triaged → Fix Committed
description: updated
Sebastien Bacher (seb128) wrote :

the fixes just got uploaded, the precise package still needs to build and the oneiric sru to be approved by a mir team member before building

Hello Mike, or anyone else affected,

Accepted vino into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I can confirm that the fixes in the proposed packages (vino and miniupnpc) allow the desktop to be viewed/controlled through VNC as before.

I hope vino remote desktop all works as well for the upgrade to 12.04.
When it is released in April. I can confirm vino now works on my machine as
well after the updates.

On Tuesday, 31 January 2012, José Alburquerque <email address hidden>
wrote:
> I can confirm that the fixes in the proposed packages (vino and
> miniupnpc) allow the desktop to be viewed/controlled through VNC as
> before.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/840696
>
> Title:
> vino-server crashed with SIGSEGV in free()
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/ubuntu/+source/miniupnpc/+bug/840696/+subscriptions
>

--
Laurence Jeloudev
Do us a favour and get gmail (http://www.gmail.com), so you don't loose
your emails and then print them off!

Martin Pitt (pitti) on 2012-01-31
tags: added: verification-done
removed: verification-needed

I can confirm as well, that the fixes in the proposed packages, from #25, made the desktop sharing work fine via VNC, but I still hope that in 12.04, it could work easily like previous versions. Thanks, Chris Rogers!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 3.2.0-0ubuntu1.1

---------------
vino (3.2.0-0ubuntu1.1) oneiric-proposed; urgency=low

  * debian/patches/05_use-system-miniupnpc.patch:
    - update to the current libminiupnpc abi, the previous version was still
      using the source .h copies and the functions prototypes and code were
      different from the runtime (lp: #840696)
 -- Sebastien Bacher <email address hidden> Thu, 26 Jan 2012 16:11:41 +0100

Changed in vino (Ubuntu Oneiric):
status: Fix Committed → Fix Released

Now working fine here, after a system update!! Thank you!!

I still get a segfault: Connecting to the vino server via vinaigre works exactly one time, but after that the server crashes.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.