vino crashes on desktop sharing with Empathy

Bug #628967 reported by Ted Gould on 2010-09-02
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
vino
Unknown
Medium
empathy (Ubuntu)
Low
Unassigned
Maverick
Low
Unassigned
vino (Ubuntu)
High
Karl Lattimer
Maverick
High
Karl Lattimer

Bug Description

Binary package hint: vino

Tried to share my desktop and got an apport dialog.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: vino 2.31.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia wl
Architecture: amd64
Date: Thu Sep 2 11:39:05 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/vino/vino-server
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: /usr/lib/vino/vino-server --sm-disable
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
Signal: 5
SourcePackage: vino
StacktraceTop:
 dbus_g_connection_register_g_object (
 tp_base_client_register ()
 ?? ()
 g_type_create_instance ()
 ?? () from /usr/lib/libgobject-2.0.so.0
Title: vino-server crashed with signal 5 in dbus_g_connection_register_g_object()
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd lpadmin netdev plugdev sambashare tape video

Ted Gould (ted) wrote :
visibility: private → public
bojo42 (bojo42) wrote :

yep vino is always crashing when you try to share the desktop with empathy. both of my test machines where running the live image of maverick beta i386, so using plain stock setup. this bug means that desktop sharing on maverick is currently broken.

summary: - Trying to share my desktop with Empathy
+ [maverick] Vino crashes on desktop sharing with Empathy
Changed in vino (Ubuntu):
status: New → Confirmed
bojo42 (bojo42) on 2010-09-06
Changed in empathy (Ubuntu):
status: New → Confirmed
Changed in vino (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
summary: - [maverick] Vino crashes on desktop sharing with Empathy
+ crashes on desktop sharing with Empathy
summary: - crashes on desktop sharing with Empathy
+ vino crashes on desktop sharing with Empathy
Changed in vino (Ubuntu):
status: Confirmed → Triaged
Changed in empathy (Ubuntu):
importance: Undecided → Low
status: Confirmed → Invalid
Changed in vino (Ubuntu):
importance: Undecided → Low
assignee: Robert Ancell (robert-ancell) → nobody
Changed in vino:
status: Unknown → In Progress
Guillaume Desmottes (cassidy) wrote :

If it crashes when trying to share that probably means Vino was not running
previoulsy (according to the trace, it crashes when trying to register the TP
client which is done when starting Vino).

Could you try to start Vino manually first and see if that helps? Use
"VINO_SERVER_DEBUG=tube /usr/lib/vino/vino-server" so you'll have some debug
output.

Sebastien Bacher (seb128) wrote :

The bug seems to be due to the indicator changes, Ken could you see what is wrong since it's you who got those reviewed and uploaded?

Changed in vino (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Low → High
Sebastien Bacher (seb128) wrote :

easy way to get the bug:
* run /usr/lib/vino/vino-server on a command line
* run empathy
* right click on a contact and share your desktop with the contact

the command line has those errors

""(vino-server:3173): GLib-GObject-WARNING **: g_object_new_valist: object class
`VinoTubeServer' has no property named `display-status-icon'

** (vino-server:3173): CRITICAL **: vino_server_init_from_screen: assertion
`screen != NULL' failed

(vino-server:3173): GLib-GObject-CRITICAL **: g_object_ref: assertion
`G_IS_OBJECT (object)' failed

(vino-server:3173): GLib-GObject-CRITICAL **: g_object_ref: assertion
`G_IS_OBJECT (object)' failed

** ERROR **: Failed to register GObject with DBusConnection"

Comment from Guillaume on the upstream bug

"This sounds wrong. VinoTube Server inherits from VinoServer which implements
this property."

The code copy for the indicator probably needs to be updated to match upstream changes

Changed in vino:
status: In Progress → Invalid

StacktraceTop:
 g_markup_collect_attributes (
 ?? ()
 ?? ()
 client_state_waiting_for_reject ()
 ?? ()

Download full text (5.3 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1: installed version 1:4.5.1-2ubuntu2, latest version: 1:4.5.1-5ubuntu1
libxrender1: installed version 1:0.9.6+git20100705.d3d20437-0ubuntu0sarvatt, latest version: 1:0.9.6-1
libdrm-radeon1: installed version 2.4.21+git20100830.23287f05-0ubuntu0sarvatt, latest version: 2.4.21-1ubuntu2
passwd: installed version 1:4.1.4.2-1ubuntu2, latest version: 1:4.1.4.2-1ubuntu3
udev: installed version 161+git20100825-1, latest version: 161+git20100827-1
mountall: installed version 2.16, latest version: 2.17
libxinerama1: installed version 2:1.1+git20100605.d8a51c48-0ubuntu0sarvatt, latest version: 2:1.1-3
libdrm-nouveau1: installed version 2.4.21+git20100830.23287f05-0ubuntu0sarvatt, latest version: 2.4.21-1ubuntu2
libxext6: installed version 2:1.1.2+git20100705.23643bd1-0ubuntu0sarvatt, latest version: 2:1.1.2-1
libxfixes3: installed version 1:4.0.5+git20100705.01e803ae-0ubuntu0sarvatt, latest version: 1:4.0.5-1
libgtk2.0-0: installed version 2.21.6-1ubuntu3, latest version: 2.21.7-1ubuntu1
libxcursor1: installed version 1:1.1.10+git20100604.0caadca5-0ubuntu0sarvatt, latest version: 1:1.1.10-2
vino: installed version 2.31.4-0ubuntu1, latest version: 2.31.91-0ubuntu1
libudev0: installed version 161+git20100825-1, latest version: 161+git20100827-1
libxcb-shm0: installed version 1.6+git20100703.75ff427d-0ubuntu0sarvatt2, latest version: 1.6-1
gcc-4.4-base: installed version 4.4.4-9ubuntu2, latest version: 4.4.4-14ubuntu1
libxrandr2: installed version 2:1.3.0+git20100604.18517a55-0ubuntu0sarvatt, latest version: 2:1.3.0-3
libdbusmenu-glib1: installed version 0.3.12-0ubuntu2~ppa1~signal2, latest version: 0.3.13-0ubuntu1
libsqlite3-0: installed version 3.7.0.1-1, latest version: 3.7.2-1
gcc-4.5-base: installed version 4.5.1-2ubuntu2, latest version: 4.5.1-5ubuntu1
libgnome-keyring0: installed version 2.30.1-1ubuntu1, latest version: 2.31.91-0ubuntu1
libdrm-intel1: installed version 2.4.21+git20100830.23287f05-0ubuntu0sarvatt, latest version: 2.4.21-1ubuntu2
libklibc: installed version 1.5.18-1, latest version: 1.5.20-1
libglib2.0-0: installed version 2.25.14-1ubuntu2, latest version: 2.25.15-0ubuntu2
libxtst6: installed version 2:1.1.0+git20100705.1676c80d-0ubuntu0sarvatt, latest version: 2:1.1.0-3
libx11-data: installed version 2:1.3.4+git20100720.554da76e-0ubuntu0sarvatt3, latest version: 2:1.3.3-3ubuntu1
libxcomposite1: installed version 1:0.4.2+git20100705.01c4691e-0ubuntu0sarvatt, latest version: 1:0.4.2-1
libcups2: installed version 1.4.4-3, latest version: 1.4.4-3ubuntu1
libxcb-render0: installed version 1.6+git20100703.75ff427d-0ubuntu0sarvatt2, latest version: 1.6-1
cpp-4.4: installed version 4.4.4-9ubuntu2, latest version: 4.4.4-14ubuntu1
libappindicator1: installed version 0.2.6-0ubuntu1, latest version: 0.2.7-0ubuntu1
libc-bin: installed version 2.12.1-0ubuntu1, latest version: 2.12.1-0ubuntu4
libxdamage1: installed version 1:1.1.3+git20100705.8abc1c8e-0ubuntu0sarva...

Read more...

tags: removed: need-amd64-retrace
Changed in vino:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in vino (Ubuntu Maverick):
assignee: Ken VanDine (ken-vandine) → Karl Lattimer (karl-qdh)
Karl Lattimer (karl-qdh) wrote :

kenvandine gave me a hint that all that's left to do on this one is to fix the issue of not having the name in the menu

Changed in vino (Ubuntu Maverick):
status: Triaged → In Progress
Colin Watson (cjwatson) wrote :

vino (2.31.91-0ubuntu2) maverick; urgency=low

  * debian/patches/12_app-indicators-only.patch
    - Fix crasher in (LP: #628967)
    - Introduces a regression, but at least fixes the crasher, we can't lookup
      the contact's alias at the time the menu is created.

 -- Ken VanDine <email address hidden> Mon, 13 Sep 2010 18:37:26 -0400

Changed in vino (Ubuntu Maverick):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.