Unreadable hint in Remote Desktop Preferences

Bug #533520 reported by Luca Ferretti on 2010-03-06
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
vino
Fix Released
Low
vino (Ubuntu)
Medium
Martin Pitt
Lucid
Medium
Martin Pitt

Bug Description

Binary package hint: light-themes

The Remote Desktop Preferences dialog shows a box hinting the current status of vnc server and how to connect to it. Unfortunately the colors are the ones for GtkTooltips, leading to unreadable text.

Here is attached a screenshot.

Something like the GtkInfoBar colors could be better. I'll open a bug against vino on bugzilla.gnome.org asking to use this widget to show that info.

# Steps to reproduce #
  * Apply Radiance or Ambiance theme
  * Open System -> Preferences -> Remote Desktop

ProblemType: Bug
Architecture: i386
Date: Sat Mar 6 23:40:20 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: light-themes 0.1.5.4
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: light-themes
Uname: Linux 2.6.32-15-generic i686

Luca Ferretti (elle.uca) wrote :
Luca Ferretti (elle.uca) wrote :

There is yet an open bug for vino: https://bugzilla.gnome.org/show_bug.cgi?id=588784
I'm unable to link it here using "Also affects project" :(

Luca Ferretti (elle.uca) wrote :

Sorry, there was a spurious gnome-screenshot window in previous screenshot.

James Schriver (dashua) wrote :

It presently takes the the tooltip_bg color. I'm trying to come up with a workaround. The only solution I see is lightening the tooltip_bg color somewhat.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Luca Ferretti (elle.uca) wrote :

Maybe there is another way to workaround it. Here [1] is the code related to the vino message box area widget. It seems the widget itself is named "gtk-tooltip".

GtkRc should allow you to (see [2]) to apply a custom style to a specific widget in a specific application. Something like the following should work.

  style "vino-message-area-fix"
  {
    ## insert here proper color
  }

  widget "vino.gtk-tooltip" style "vino-message-area-fix"

Of course it's totally untested and needs more investigation.

[1] http://pastebin.ubuntu.com/390461/
[2] http://live.gnome.org/GnomeArt/Tutorials/GtkThemes#widget_matches

Kenneth Wimer (kwwii) wrote :

Vino appears to use the bg colour set for the tooltips but not the fg colour. Sounds like a bug in gtk/vino to me.

Conn O Griofa (psyke83) wrote :

Kenneth,

Even if the application uses the correct @tooltip_fg_color, the application may still look odd due to the new themes using such a dark purple colour for the tooltip background. The author chose that colour with the impression that tooltips always using a light background colour (which is almost always the case, except for dark themes).

I'm attaching a patch against vino for consideration, that merely removes the use of the "gtk-tooltip" type in the code (note that the author specifically refers to it as a hack ;)).

tags: added: patch
Kenneth Wimer (kwwii) on 2010-03-09
Changed in light-themes (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Kenneth Wimer (kwwii)
Kenneth Wimer (kwwii) on 2010-03-09
Changed in light-themes (Ubuntu):
assignee: Kenneth Wimer (kwwii) → nobody
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Lorenzo De Liso (blackz) wrote :

Added the bug watch of the gnome's bugs tracker.

affects: light-themes (Ubuntu) → vino (Ubuntu)
Martin Pitt (pitti) on 2010-04-06
Changed in vino (Ubuntu Lucid):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Uploaded, will hit lucid after beta-2 release.

Changed in vino (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 2.28.2-0ubuntu2

---------------
vino (2.28.2-0ubuntu2) lucid; urgency=low

  * Add 03_remove_tooltip_bg.patch: Remove "gtk-tooltip" style from
    preferences dialog, which causes unreadable text with some themes. This is
    a quick workaround until the widget is properly redesigned to be a
    GtkInfoBar. Thanks to Conn O Griofa for the patch! (LP: #533520)
  * debian/control.in: Add missing Vcs-Bzr:.
 -- Martin Pitt <email address hidden> Tue, 06 Apr 2010 18:12:29 +0200

Changed in vino (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in vino:
status: Unknown → New
Changed in vino:
status: New → Fix Released
Changed in vino:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.