Notification always appears even when disabled - Jaunty

Bug #318708 reported by Philip Wyett on 2009-01-19
4
Affects Status Importance Assigned to Milestone
vino (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: vino

Distro: Jaunty

Problem:

Notification always appears even when disabled.

Reproduce:

 * Setup Remote Desktop to under the "Advanced" tab "Notification Area" section. Select "Never display and icon".
 * VNC into the jaunty machine now by your preferred method.
   Note: I use Terminal Services Client with xvnc4viewer.

What happens:

You see the notification in the top right corner.

What should happen:

You should not see the notification.

Related branches

Philip Wyett wrote:
> Notification always appears even when disabled.
>
> Reproduce:
>
> * Setup Remote Desktop to under the "Advanced" tab "Notification Area" section. Select "Never display and icon".
> * VNC into the jaunty machine now by your preferred method.
> Note: I use Terminal Services Client with xvnc4viewer.
>
> What happens:
>
> You see the notification in the top right corner.

I can't reproduce it (I connected with vinagre but that shouldn't matter).
Sebastien Bacher can't either. (we have tested with 2.25.4). 2.25.5 have just
been uploaded, can you retest with it when it appears in your mirror?

Thanks

Philip Wyett (philwyett) wrote :

See video even with latest vino installed as this illustrates the issue.

Philip Wyett wrote:
> See video even with latest vino installed as this illustrates the issue.

Thanks for the video! Indeed, it's more clear now :)

I can't see the tray icon appearing there, but the libnotify bubble.

Jonh, is this a bug? Should the libnotify bubble appear when the tray icon is
disabled?

Jonh Wendell (wendell) wrote :

Thanks for the bug reporting. I just fixed it upstream:
http://svn.gnome.org/viewvc/vino?view=revision&revision=1056

The fix will be released in Vino 2.25.90.

Changed in vino:
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 2.25.90-0ubuntu1

---------------
vino (2.25.90-0ubuntu1) jaunty; urgency=low

  * New upstream release
    - Only show notification if the status icon is visible. (LP: #318708)
    - Fix drawing issues in the connectivity label.
    - Uses a file containing links to webservices, instead of use a hard coded one.
    - Shows an IP address instead of the local hostname in the connectivity label.
  * Update debian/watch

 -- <email address hidden> (Jorge O. Castro) Fri, 06 Feb 2009 14:40:25 +0100

Changed in vino:
status: Fix Committed → Fix Released
Philip Wyett (philwyett) wrote :

Confirm as fixed here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers