vino-preferences port range set goes from 5000 to 49999

Bug #264315 reported by MarcoBazzani on 2008-09-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vino (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: vino

when you configure a port different from 5900 on vino-preferences the allowed ports are from 5000 to 49999 lower or higher port doesn't get into listen mode
you can check it by changing the port while running this command

watch -n0.1 "sudo netstat -aptun |grep vino "

the gui should notify this to the user (good)
or allow to bind to all ports (better)
or remove the possiblity to change the port number and leave the user without this option (worst)

Related branches

MarcoBazzani (visik7) on 2008-09-03
description: updated
Didier Roche (didrocks) wrote :

the new version of vino 2.24.1 seems to fix it.

Changed in vino:
assignee: nobody → didrocks
status: New → In Progress
assignee: didrocks → nobody
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 2.24.1-0ubuntu1

---------------
vino (2.24.1-0ubuntu1) intrepid; urgency=low

  * New upstream version (LP: #286555)
    - Propagates port changes via avahi. (LP: #264315)
    - Update label in vino-preferences when the port changes.
    - Hopefully fix an window empty bug
    - Only restore the wallpaper when the last client disconnects.
      (LP: #266932)
    - Updated translations: ar, be@latin, bg, it

 -- Didier Roche <email address hidden> Mon, 20 Oct 2008 20:40:59 +0200

Changed in vino:
status: Confirmed → Fix Released
Didier Roche (didrocks) wrote :

After having discussed with jwendell, I misunderstood the bug : I tested the new version on some ports around default one (5900), not out of this range.

I reopen the bug, sorry.

Changed in vino:
status: Fix Released → Confirmed
AndreK (andre-k) wrote :

Also, in Ubuntu 9.04 alpha, port cannot longer be changed - but it's still the one I configured before - but I don't know how to change it. (don't know where it's saved)

AndreD wrote:
> Also, in Ubuntu 9.04 alpha, port cannot longer be changed - but it's
> still the one I configured before - but I don't know how to change it.
> (don't know where it's saved)

In GConf. You can change it from gconf-editor. Go to apps/vinagre from it.

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in vino (Ubuntu):
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers