vino-server crashed with SIGSEGV in _XSend()

Bug #1724572 reported by Nico Jabin on 2017-10-18
98
This bug affects 12 people
Affects Status Importance Assigned to Milestone
vino
Fix Released
Critical
vino (Debian)
Fix Released
Unknown
vino (Ubuntu)
High
Unassigned

Bug Description

Following upgrade from 17.04 (Gnome) to 17.10.

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: vino 3.8.1-0ubuntu12
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CrashCounter: 1
CurrentDesktop: GNOME
Date: Wed Oct 18 12:59:52 2017
ExecutablePath: /usr/lib/vino/vino-server
InstallationDate: Installed on 2017-04-17 (183 days ago)
InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Release amd64 (20170412)
JournalErrors:
 Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] failed with exit code 1: Hint: You are currently not seeing messages from other users and the system.
       Users in the 'systemd-journal' group can see all messages. Pass -q to
       turn off this notice.
 No journal files were opened due to insufficient permissions.
ProcCmdline: /usr/lib/vino/vino-server
ProcEnviron:
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
SegvAnalysis:
 Segfault happened at: 0x7f2a587b63ce <_XSend+126>: mov (%rax),%rdx
 PC (0x7f2a587b63ce) ok
 source "(%rax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: vino
StacktraceTop:
 _XSend () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XQueryExtension () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libXtst.so.6
 XTestQueryExtension () from /usr/lib/x86_64-linux-gnu/libXtst.so.6
 ?? ()
Title: vino-server crashed with SIGSEGV in _XSend()
UpgradeStatus: Upgraded to artful on 2017-10-18 (0 days ago)
UserGroups: sudo

Nico Jabin (nico-jabin) wrote :

StacktraceTop:
 _XSend (dpy=dpy@entry=0x558127139100, data=data@entry=0x7f2a58576f30 "XInputExtension", size=15) at ../../src/xcb_io.c:447
 XQueryExtension (dpy=dpy@entry=0x558127139100, name=name@entry=0x7f2a58576f30 "XInputExtension", major_opcode=major_opcode@entry=0x7ffe5c2962fc, first_event=first_event@entry=0x7ffe5c296300, first_error=first_error@entry=0x7ffe5c296304) at ../../src/QuExt.c:47
 get_xinput_base (dpy=0x558127139100) at ../../src/XTest.c:79
 find_display (dpy=0x558127139100) at ../../src/XTest.c:83
 XTestQueryExtension (dpy=dpy@entry=0x558127139100, event_base_return=event_base_return@entry=0x7ffe5c2963ac, error_base_return=error_base_return@entry=0x7ffe5c2963ac, major_return=major_return@entry=0x7ffe5c2963ac, minor_return=minor_return@entry=0x7ffe5c2963ac) at ../../src/XTest.c:101

Changed in vino (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vino (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

information type: Private → Public
Changed in vino (Ubuntu):
importance: Medium → High
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

vino doesn't work under wayland and should try to start in that session, did you try to start it manually?

Changed in vino:
importance: Unknown → Critical
status: Unknown → Confirmed
Changed in vino (Debian):
status: Unknown → Confirmed
tags: added: bionic
Changed in vino:
status: Confirmed → Fix Released
Changed in vino (Debian):
status: Confirmed → Fix Released
Mark (1aunchpad-nct) wrote :

When will this fix be completed in Ubuntu. I am running 18.04 and, because of this bug, can't use screen sharing when using Wayland.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.