Activity log for bug #1607663

Date Who What changed Old value New value Message
2016-07-29 07:40:09 Florian Apolloner bug added bug
2016-08-01 15:31:05 Jeremy Bicha bug task added ubuntu-gnome
2016-09-26 12:40:31 Launchpad Janitor vino (Ubuntu): status New Confirmed
2016-10-02 02:37:16 Jeremy Bicha vino (Ubuntu): importance Undecided High
2016-10-02 02:37:20 Jeremy Bicha vino (Ubuntu): status Confirmed Triaged
2016-10-02 02:37:27 Jeremy Bicha nominated for series Ubuntu Xenial
2016-10-02 02:37:27 Jeremy Bicha bug task added vino (Ubuntu Xenial)
2016-10-02 02:37:37 Jeremy Bicha vino (Ubuntu Xenial): importance Undecided High
2016-10-02 02:37:41 Jeremy Bicha vino (Ubuntu Xenial): status New Triaged
2016-10-02 02:37:45 Jeremy Bicha ubuntu-gnome: importance Undecided High
2016-10-02 02:37:48 Jeremy Bicha ubuntu-gnome: status New Triaged
2016-10-02 02:37:55 Jeremy Bicha vino (Ubuntu): status Triaged Fix Committed
2016-10-02 03:01:00 Jeremy Bicha description The vino-server does currently not autostart if one enables it via the sharing settings in gnome-control-center. Running gnome-settings-daemon -r --debug shows that it tries to locate vino-server.desktop which it cannot find and therefore fails to start. Looking at the debian package, a confirmed and working fix for Ubuntu 16.04 is: sudo ln -s /etc/xdg/autostart/vino-server.desktop /usr/share/applications/vino-server.desktop or only shipping that file in /usr/share/application Impact ====== The Desktop Sharing option in GNOME's Settings apps silently doesn't work. Test Case ========= On the host computer: 1. In Ubuntu GNOME, open the Settings app. 2. Open the Sharing panel. 3. In the headerbar, turn on Sharing. 4. Click Screen Sharing. Turn it On. (If it was already On, turn it off then On.) On the guest computer: 5. From a different computer connected to the same local network, attempt to connect to the local For this, you can install Vinagre. Click Connect. Use Protocol: VNC and enter the IP address for the test computer in the Host: field. Click Connect. On the host computer: 6. You probably need to approve a popup message to allow the remote user to connect. Regression Potential ==================== This only adds a symlinked NoDisplay=true .desktop to /usr/share/applications/ Other Info ========== The fix for Ubuntu 16.10 is a bit different. There we can just backport the systemd service file added to vino 3.22 since gnome-settings-daemon 3.22 handles sharing services via systemd user services. I verified that the extra .service file does not affect the way vino-preferences works in Unity 16.10. It's just ignored and manually trying to start the service in Unity doesn't work either which is fine. For 17.04+ we should look at having Unity use the systemd user service too. Original Bug Report with Workaround =================================== Running gnome-settings-daemon -r --debug shows that it tries to locate vino-server.desktop which it cannot find and therefore fails to start. Looking at the debian package, a confirmed and working fix for Ubuntu 16.04 is: sudo ln -s /etc/xdg/autostart/vino-server.desktop /usr/share/applications/vino-server.desktop or only shipping that file in /usr/share/application
2016-10-02 03:08:33 Jeremy Bicha vino (Ubuntu Xenial): status Triaged In Progress
2016-10-02 03:08:40 Jeremy Bicha ubuntu-gnome: status Triaged Fix Committed
2016-10-02 10:15:03 Launchpad Janitor vino (Ubuntu): status Fix Committed Fix Released
2016-10-02 12:15:06 Jeremy Bicha tags xenial yakkety
2016-10-03 15:28:56 Jeremy Bicha description Impact ====== The Desktop Sharing option in GNOME's Settings apps silently doesn't work. Test Case ========= On the host computer: 1. In Ubuntu GNOME, open the Settings app. 2. Open the Sharing panel. 3. In the headerbar, turn on Sharing. 4. Click Screen Sharing. Turn it On. (If it was already On, turn it off then On.) On the guest computer: 5. From a different computer connected to the same local network, attempt to connect to the local For this, you can install Vinagre. Click Connect. Use Protocol: VNC and enter the IP address for the test computer in the Host: field. Click Connect. On the host computer: 6. You probably need to approve a popup message to allow the remote user to connect. Regression Potential ==================== This only adds a symlinked NoDisplay=true .desktop to /usr/share/applications/ Other Info ========== The fix for Ubuntu 16.10 is a bit different. There we can just backport the systemd service file added to vino 3.22 since gnome-settings-daemon 3.22 handles sharing services via systemd user services. I verified that the extra .service file does not affect the way vino-preferences works in Unity 16.10. It's just ignored and manually trying to start the service in Unity doesn't work either which is fine. For 17.04+ we should look at having Unity use the systemd user service too. Original Bug Report with Workaround =================================== Running gnome-settings-daemon -r --debug shows that it tries to locate vino-server.desktop which it cannot find and therefore fails to start. Looking at the debian package, a confirmed and working fix for Ubuntu 16.04 is: sudo ln -s /etc/xdg/autostart/vino-server.desktop /usr/share/applications/vino-server.desktop or only shipping that file in /usr/share/application Impact ====== The Desktop Sharing option in GNOME's Settings apps silently doesn't work. Test Case ========= On the host computer: 1. In Ubuntu GNOME, open the Settings app. 2. Open the Sharing panel. 3. In the headerbar, turn on Sharing. 4. Click Screen Sharing. Turn it On. (If it was already On, turn it off then On.) On the guest computer: 5. From a different computer connected to the same local network, attempt to connect to the host computer. For this, you can install Vinagre. Click Connect. Use Protocol: VNC and enter the IP address for the test computer in the Host: field. Click Connect. On the host computer: 6. You probably need to approve a popup message to allow the remote user to connect. Regression Potential ==================== This only adds a symlinked NoDisplay=true .desktop to /usr/share/applications/ Other Info ========== The fix for Ubuntu 16.10 is a bit different. There we can just backport the systemd service file added to vino 3.22 since gnome-settings-daemon 3.22 handles sharing services via systemd user services. I verified that the extra .service file does not affect the way vino-preferences works in Unity 16.10. It's just ignored and manually trying to start the service in Unity doesn't work either which is fine. For 17.04+ we should look at having Unity use the systemd user service too. Original Bug Report with Workaround =================================== Running gnome-settings-daemon -r --debug shows that it tries to locate vino-server.desktop which it cannot find and therefore fails to start. Looking at the debian package, a confirmed and working fix for Ubuntu 16.04 is: sudo ln -s /etc/xdg/autostart/vino-server.desktop /usr/share/applications/vino-server.desktop or only shipping that file in /usr/share/application
2016-10-05 07:23:23 Martin Pitt vino (Ubuntu Xenial): status In Progress Fix Committed
2016-10-05 07:23:25 Martin Pitt bug added subscriber Ubuntu Stable Release Updates Team
2016-10-05 07:23:28 Martin Pitt bug added subscriber SRU Verification
2016-10-05 07:23:32 Martin Pitt tags xenial yakkety verification-needed xenial yakkety
2017-01-07 11:37:59 Ikuya Awashiro bug added subscriber Ikuya Awashiro
2017-05-21 12:57:45 pasdVn tags verification-needed xenial yakkety verification-done xenial yakkety
2017-05-21 12:58:32 pasdVn bug added subscriber pasdVn
2017-05-24 00:52:17 Launchpad Janitor vino (Ubuntu Xenial): status Fix Committed Fix Released
2017-05-24 00:52:24 Chris Halse Rogers removed subscriber Ubuntu Stable Release Updates Team
2017-11-07 09:10:10 Mantas Kriaučiūnas bug added subscriber Mantas Kriaučiūnas