Ubuntu

incorrect schema setting used for authentication-methods in vino server

Reported by fedsed on 2012-07-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vino
Fix Released
Medium
vino (Ubuntu)
Low
Unassigned
Precise
Low
Ritesh Khadgaray
Raring
Low
Unassigned

Bug Description

[Impact]

 * User is unable to update authentication method via dconf-editor
 * When editing the value /desktop/gnome/remote-access/authentication-methods there is a error "Error setting value: 0-4: unknown keyword" OR "Error setting value: 0-3:unknown keyword" .

[Test Case]

 * Install vino and dcont-tools on system
 * Open dconf-editor
 * Try to edit key " /desktop/gnome/remote-access/authentication-methods"

[Regression Potential]

 * This has zero regression potential. Worst case, user has to manually set the authentication method via dconf-editor. vino preferences automatically sets this up correctly.

  * This fix has been merged into upstream .

[Other info]

 * upstream merge
   - https://git.gnome.org/browse/vino/commit/?id=130d6a4a1f4f6e90586d42903484e5899459c403
  - https://git.gnome.org/browse/vino/commit/?id=b22249a387c2e6a80a1d7fee256dc14b71b70235

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in d-conf (Ubuntu):
status: New → Confirmed
Leonardo Borda (lborda) wrote :

I can confirm that it does not allow one to set authentication-methods.

You can brute force by running the following:

gsettings set org.gnome.Vino authentication-methods "['vnc']"

Leo

Changed in d-conf (Ubuntu):
importance: Undecided → Low
affects: dconf → vino
affects: d-conf (Ubuntu) → vino (Ubuntu)
summary: - dconf-editor not edit authentication-metnods in vino server
+ incorrect schema setting used for authentication-methods in vino server
Changed in vino:
importance: Unknown → Medium
status: Unknown → New
Ritesh Khadgaray (khadgaray) wrote :

We have a major customer looking for a fix to this issue in precise.

Ritesh Khadgaray (khadgaray) wrote :

[IMPACT]

 * User is unable to change the auth method in vino using dconf-editor.

 * This is a trivial fix, and awaiting on upstream.

 * The patch attached to upstream bz. authentication-methods is listed as type "as", and but the value is stored as
string.

[TESTCASE]

 * When editing the value /desktop/gnome/remote-access/authentication-methods there is a error "Error setting value: 0-4: unknown keyword"

 * Apply the patch, and the issue is resolved.

[Regression Potential]

 * Minimal regression potential, and is a trivial patch to apply or revert from.

 * This should not cause any issues, based on the tests I ran locally. Has zero security implications

[Other Info]

 * Currently waiting on upstream to accept the stated patch.

The attachment "proposed patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

discussion about the patch and how correct it is are happening upstream, seems like it shouldn't be sponsored yet

Sebastien Bacher (seb128) wrote :

note that it might just be a bug in dconf-editor, using the gsettings command line to set the value is an easy workaround

Leonardo Borda (lborda) wrote :

Hi Seb128, Ritesh

The workaround does work however imo the fix should be included in the Ubuntu packages. We have thousands of machines affected by this issue and since 12.04 is the LTS version customers are migrating from 10.04. They are all being affected by that issue.

Could you guys check with upstream what's the best for having this fixed?

Leo

Ritesh Khadgaray (khadgaray) wrote :

[Impact]

 * User is unable to update authentication method via dconf-editor
 * When editing the value /desktop/gnome/remote-access/authentication-methods there is a error "Error setting value: 0-4: unknown keyword" OR "Error setting value: 0-3:unknown keyword" .

[Test Case]

 * Install vino and dcont-tools on system
 * Open dconf-editor
 * Try to edit key " /desktop/gnome/remote-access/authentication-methods"

[Regression Potential]

 * This has zero regression potential. Worst case, user has to manually set the authentication method via dconf-editor. vino preferences automatically sets this up correctly.

[Other Info]

  * Still awaiting feedback from upstream on this for an alternate approach - https://bugzilla.gnome.org/show_bug.cgi?id=683103 . It seems from the talks, we are not supposed to mention choices for as (array of string), which vino does not follow through.

Ritesh Khadgaray (khadgaray) wrote :

Addendum

  Upstream is suggesting a lot more intrusive change , which I believe is unsuitable for precise. The best option would be to remove the choice option, as posted here ( sru/debdiff )

-- ritz

Sebastien Bacher (seb128) wrote :

@Leonardo: is using dconf-editor an hard requirement there? what's wrong with just running the gsettings command to change the value?

@Ritesh: I'm not convinced that diff is right, wouldn't it remove the choices listed from dconf-editor and turn that to an open input entry?

Sebastien Bacher (seb128) wrote :

(unsubscribing sponsors, I've been following that bug directly so no need to have it on the sponsoring queue for others)

Changed in vino:
status: New → Confirmed
Changed in vino (Ubuntu):
status: Confirmed → Triaged
Changed in vino:
status: Confirmed → Fix Released
Ritesh Khadgaray (khadgaray) wrote :

Hi @seb128

> @Ritesh: I'm not convinced that diff is right, wouldn't it remove the choices listed from dconf-editor and turn that to an open input entry?

This is the right way, and adopted by upstream [1]

[1] https://git.gnome.org/browse/vino/commit/?id=130d6a4a1f4f6e90586d42903484e5899459c403

-- ritz

Sebastien Bacher (seb128) wrote :

@Ritesh, I've uploaded to raring but it seems slightly buggy, as commented on the upstream bug:

"that commit seems slightly buggy, with it (applied on 3.6 for raring) I get that warning:

"vino_server_set_auth_methods: assertion `auth_methods != VINO_AUTH_INVALID' failed"

$ gsettings get org.gnome.Vino authentication-methods
@as []"

I'm holding on the precise upload until we sort that out

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 3.6.2-0ubuntu3

---------------
vino (3.6.2-0ubuntu3) raring; urgency=low

  * debian/patches/git_auth_methods_setting.patch:
    - incorrect schema setting used for authentication-methods in
      vino server ( lp: #1027086)
 -- Ritesh Khadgaray <email address hidden> Wed, 20 Mar 2013 22:12:06 +0530

Changed in vino (Ubuntu Raring):
status: Triaged → Fix Released
Ritesh Khadgaray (khadgaray) wrote :

Hi @seb128

  This is a harmless message, and can be ignored. Alternatively, we could remove the choice listing .

-- ritz

Sebastien Bacher (seb128) wrote :

@ritz: we shouldn't ignore those warning, they might stop run if people run in debug mode and they polute logs, please get the warning dropped upstream if it's buggy, thanks

Changed in vino:
status: Fix Released → Confirmed
Changed in vino:
status: Confirmed → Fix Released
Ritesh Khadgaray (khadgaray) wrote :

Updated patch

Ritesh Khadgaray (khadgaray) wrote :

Updated the patch to remove the earlier commit, and update the dconf schema

Chris J Arges (arges) on 2013-04-01
Changed in vino (Ubuntu Precise):
assignee: nobody → Ritesh Khadgaray (khadgaray)
importance: Undecided → Medium
status: New → In Progress
Sebastien Bacher (seb128) wrote :

@ritz: that solution still seems a bit buggy, now you can enter any value you want but it will complain about

"(vino-server:20654): GLib-GIO-WARNING **: Unable to lookup flags nick 'one' via GType"

when it's not 'none' or 'vnc', I uploaded to raring to fix the regression but that doesn't seem an improvement over what we have in the current precise version

description: updated
Ritesh Khadgaray (khadgaray) wrote :

Hi @seb128

> @ritz: that solution still seems a bit buggy, now you can enter any value you want but it will complain about

I dont see this as an issue, given that we allow for free form entry for many gnome applications. This would be an expected behaviour, until unless the application fails/breaks with invalid input.

If not, I will push for https://bug683103.bugzilla-attachments.gnome.org/attachment.cgi?id=238907 from gnome bz#683103 .

-- ritz

Didier Roche (didrocks) wrote :

I agree with seb128 on that one, I think we should have a better solution to get that fixed. Unsuscribing sponsors for now.

Ritesh Khadgaray (khadgaray) wrote :

Hi didrocks

> doesn't seem an improvement over what we have in the current precise version
The patch would allow user to enter value via dconf-editor

> "(vino-server:20654): GLib-GIO-WARNING **: Unable to lookup flags nick 'one' via GType"

From upstream - https://bugzilla.gnome.org/show_bug.cgi?id=683103#c21

(In reply to comment #20)
> this patch results in a warning message, if the user inputs an incorrect
> value into the field.
>
> "(vino-server:20654): GLib-GIO-WARNING **: Unable to lookup flags nick 'one'
> via GType"

Right, it is intended that bad input generates warnings.

> I believe attachment# 238907 [details] [details] is a more appropriate fix.

No, it is fine as is.

--------------------------------------------------------------

Cheers
-- ritz

Changed in vino (Ubuntu Precise):
assignee: Ritesh Khadgaray (khadgaray) → nobody
Changed in vino (Ubuntu Precise):
status: In Progress → Triaged
importance: Medium → Low
description: updated
description: updated
Sebastien Bacher (seb128) wrote :

@ritz: since that's what we have in newer series I sponsored it to precise as well

Changed in vino (Ubuntu Precise):
assignee: nobody → Jeff (ritz)
status: Triaged → In Progress
Changed in vino (Ubuntu Precise):
assignee: Jeff (ritz) → Ritesh Khadgaray (khadgaray)

Hello fedsed, or anyone else affected,

Accepted vino into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/vino/3.4.2-0ubuntu1.3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in vino (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: precise verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 3.4.2-0ubuntu1.3.1

---------------
vino (3.4.2-0ubuntu1.3.1) precise; urgency=low

  * debian/patches/lp1027086-dconf-key.patch:
    - incorrect schema setting used for authentication-methods (lp: #1027086)
 -- Ritesh Khadgaray <email address hidden> Wed, 27 Mar 2013 17:43:16 +0530

Changed in vino (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for vino has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.