SSH Tunnel Login only allows 8 character passwords

Bug #588532 reported by Harrison Neal on 2010-06-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vinagre (Ubuntu)
Low
Unassigned
Lucid
Low
Sebastien Bacher

Bug Description

Binary package hint: vinagre

The SSH Tunnel Login Dialog in Vinagre, similar to the Password Dialog in the same, only allows for passwords to be entered up to 8 characters. While this should be done for the standard password dialog as per the VNC protocol, the SSH protocol has no such restriction and users should be able to login to the SSH host with a password longer than 8 characters.

Expected: The SSH Tunnel Login Dialog would allow me to enter my full password for the remote SSH host used to tunnel the VNC connection.
Actual: I was only able to enter 8 characters.

Ubuntu 10.04, Vinagre 2.30.1-0ubuntu1

A quick patch. May be the chosen lenght is high, but for ssh-passwords there should be "no" restriction and even if there is a length-restriction for passwords in the vnc protocol it does not hurt if a client accept longer passwords. It is the business of the server to check that only protocol-conform passwords can be set.

Changed in vinagre (Ubuntu):
status: New → Fix Committed
Jonh Wendell (wendell) wrote :

Hi. This patch is wrong. Anyway, this is fixed upstream some time ago: http://git.gnome.org/browse/vinagre/commit/?id=e0721cd7c31291142117ec39da75d48ec4940db8

Also, see bug #483696

Hello

Just for curiosity and to learn for the future: Whats wrong with the patch? Formal failures?
It works for me here - and did not before the patch.

tags: added: patch
Changed in vinagre (Ubuntu):
importance: Undecided → Low
Changed in vinagre (Ubuntu Lucid):
assignee: nobody → Sebastien Bacher (seb128)
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

sru team, the debdiff for the lucid update is on bug #594746

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vinagre - 2.30.2-0ubuntu1.1

---------------
vinagre (2.30.2-0ubuntu1.1) maverick; urgency=low

  * New upstream version
    - Removed password length limit for SSH connections (lp: #588532)
    - Allows using of an alternative ssh port when doing tunnel
      (lp: #594746)
 -- Sebastien Bacher <email address hidden> Mon, 21 Jun 2010 16:53:47 +0200

Changed in vinagre (Ubuntu):
status: Fix Committed → Fix Released
Pedro Villavicencio (pedro) wrote :

Reproduced the bug with the package on Lucid and i can confirm that the proposed one fixes the bug, marking this as verification done, thanks all.

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vinagre - 2.30.2-0ubuntu1

---------------
vinagre (2.30.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream version
    - Removed password length limit for SSH connections (lp: #588532)
    - Allows using of an alternative ssh port when doing tunnel
      (lp: #594746)
 -- Sebastien Bacher <email address hidden> Mon, 21 Jun 2010 16:25:44 +0200

Changed in vinagre (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers