Ubuntu

Spurious delayed command line output when using gvim and gnome-shell

Reported by Tobias Quinn on 2012-04-04
112
This bug affects 25 people
Affects Status Importance Assigned to Milestone
vim (Ubuntu)
Undecided
Unassigned

Bug Description

When gvim is launched from the command line, gvim edits files correctly but after a delay the following line is output to the terminal:

** (gvim:32345): WARNING **: Unable to create Ubuntu Menu Proxy: Timeout was reached

This interrupts the flow of output in the terminal that gvim was launched from.

Tobias Quinn (tobias-quinn) wrote :

Precise 12.04 beta 2 with latest updates

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vim (Ubuntu):
status: New → Confirmed
James Shackleford (tshack) wrote :

Confirmed. Precise 12.04 beta2 with latest updates.
As a developer who uses Vim everyday - this bug would make 12.04 unusable for me.

Marius Gedminas (mgedmin) wrote :

Sounds very similar to bug 776499.

Tobias Quinn (tobias-quinn) wrote :

> Sounds very similar to bug 776499.

Placing this in ~/.bashrc seems to be a workaround

# workaround for gvim
function gvim () { /usr/bin/gvim -f $* & }

Vadim Rutkovsky (roignac) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 776499, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Tobias Quinn (tobias-quinn) wrote :

Removing ibus as per suggestion in #776499 doesn't get rid of the line output on the terminal (after about 20 seconds):

** (gvim:5620): WARNING **: Unable to create Ubuntu Menu Proxy: Timeout was reached

This is using gnome-shell 3.4.1, there is a menubar shown as gnome-shell doesn't have global menus so I'm not sure if this is actually a duplicate of https://bugs.launchpad.net/bugs/776499

Tim Starling (tstarling) wrote :

Please unduplicate.

I have confirmed that this problem does not occur in 7.3.314, and does occur in 7.3.315, which indicates that it's a problem related to the patch I wrote:

https://groups.google.com/group/vim_dev/browse_thread/thread/4a9b55c51847a44f/40c24aad020218b8?hl=en_US&lnk=gst

That patch was written after bug 776499 was filed, so it's not possible for it to be a duplicate.

It would have been nice to know about this a bit earlier, maybe someone upstream could have pointed you to a relevant developer if you raised it there.

Tim Starling (tstarling) wrote :

This was fixed in patch 7.3.520, same as bug 987707. But it's not a duplicate of bug 987707.

nobrain (dldz2002) wrote :

Yes, I encounter this problem on latest 12.04 with vim version 7.3.429.
As Tim said, this was fix in patch 7.3.520.
I wonder if it is possible to upgrade official repository vim package to that version ?

Norman Rasmussen (normanr) wrote :

any chance we can get a newer version of vim in precise? perhaps in precise-backports?

Norman Rasmussen (normanr) wrote :

btw, I installed vim-gnome_7.3.547 (and deps) from quantal, and I still can't see the menus :-(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers