vim-gnome ignores colorscheme setting from vimrc

Bug #951440 reported by Dariusz Gadomski on 2012-03-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vim (Ubuntu)
Undecided
Unassigned

Bug Description

For some time (about 2-3 weeks) I observe a regression in vim-gnome package.

For some reason it ignores the colorscheme setting on startup.

I have tested it with a simple one-line ~/.vimrc file:
colorscheme desert

Each time I start vim it has theme 'default' set, after I manually change it to 'desert' in runtime it switches correctly, but I need to do it each time after starting vim.

I have tried to purge the package and install it again, I have created a new user (to exclude any current user-related settings), added a 1-line .vimrc with just setting the theme. The result is always the same - vim starts with the default theme.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: vim-gnome 2:7.3.429-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Sat Mar 10 11:28:13 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: vim
UpgradeStatus: Upgraded to precise on 2012-02-03 (35 days ago)

Dariusz Gadomski (dgadomski) wrote :
Dariusz Gadomski (dgadomski) wrote :

This bug does not affect the console vim application. Running 'colorscheme' command in vim returns the requested 'desert' scheme. The issue concerns only vim-gnome.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vim (Ubuntu):
status: New → Confirmed
Kagetsuki (zero-tsuki) wrote :

I can confirm this issue. As a temporary workaround set colorscheme in .gvimrc. I'm guessing someone included a system wide default gvimrc which is being loaded after users local .vimrc?

Michael Bienia (geser) wrote :

Bah, I guess it's related to "fixing" bug #871907 where I set background=dark for vim by default and set background=light for gvim (to undo it). Will have to check if there is a better way to do it.

Michael Bienia (geser) wrote :

vim (2:7.3.429-2ubuntu2) precise; urgency=low

  * debian/runtime/vimrc, debian/runtime/gvimrc:
    Undo the changes from the previous upload as they conflict with/override
    user settings from ~/.vimrc (lp: #951440; re-open #871907).

 -- Michael Bienia <email address hidden> Sun, 11 Mar 2012 14:30:55 +0100

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vim - 2:7.3.429-2ubuntu2

---------------
vim (2:7.3.429-2ubuntu2) precise; urgency=low

  * debian/runtime/vimrc, debian/runtime/gvimrc:
    Undo the changes from the previous upload as they conflict with/override
    user settings from ~/.vimrc (lp: #951440; re-open #871907).
 -- Michael Bienia <email address hidden> Sun, 11 Mar 2012 14:30:55 +0100

Changed in vim (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers