Better vimrc default

Bug #63172 reported by Guillaume Desmottes on 2006-09-30
10
Affects Status Importance Assigned to Milestone
vim (Ubuntu)
Wishlist
Dustin Kirkland 
Declined for Hardy by Dustin Kirkland 

Bug Description

Since edgy indentation is not activated by default. The user has to uncomment 3 lines in /etc/vim/vimrc.
It's really disturbing and IMHO this essential feature should be activated by default.

I think we should enable syntax highlighting by default too.

Related branches

Mateusz Drożdżyński (matid) wrote :

Thanks for your suggestion. I agree that activating the indentation might be a good idea, but I doubt we will be able to enable the syntax highlighting, since vim-full isn't installed by default what as far as I know strips out the highlighting functionality.

Changed in vim:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed

Is this the autoindent option? If so I find it incredibly annoying in a Debian install I sometimes have to work on, as it makes pasting code from another app impossible without first disabling the setting.

Ajay (ajaygautam) wrote :

I vote for both auto-indent and color enabling.

>>> I doubt we will be able to enable the syntax highlighting

Well, I say, enable it, if the functionality is not available, the selection will not harm anything, now, would it ?
(PS: I just spent the last 20 minutes, trying to find where the color flag is. Found it, thanks to this bug description)

Misc: Not sure it matters: Gentoo has color highlight enabled by default (I don't remember setting this on my gentoo box).

Dustin Kirkland  (kirkland) wrote :

I'm confirming the "syntax on" portion of this bug. I think this is a very sane default when full vim is installed.

The indentation part, though, is more controversial, I'm afraid. Too often vim doesn't do the correct thing. Or, more precisely, there is no universal "correct" indentation.

I think we can fix the color part without offending too many people. I don't think we can fix the indentation part of this bug without offending a lot of people.

:-Dustin

Changed in vim:
assignee: nobody → kirkland
status: Confirmed → Triaged
Dustin Kirkland  (kirkland) wrote :

Colin-

Would you care to comment? What do you think?

:-Dustin

Changed in vim:
status: Triaged → In Progress
Colin Watson (cjwatson) wrote :

I agree regarding indentation. The description of this bug is not true; you just have to put 'set autoindent' in ~/.vimrc - not a big deal. IME the confusion caused by needing to do that is less than the confusion caused by people not realising that they need to do ':set paste' to paste things.

Turning on syntax highlighting when you install the full vim package would make sense.

Dustin Kirkland  (kirkland) wrote :

I've uploaded a fix for this in Jaunty. However, I declined this for Hardy. I don't think that this rises to the merit for an SRU in Hardy. It's a simple configuration change, with a trivial work around.

Cheers,
:-Dustin

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vim - 2:7.2.079-1ubuntu3

---------------
vim (2:7.2.079-1ubuntu3) jaunty; urgency=low

  * debian/runtime/vimrc: "syntax on" is a sane default for non-tiny vim,
    LP: #63172

 -- Dustin Kirkland <email address hidden> Thu, 05 Mar 2009 09:28:52 -0600

Changed in vim:
status: In Progress → Fix Released
James McCoy (jamessan) wrote :

Enabling syntax highlighting runs afoul of the same problem that caused me to stop enabling filetype plugins by default in the Debian package. It causes Vim to source various script from its runtimepath. This cannot be undone by the user and therefore makes the user unable to make certain configuration changes that must occur before those files are sourced.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers