Activity log for bug #407038

Date Who What changed Old value New value Message
2009-07-30 18:34:03 Bhavani Shankar bug added bug
2009-07-30 18:38:30 Bhavani Shankar attachment added debian > ubuntu diff http://launchpadlibrarian.net/29724864/debian.debdiff
2009-07-30 18:38:45 Bhavani Shankar vim (Ubuntu): status New Confirmed
2009-07-30 18:39:24 Bhavani Shankar tags merge
2009-08-20 13:02:41 Simon Olofsson vim (Ubuntu): status Confirmed Incomplete
2009-08-20 15:57:46 Bhavani Shankar vim (Ubuntu): status Incomplete In Progress
2009-08-20 15:57:58 Bhavani Shankar vim (Ubuntu): assignee Bhavani Shankar (bhavi)
2009-08-21 05:19:35 Daniel Holbach removed subscriber Ubuntu Sponsors for main
2009-08-21 14:39:53 Bhavani Shankar description Binary package hint: vim Debian has a new version to be merged vim (2:7.2.245-1) unstable; urgency=low [ James Vega ] * debian/rules: - [b131ea4] Remove SHELL=/bin/bash (again) along with the bashisms - [ac8c907] Build Vim to look for its (g)vimrc at /etc/vim/(g)vimrc, not in $VIM. This allows Vim to find the files even if /usr isn't mounted, in preparation for moving vim-tiny to /bin. - [24ab3e8] Remove calls to dh_desktop since desktop files are now handled by triggers. - [67f3b5b] Only install the UTF-8 versions of the man pages (Closes: #527744) * Debian-related runtime files: - [3071077] Remove gutsy as a valid distribution -- EOLed. - [be3e3b7] Add avr32 as a valid architecture. (Closes: #528438) - [1e21fa5] Fix the upload target highlighting so experimental isn't flagged as an error. (Closes: #532027) - [9ed9ffd] Syntax highlight X[SB]-Python-Version and XSBC-Original-Maintainer. (Closes: #536657) - [ab86bac] Properly highlight comments in multi-line fields in debian/control. * [ea1da8a] Update README for patches 149 - 191 * [f0b6a54] Update README for patches 192 - 196 * [6c7d809] Update README for patches 197 - 209 * [7489ef5] vim-variant.prerm: Cleanup of mis-handled alternatives is no longer needed * [7be3c83] vim-variant.postinst: Remove directory->symlink code from Etch * Lintian cleanups: - [0be1067] debian/control: Remove Priority fields from binary package stanzas if they're the same as the source package stanza. - [bfba0d4] debian/control: Add version for debhelper Build-Depends - [6fb245c] debian/control: Remove version for make Build-Depends - [d62624b] debian/control: Drop make from Build-Depends since we the version we were Build-Depending on is available in Lenny and it is a build-essential package. - [2fd98ed] Use “set -e” instead of passing -e on the shebang line for maintainer scripts. - [1759cb6] Fix hyphen-used-as-minus-sign in French man pages - [a749e25] Fix hyphen-used-as-minus-sign/manpage-has-errors-from-man in Russian man pages - [b9533d9] Fix hyphen-used-as-minus-sign in English man pages - [64aeabe] Fix manpage-has-errors-from-man in Polish man pages - [7125002] Fix hyphen-used-as-minus-sign in Italian man page - [4f9d282] Install upstream's README file which describes the patches made since the last major upstream release as the upstream changelog. * [fe81bdf] Restrict spell checking in matlab filetype to strings/comments (Closes: #509123) * [567c06a] Add debian/update-runtime script to automate syncing the latest runtime files from upstream's ftp site. * [6082754] Update README for patches 210 - 239 - [ef67fb5] [7.2.221] X cut_buffer0 text may be used in the wrong encoding (Closes: #531372) * [f8033cf] Sync runtime files from upstream's ftp - Support automatically reading/writing lzma files (Closes: #535665) * [8132670] Make NRead's behavior for HTTP consistent across backends. They will all download source by default but some can be configured to download rendered text. (Closes: #525422) * [cb968f3] Update README for patches 240 - 245 * [e1e7abe] Sync runtime files from upstream's ftp - Add LocalCommand keyword to sshconfig.vim (Closes: #536299) [ Stefano Zacchiroli ] * [5f48b8d] Removing myself from Uploaders list. -- James Vega <jamessan@debian.org> Wed, 29 Jul 2009 20:18:17 +0200 Binary package hint: vim Debian has a new version to be merged vim (2:7.2.245-2) unstable; urgency=low * [5263ec7] Add Suggests: indent to vim-tiny since it will invoke indent when the user tries to re-indent text without 'equalprg' set. (Closes: #531647) * [f24fadd] Restore previous behavior of Vim looking for its (g)vimrc in $VIM for non vim-tiny packages. Only vim-tiny will look in /etc/vimrc. -- James Vega <jamessan@debian.org> Thu, 30 Jul 2009 16:14:44 +0200  vim (2:7.2.245-1) unstable; urgency=low    [ James Vega ]    * debian/rules:      - [b131ea4] Remove SHELL=/bin/bash (again) along with the bashisms      - [ac8c907] Build Vim to look for its (g)vimrc at /etc/vim/(g)vimrc, not        in $VIM. This allows Vim to find the files even if /usr isn't mounted,        in preparation for moving vim-tiny to /bin.      - [24ab3e8] Remove calls to dh_desktop since desktop files are now handled        by triggers.      - [67f3b5b] Only install the UTF-8 versions of the man pages (Closes:        #527744)    * Debian-related runtime files:      - [3071077] Remove gutsy as a valid distribution -- EOLed.      - [be3e3b7] Add avr32 as a valid architecture. (Closes: #528438)      - [1e21fa5] Fix the upload target highlighting so experimental isn't        flagged as an error. (Closes: #532027)      - [9ed9ffd] Syntax highlight X[SB]-Python-Version and        XSBC-Original-Maintainer. (Closes: #536657)      - [ab86bac] Properly highlight comments in multi-line fields in        debian/control.    * [ea1da8a] Update README for patches 149 - 191    * [f0b6a54] Update README for patches 192 - 196    * [6c7d809] Update README for patches 197 - 209    * [7489ef5] vim-variant.prerm: Cleanup of mis-handled alternatives is      no longer needed    * [7be3c83] vim-variant.postinst: Remove directory->symlink code from      Etch    * Lintian cleanups:      - [0be1067] debian/control: Remove Priority fields from binary package        stanzas if they're the same as the source package stanza.      - [bfba0d4] debian/control: Add version for debhelper Build-Depends      - [6fb245c] debian/control: Remove version for make Build-Depends      - [d62624b] debian/control: Drop make from Build-Depends since we the        version we were Build-Depending on is available in Lenny and it is a        build-essential package.      - [2fd98ed] Use “set -e” instead of passing -e on the shebang line for        maintainer scripts.      - [1759cb6] Fix hyphen-used-as-minus-sign in French man pages      - [a749e25] Fix hyphen-used-as-minus-sign/manpage-has-errors-from-man in        Russian man pages      - [b9533d9] Fix hyphen-used-as-minus-sign in English man pages      - [64aeabe] Fix manpage-has-errors-from-man in Polish man pages      - [7125002] Fix hyphen-used-as-minus-sign in Italian man page      - [4f9d282] Install upstream's README file which describes the patches        made since the last major upstream release as the upstream changelog.    * [fe81bdf] Restrict spell checking in matlab filetype to      strings/comments (Closes: #509123)    * [567c06a] Add debian/update-runtime script to automate syncing the latest      runtime files from upstream's ftp site.    * [6082754] Update README for patches 210 - 239      - [ef67fb5] [7.2.221] X cut_buffer0 text may be used in the wrong encoding        (Closes: #531372)    * [f8033cf] Sync runtime files from upstream's ftp      - Support automatically reading/writing lzma files (Closes: #535665)    * [8132670] Make NRead's behavior for HTTP consistent across backends. They      will all download source by default but some can be configured to download      rendered text. (Closes: #525422)    * [cb968f3] Update README for patches 240 - 245    * [e1e7abe] Sync runtime files from upstream's ftp      - Add LocalCommand keyword to sshconfig.vim (Closes: #536299)    [ Stefano Zacchiroli ]    * [5f48b8d] Removing myself from Uploaders list.  -- James Vega <jamessan@debian.org> Wed, 29 Jul 2009 20:18:17 +0200
2009-08-21 14:40:29 Bhavani Shankar summary Please merge vim 7.2.245-1(main) from debian unstable(main) Please merge vim 7.2.245-2(main) from debian unstable(main)
2009-08-21 14:45:19 Bhavani Shankar attachment added Debian -> ubuntu debdiff http://launchpadlibrarian.net/30641815/debian.debdiff
2009-08-21 14:45:31 Bhavani Shankar vim (Ubuntu): status In Progress Confirmed
2009-08-21 14:45:38 Bhavani Shankar vim (Ubuntu): assignee Bhavani Shankar (bhavi)
2009-08-26 10:00:14 Launchpad Janitor vim (Ubuntu): status Confirmed Fix Released
2009-09-03 14:23:11 Launchpad Janitor branch linked lp:ubuntu/karmic/vim
2011-02-17 12:19:03 Daniel Holbach bug added subscriber Ubuntu Sponsors Team
2011-02-17 12:19:07 Daniel Holbach removed subscriber [DEPRECATED] Ubuntu Sponsors for main
2011-02-22 00:23:53 Benjamin Drung removed subscriber Ubuntu Sponsors Team