vim is dependent on libcanberra0 in Ubuntu 20.04, had no such dependency in Ubuntu 18.04

Bug #1884583 reported by Wladimir Mutel
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
vim (Debian)
Fix Released
Unknown
vim (Ubuntu)
Undecided
Unassigned

Bug Description

which pulls in libasound and some alsa packages which I am not sure why it is useful and desired on most text-only/headless systems.
In Debian I also see this dependency arisen with Bullseye/testing and Sid/unstable (but not with Buster/stable) but I don't see any mention of this introduction and its usefulness in the package's changelog. Could the reason of this dependency creation please be investigated, its usefulness evaluated, and if possible, this dependency to be made optional for vim builds ? Surprisingly, installing vim-nox also pulls in libcanberra0. vim-tiny does not pull in libcanberra0, but it also does not have syntax highlighting. What should I do to have syntax highlighting without libcanberra0 overhead ?

Revision history for this message
Kai Kasurinen (kai-kasurinen) wrote :
Revision history for this message
Wladimir Mutel (mwg) wrote :

So this is going to be kept forever ? For vim-nox as well ?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vim (Ubuntu):
status: New → Confirmed
Revision history for this message
Scott Mcdermott (smemsh) wrote :

This is really crazy, the package named "vim-nox" now requires an abstract sound library that uses XDG specification for sound, is packaged by GNOME maintainers, and pulls in several audio libraries and freedesktop sound theme? What on earth does that have to do with editing files, and how is that "nox"? The reason we use vim-nox is so all the desktop/gui/X nonsense isn't needed or installed on our systems. We don't want a stripped vim-tiny that's barely functional. Please revert this madness.

Revision history for this message
Scott Mcdermott (smemsh) wrote :
Revision history for this message
Scott Mcdermott (smemsh) wrote :

Upstream says they will not remove the sound library and its indirect freedesktop theme (35 sound files) dependencies because it's not a big deal, and it's not X so technically it's still 'nox'. I don't think this is sane for a package installed on many servers to start bringing in desktop requirements, but the maintainer is firm.

I'm hoping Ubuntu will consider overriding Debian and adding --disable-canberra to their vim-nox build.

Revision history for this message
Rudolph Pienaar (rudolph-pienaar) wrote :

Use 'neovim' instead. I too have no idea why 'vim' is needlessly linked to pulling sound libraries. This is bizarre esp for docker containers. Madness.

Revision history for this message
Adrien Beau (adrienbeau) wrote :

Also filed (and fixed!) in Arch Linux: https://bugs.archlinux.org/task/63073

A build switch was introduced in Vim 8.1.1529, so vim can be built with --disable-canberra.
Commit https://github.com/vim/vim/commit/21606676d9ebc6f159c56ee90733e5d5720ab3d7

Even though it is technically "no X", I think the underlying package philosophy is "no desktop", and bringing in sound-theme-freedesktop, Vorbis, Ogg and libasound very much goes against that.

That said, the "no X" build is a rather fat build with many dependencies to scripting languages, so disk size is not much of an argument for that package. On the other hand, the regular, main "vim" package has (or used to have) very few dependencies (3 on a barebone Ubuntu install). Canberra adds 9 more...

Please build "vim" with --disable-canberra: because it should have few dependencies
Please build "vim-nox" with --disable-canberra: because it should be "no desktop"

tags: added: focal packaging
Changed in vim (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.