Changing font size in a maximized window doesn't recalculate usable area

Bug #183760 reported by Chris Butler on 2008-01-17
6
Affects Status Importance Assigned to Milestone
vim (Debian)
Fix Released
Unknown
vim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vim-gnome

If you maximize a gvim window, and then change the font size, it fails to recalculate the usable area of the window, resulting in a display that either doesn't use all of the window, or tries to use too much.

Screenshot: http://www.crustynet.org.uk/~chrisb/gvimbug.png

Steps to reproduce:

Open gvim
:set gfn=Monospace\ 10
Maximize the window
:set gfn=Monospace\ 8

Version of ubuntu is gutsy, fully up-to-date. vim-gnome version 1:7.1-056+2ubuntu2

I can reproduce this bug with Ubuntu-8.04 using Vim-7.1.138 which comes with Hardy.
I can also still reproduce it if I compile the latest Vim-7.2.26.

Daniel T Chen (crimsun) wrote :

I presume this symptom remains reproducible in 9.04?

Changed in vim:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in vim:
status: Incomplete → Invalid

This bug is upstream but it's a valid bug. I really don't
understand why it gets marked as INVALID because someone
asked whether it happened in 9.04 (which has not even been
officially released yet since its only Jan 2009).

The bug still happens in the latest release Ubuntu-8.10 (Intrepid).

Chris Butler (chrisb-debian) wrote :

I have reopened this bug, as I don't believe it has been fixed, so should never have been closed in the first place. The bug is still open in Debian Lenny, and no-one's decided to randomly close it there.

The steps to reproduce it are so simple, I'm sure someone who has access to an Ubuntu 9.04 system can have a go. If there's really no-one available who can perform this simple 4-step test, then I will install a 9.04 VM and test it myself.

Changed in vim:
status: Invalid → New
Vitaly Minko (vitaly-minko) wrote :

Try this patch please. It works fine for me.

Changed in vim (Debian):
status: Unknown → Confirmed
Chris Butler (chrisb-debian) wrote :

I have tried the patch listed in this bug and I can confirm that it fixes the bug.

Changed in vim (Debian):
status: Confirmed → Fix Released
Changed in vim (Ubuntu):
status: New → Confirmed
James McCoy (jamessan) wrote :

This bug was fixed in version 2:7.2.284-1 of the Debian package, which was merged to Ubuntu in 2:7.2.330-1ubuntu1. This is available in Lucid (10.04).

Changed in vim (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.