Upgrading to 16.04 disables Python3?

Bug #1574897 reported by Michael Heuberger on 2016-04-25
This bug affects 6 people
Affects Status Importance Assigned to Milestone
vim (Ubuntu)
Adam Conrad
Adam Conrad

Bug Description

Since I ran a do-release-upgrade last week from 15.10 to 16.04, starting Vim now produces this warning I haven't seen before:

~/D/abc ❯❯❯ vim develop ✭
You need vim compiled with Python 2.6, 2.7 or 3.2 and later support
for Powerline to work. Please consult the documentation for more
Press ENTER or type command to continue

Then had a look at the included features of Vim:

/e/alternatives ❯❯❯ vim --version
VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Apr 08 2016 11:38:28)
Included patches: 1-1689
Modified by <email address hidden>
Compiled by <email address hidden>
Huge version without GUI. Features included (+) or not (-):
+acl +farsi +mouse_netterm +tag_binary
+arabic +file_in_path +mouse_sgr +tag_old_static
+autocmd +find_in_path -mouse_sysmouse -tag_any_white
-balloon_eval +float +mouse_urxvt -tcl
-browse +folding +mouse_xterm +terminfo
++builtin_terms -footer +multi_byte +termresponse
+byte_offset +fork() +multi_lang +textobjects
+channel +gettext -mzscheme +timers
+cindent -hangul_input +netbeans_intg +title
-clientserver +iconv +packages -toolbar
-clipboard +insert_expand +path_extra +user_commands
+cmdline_compl +job -perl +vertsplit
+cmdline_hist +jumplist +persistent_undo +virtualedit
+cmdline_info +keymap +postscript +visual
+comments +langmap +printer +visualextra
+conceal +libcall +profile +viminfo
+cryptv +linebreak -python +vreplace
+cscope +lispindent -python3 +wildignore
+cursorbind +listcmds +quickfix +wildmenu
+cursorshape +localmap +reltime +windows
+dialog_con -lua +rightleft +writebackup
+diff +menu -ruby -X11
+digraphs +mksession +scrollbind -xfontset
-dnd +modify_fname +signs -xim
-ebcdic +mouse +smartindent -xsmp
+emacs_tags -mouseshape +startuptime -xterm_clipboard
+eval +mouse_dec +statusline -xterm_save
+ex_extra +mouse_gpm -sun_workshop -xpm
+extra_search -mouse_jsbterm +syntax
   system vimrc file: "$VIM/vimrc"
     user vimrc file: "$HOME/.vimrc"
 2nd user vimrc file: "~/.vim/vimrc"
      user exrc file: "$HOME/.exrc"
  fall-back for $VIM: "/usr/share/vim"
Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -Wdate-time -g -O2 -fPIE -fstack-protector-strong -Wformat -Werror=format-security -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
Linking: gcc -Wl,-Bsymbolic-functions -fPIE -pie -Wl,-z,relro -Wl,-z,now -Wl,--as-needed -o vim -lm -ltinfo -lnsl -lselinux -lacl -lattr -lgpm -ldl

I see, there is -python and -python3

But all news and documentation say the Vim in Xenial 16.04 comes with Python3 enabled. I am confused? A bug?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vim (Ubuntu):
status: New → Confirmed
Lyle (mamadontgodaddycomehome) wrote :

I'm having the exactly same issue as described above for using powerline with my newly installed 16.04, which I've never met with 14.04.

Adam Conrad (adconrad) on 2016-06-16
Changed in vim (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Changed in vim (Ubuntu Xenial):
assignee: nobody → Adam Conrad (adconrad)
Martin Pitt (pitti) wrote :

In y this is fixed by https://launchpad.net/ubuntu/+source/vim/2:7.4.1829-1ubuntu1 (still in -proposed).

Changed in vim (Ubuntu):
status: Confirmed → Fix Committed
Changed in vim (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed

Hello Michael, or anyone else affected,

Accepted vim into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vim/2:7.4.1689-3ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vim - 2:7.4.1829-1ubuntu2

vim (2:7.4.1829-1ubuntu2) yakkety; urgency=medium

  * Explicitly set TERM to xterm for testsuite to avoid failures.

 -- Adam Conrad <email address hidden> Fri, 17 Jun 2016 01:39:04 -0600

Changed in vim (Ubuntu):
status: Fix Committed → Fix Released
Adam Conrad (adconrad) wrote :

As expected, the new xenial vim binary package grew a dependency on libpython3.5, and powerline now works correctly.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vim - 2:7.4.1689-3ubuntu1.1

vim (2:7.4.1689-3ubuntu1.1) xenial; urgency=medium

  * debian/rules: Specify python3 setup correctly (LP: #1574897)

 -- Adam Conrad <email address hidden> Thu, 16 Jun 2016 04:50:38 -0600

Changed in vim (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for vim has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Rene Luria (herel) wrote :

Can someone explain to the community why this has gone this far ?

Powerline is not shipped directly with vim, but with powerline (http://packages.ubuntu.com/xenial/powerline).

How come you solve a powerline problem by changing dependencies on vim package instead of fixing powerline package ?

Forcing vim users to install libpython3.5 is a bit excessive, don't you think ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers