Gvim displays lots of scary messages about UNITY_GTK_IS_MENU_SHELL

Bug #1499899 reported by Alexandru Panoiu on 2015-09-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
New
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
vim (Ubuntu)
High
Lee moonhyoung

Bug Description

When launched from a terminal the widely used text editor gvim displays lots WARNING and CRITICAL messages such as:

** (gvim:3608): WARNING **: (../../../lib/unity-gtk-menu-shell.c:176):unity_gtk_menu_shell_show_item: code should not be reached

** (gvim:3608): CRITICAL **: unity_gtk_menu_shell_handle_item_notify: assertion 'UNITY_GTK_IS_MENU_SHELL (shell)' failed

This did not happen in 15.04. It is a most embarrassing bug. Gvim is an essential tool for many users.

I am using Ubuntu 15.10 Beta 2.

$ lsb_release -rd
Description: Ubuntu Wily Werewolf (development branch)
Release: 15.10
$ apt-cache policy vim-gnome
vim-gnome:
  Installed: 2:7.4.712-2ubuntu3
  Candidate: 2:7.4.712-2ubuntu3
  Version table:
 *** 2:7.4.712-2ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
        100 /var/lib/dpkg/status
$ apt-cache policy vim-gtk
vim-gtk:
  Installed: 2:7.4.712-2ubuntu3
  Candidate: 2:7.4.712-2ubuntu3
  Version table:
 *** 2:7.4.712-2ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ wily/universe amd64 Packages
        100 /var/lib/dpkg/status

I expected to be able to use Gvim. Now Gvim pollutes the terminal with scary messages, and disturbs the messages shown by other programs running in the terminal.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: vim-gnome 2:7.4.712-2ubuntu3
ProcVersionSignature: Ubuntu 4.2.0-11.13-generic 4.2.1
Uname: Linux 4.2.0-11-generic x86_64
ApportVersion: 2.19-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Sep 26 00:40:37 2015
InstallationDate: Installed on 2015-09-25 (0 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150924)
SourcePackage: vim
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vim (Ubuntu):
status: New → Confirmed

Someone needs to check if this is a security bug.

Changed in vim (Ubuntu):
importance: Undecided → High
information type: Public → Public Security
information type: Public Security → Public
Changed in vim (Ubuntu):
assignee: nobody → Lee moonhyoung (eobeauti2)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers