vim no longer installable dependancy problems

Bug #1043035 reported by Matthew Gregg on 2012-08-29
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
vim (Ubuntu)
High
Unassigned

Bug Description

Running an up to date 12.10, vim-gtk, vim-gnome and vim-nox are all no longer installable due to a dependency problem.

Michael Bienia (geser) wrote :

Merging vim 2:7.3.547-4 from Debian unstable fixes it.

Changed in vim (Ubuntu):
status: New → Triaged
Julian Taylor (jtaylor) on 2012-08-29
Changed in vim (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vim - 2:7.3.547-4ubuntu1

---------------
vim (2:7.3.547-4ubuntu1) quantal; urgency=low

  * Make vim-* installable again (lp: #1043035) by merging with Debian
    unstable:
    - debian/runtime/debian.vim.in:
      + Add Launchpad integration to the Help menu if launchpad-integration is
        installed.
    - debian/runtime/vimrc:
      + "syntax on" is a sane default for non-tiny vim
    - debian/patches/debian/ubuntu-grub-syntax.patch:
      + Add Ubuntu-specific "quiet" keyword.

vim (2:7.3.547-4) unstable; urgency=low

  * Add remove-py_config.patch, removing the dependence on Python's config.c.
    (Closes: #681599)

vim (2:7.3.547-3) unstable; urgency=low

  * Add netrw-syntax-fix.patch to fix a syntax error in NetRead's ftp
    handling. (Closes: #678513)

vim (2:7.3.547-2) unstable; urgency=low

  * Work around GCC 4.7 optimization bug, #678122, by explicitly using gcc-4.6
 -- Michael Bienia <email address hidden> Wed, 29 Aug 2012 09:30:43 +0200

Changed in vim (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches