Menu key shortcuts gone in GVim

Bug #1007075 reported by Anders Lind on 2012-05-31
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
vim (Ubuntu)
Undecided
Unassigned

Bug Description

I have noticed that keyboard shortcuts from GVim are gone (visually) from the menu in Ubuntu 12.04.
I have noticed the same in the menu of Inkscape.

In Ubuntu 11.04 these key shortcuts were displayed in the menus.

Ubuntu version and package information:

anders@anders-desktop:~$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

anders@anders-desktop:~$ apt-cache policy vim-gnome
vim-gnome:
  Installed: 2:7.3.429-2ubuntu2.1
  Candidate: 2:7.3.429-2ubuntu2.1
  Version table:
 *** 2:7.3.429-2ubuntu2.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     2:7.3.429-2ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main i386 Packages

anders@anders-desktop:~$ apt-cache policy inkscape
inkscape:
  Installed: 0.48.3.1-1ubuntu1
  Candidate: 0.48.3.1-1ubuntu1
  Version table:
 *** 0.48.3.1-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

description: updated
pi-rho (pi-rho) wrote :

If you press the Alt key, the menu will activate and accelerators will become underlined. You should be able to press Alt-F and the file menu will pop open with several items showing their accelerators (provided that you haven't remapped Alt-F). If you mouse through the menus, the accelerators are hidden.

pi-rho (pi-rho) wrote :

... actually, it depends on which GUI you're using. vim-gtk shows accelerators always; on Windows they're hidden until activated.

Anders Lind (anders-lind) wrote :

Thank pi-rho for taking your time! :-)

First of all I use Unity (and therefore not Gnome although I do not know how much Unity shares with Gnome.)

I have tried using the Alt key and Alt-F instead of activating the menu with the mouse. I have tried this both with vim-gnome and vim-gtk packages where only one of each is installed at a time!

But the result is still the same. Neither mouse activated menu nor Alt key or Alt-F activated menu shows the accelerators (/key shortcuts) in the menu.

I think I use Unity 3D because of:
anders@anders-desktop:~$ echo $DESKTOP_SESSION
ubuntu
, with respect to the answers given here: http://askubuntu.com/questions/62001/am-i-using-unity-or-unity-2d

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vim (Ubuntu):
status: New → Confirmed

Keyboard shortcuts are added manually when creating a menu item. Example:

:menu Edit.Echo\ Hello<Tab>eh :echo "Hello"<CR>

Actually, the command "eh" will not echo anything because the real shortcut was not created by a :map command. But you can execute the command through the menu, which should have the following appearance:

    Edit
    [...]
    Echo Hello eh

But we actually see:

    Edit
    [...]
    Echo Hello

The keyboard shortcuts only appear if the global menu is disabled by starting gvim with the command:

UBUNTU_MENUPROXY= gvim

I'm using Ubuntu 12.10 64bit.

TJ (tj) wrote :

The loss of the keyboard short-cut hints to the right (left for bidi languages) of gvim menus occurs when it is using the Unity global menus.

When starting gvim such that it uses its own window menus the short-cut hints are present. Starting gvim using Alt+F2 then "gvim", or from a terminal:

UBUNTU_MENUPROXY="" gvim
(this simply clears the setting of the UBUNTU_MENUPROXY variable which is usually "libappmenu.so")

 will both launch gvim without using Unity global menus.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers