Trying to install the character "é" fails with vim-latexsuite

Bug #71754 reported by Miguel Martinez on 2006-11-14
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
vim-latexsuite (Debian)
Fix Released
Unknown
vim-latexsuite (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vim-latexsuite

Distribution affected: edgy

The title says it all, trying to insert the "é" character in a latex file via vim-latexsuite fails. Please note that the character can be displayed in the dvi file with the command \'e, and note that this doesn't happen with the other vowels: á í ó ú appear properly.

Steps to reproduce:
* Install vim (the full one) and vim-latexsuite
* Edit (via gvim or vim, doesn't matter) a tex file.
* Try to insert the character é (may not be possible on non-spanish or non-french keyboards). It will refuse.

If I uninstall vim-latexsuite I am able to insert accented e's at will.

Package: vim-latexsuite
Version: 0.20040314-1
Followup-For: Bug #257163

The problem is, that some sequences are mapped to <M-something>. Eg.
a map to <M-i>. These are understood as "character i with high bit set"
-- which happens to be e-acute. But the alt combinations are sent as
escape sequences -- at least here (as they really need to be on any
8-bit clean terminal). I will fix it by using <Esc>something explicitely
here, but am not sure, what is the correct fix.

-------------------------------------------------------------------------------
       Jan 'Bulb' Hudec <email address hidden>

tags 257163 moreinfo
thanks

Hello,
Could you provide me some additional information?

How do you use vim:
 a) under text console;
 b) under X in xterm as vim;
 c) under X as gvim/kvim?

Ad.a)
 Could you provide me your console keymap?

Ad.b and c)
 What you select in section "InputDevice" for keyboard as a value for option
 "XkbLayout"?

Cheers
 Artur
--
Co dwie kopie to nie jedna
 /z pamiętnika administratora/

On Fri, Jul 02, 2004 at 23:48:48 +0200, Artur R. Czechowski wrote:
> tags 257163 moreinfo
> thanks
>
> Hello,
> Could you provide me some additional information?
>
> How do you use vim:
> a) under text console;
> b) under X in xterm as vim;
> c) under X as gvim/kvim?

Under multi-gnome-terminal as vim. (though compiled with KDE support)

I just checked running it under various conditions and it turns out,
that multi-gnome-terminal is not really compatible with xterm here. True
xterm sends Alt as high bit. Sending escape is "rxvt" behaviour (and
console one, too).

However, even if I use a terminal, that should have correct terminfo --
like console or rxvt, :imap <M-i> still maps to e-acute and not to
<esc>i, as would be appropriate for that terminal. I tried default
settings, too (I normaly use encoding=utf8, termendocing=iso-8859-2).

Even if vim was forced to correctly use <Esc> on terminals, that send
alt as esc, it would not solve the problem for xterms and does not solve
it for kvim, which both generate character 0351 (or U+e9 if you prefer)
for Alt-i and that's simply indistiguishable from e-acute (because it is
e-acute (in iso-8859-1, iso-8859-2 and unicode)).

> Ad.a)
> Could you provide me your console keymap?
>
> Ad.b and c)
> What you select in section "InputDevice" for keyboard as a value for option
> "XkbLayout"?

I use special "ucw" keyboard. It behaves just like standard cz_qwerty
for applications, though. It resolves to iso-8859-2 characters on
XLookupSymbol.

> Cheers
> Artur
> --
> Co dwie kopie to nie jedna
> /z pamiętnika administratora/
>
-------------------------------------------------------------------------------
       Jan 'Bulb' Hudec <email address hidden>

On Sun, Jul 04, 2004 at 16:16:38 +0200, Artur R. Czechowski wrote:
> Hello,
>
>
> On Sat, Jul 03, 2004 at 11:12:31AM +0200, Jan Hudec wrote:
> > Under multi-gnome-terminal as vim. (though compiled with KDE support)
> >
> > I just checked running it under various conditions and it turns out,
> > that multi-gnome-terminal is not really compatible with xterm here. True
> [cut]
>
> You sent this email only to me. May I bounce it to debian BTS?

Of course you can.

-------------------------------------------------------------------------------
       Jan 'Bulb' Hudec <email address hidden>

Hello
I just prepared new vim-latexsuite package. There was some changes about
mapping code. If you like to test if it solves your problem, you can fetch
a package from http://blabluga.hell.pl/vls/. Feedback is welcomed.

Cheers
 Artur

On Mon, Jul 05, 2004 at 17:05:39 +0200, Artur R. Czechowski wrote:
> Hello
> I just prepared new vim-latexsuite package. There was some changes about
> mapping code. If you like to test if it solves your problem, you can fetch
> a package from http://blabluga.hell.pl/vls/. Feedback is welcomed.

No, it does not :-(.

The problem is, that the terminal emulator sends <Esc>key for Alt-key
presses. It can't do otherwise, since some 8-bit codes are valid
characters to be typed in. But vim parses <M-key> sequences as
"chr(key) + 128". So the bindings end up totaly bogus.

I actualy think the 'xterm-8bit' stuff in vim could do something with
it, but I don't see a way to explicitely disable it (since the terminal
does NOT use 8bit codes, obviously).

-------------------------------------------------------------------------------
       Jan 'Bulb' Hudec <email address hidden>

Maybe it may be usefull to include a link to the FAQ of vim-latexsuite at the
end of this bug report for peoples searching the solution :

http://vim-latex.sourceforge.net/index.php?subject=faq&title=FAQ#faq-e-acute

Q: I cannot insert the e-acute (é) character! HELP!
 Insert the following line in your ~/.vim/ftplugin/tex.vim file:
imap <buffer> <leader>it <Plug>Tex_InsertItemOnThisLine

 Replace <leader>it with any other key-sequence. This will make <leader>it key
insert an \item command corresponding to the last opened environment in the
current line in insert mode. The <M-i> key which is used for inserting the
e-acute character will remain unmapped.

--
Bertrand Haut
pgpkey ID:B9514013C02E33FA

Package: vim-latexsuite
Version: 0.20041219-2
Followup-For: Bug #257163

If I type "EAR" it results in

\left
\begin{array}{<+dimension+>}
<+elements+>
\end{array}
\right<++>

thanks,
augh

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.14
Locale: LANG=it_IT@euro, LC_CTYPE=it_IT@euro (charmap=ISO-8859-15)

Versions of packages vim-latexsuite depends on:
ii vim 1:6.4-004+2 Vi IMproved - enhanced vi editor

Versions of packages vim-latexsuite recommends:
pn latex <none> (no description available)

-- no debconf information

Package: vim-latexsuite
Version: 0.20041219-1
Followup-For: Bug #257163

I'm adding this to #257163, as Alberto Maurizi did with his comment
about "EAR", but it might be worth splitting this and the "EAR"
expansion off into a separate bug, as it looks like they might have a
different cause.

To typeset polytonic Greek, I use the ibycus4 package. For example, I
might type something like this sentence from Longus:

  {\greek Kai` to` a)'ntron e)ko'smhsan kai` ei)ko'nas a)ne'qesan, kai`
  bwmo`n ei('santo Poime'nos )'Erwtos; kai` tw=| Pani` de` e)'dosan a)nti`
  th=s pi'tuos oi)kei=n new'n, Pa=na Stratiw'thn o)noma'santes.}

With vim-latexsuite, I end up with this:

  {\greek Kai` to` a)'ntron e)ko'smhsan kai` ei)ko'nas a)ne'qesan, kai`
  bwmo\nu ei('santo Poime'nos )'Erwtos; kai` tw=| Pani` de` e)'dosan a)nti`
  th=s pi'tuos oi)kei=n new'n, Pa=na Stratiw'thn o)noma'santes.}

Note how "bwmo`n" became "bwmo\nu". If I enter a single backtick
followed by a letter other than 'i', 'j' or 'o', it gets expanded into
something else.

This problem would go away if special math-mode expansions were only
used when the user is entering text in math-mode.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.14
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages vim-latexsuite depends on:
ii vim 1:6.3-071+1sarge1 Vi IMproved - enhanced vi editor

-- no debconf information

On Wed, Nov 23, 2005 at 11:18:37AM +0100, Bertrand Haut wrote:
> FAQ entry about e-acute[1]
>
> Q: I cannot insert the e-acute (é) character! HELP! Insert the
> following line in your ~/.vim/ftplugin/tex.vim file: imap <buffer>
> <leader>it <Plug>Tex_InsertItemOnThisLine

 1. http://vim-latex.sourceforge.net/index.php?subject=faq&title=FAQ#faq-e-acute

Hi, thanks Bertrand for pointing to this FAQ entry. That definitely
closes the bug IMHO. This behaviour is documented and user is able to
change it if needed.

The messages about EAR replacements are off topic (still IMHO), since
this is one of the autoreplacements set up by this extension. Please
have a look at the FAQ for this item too[2].

 2. http://vim-latex.sourceforge.net/index.php?subject=faq&title=FAQ#faq-disabling-imap

Since both unrelated questions/matters are known and documented, I
think that this bug should be closed.

Finally, I'm not sure this bug thread is the place for Will Aoki's
message, so I'd like to suggest closing this bug, and asking Will
(Cc'd) to open a(nother) bug if he feels it's necessary.

Cheers,

--
Cyril Brulebois

I agree with Cyril, both problems seem to be addressed by the FAQ so
there's no need to keep this bug open. If issues remain please consider
reopening this bug or open a new one.

Cheers,
Franz
(new maintainer of vim-latexsuite)

--
Franz Pletz \ The Internet treats censorship as
www: http://franz-pletz.org/ \ damage and routes around it.
email: <email address hidden> \ -- John Gilmore

Miguel Martinez (el-quark) wrote :

Binary package hint: vim-latexsuite

Distribution affected: edgy

The title says it all, trying to insert the "é" character in a latex file via vim-latexsuite fails. Please note that the character can be displayed in the dvi file with the command \'e, and note that this doesn't happen with the other vowels: á í ó ú appear properly.

Steps to reproduce:
* Install vim (the full one) and vim-latexsuite
* Edit (via gvim or vim, doesn't matter) a tex file.
* Try to insert the character é (may not be possible on non-spanish or non-french keyboards). It will refuse.

If I uninstall vim-latexsuite I am able to insert accented e's at will.

This problem is exists.

http://vim-latex.sourceforge.net/index.php?subject=faq&title=FAQ
The solution is written on the page above (search for é), but the solution is a little bit difficult. And I can use it only if I put the latexsuite from tar.gz to ~/.vim .
  Arpad

Fernando Ribeiro (ipsec) wrote :

http://vim-latex.sourceforge.net/index.php?subject=faq&title=FAQ#faq-e-acute

Anyone can to test?
Copy to maintainer vim-latexsuite.

Thanks

Fernando Ribeiro (ipsec) on 2006-11-21
Changed in vim-latexsuite:
assignee: nobody → fernando.ribeiro
status: Unconfirmed → Confirmed
Changed in vim-latexsuite:
status: Unknown → Fix Released
William Grant (wgrant) wrote :

This is a user-configurable behaviour [1], and Debian feels it inappropriate to change it in the package. I tend to agree.

[1] http://vim-latex.sourceforge.net/index.php?subject=faq&title=FAQ#faq-e-acute

Changed in vim-latexsuite:
status: Confirmed → Rejected
torzsmokus (torzsmokus) wrote :

despite 'working as designed', this behaviour is still very annoying. one should not expect average users of an Ubuntu package to read upstream FAQs and fix an issue by manually editing config files when all they want is to actually _type_ a character in their native script (and not even some obscure rarely-used one).
why not include that one-liner fix in the package by default? I tend to disagree with W. Grant.

Changed in vim-latexsuite (Ubuntu):
status: Invalid → Opinion
torzsmokus (torzsmokus) on 2011-04-26
Changed in vim-latexsuite (Ubuntu):
status: Opinion → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.