[gutsy] latexsuite doesn't load in vim after install

Bug #137205 reported by Ilmari Vacklin on 2007-09-04
38
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vim-latexsuite (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: vim-latexsuite

After installing vim-latexsuite, I opened a .tex file, but the latexsuite scripts were not loaded. I installed vim-full as per instructions in bug 92146, but that didn't help. The script doesn't load in either vim or gvim.

I have the following vim-related packages installed:

wolverian@puni:/usr/share/doc/aptitude$ sudo aptitude -F '%p %20v' search '~ivim'
vim 1:7.1-056+2ubuntu1
vim-common 1:7.1-056+2ubuntu1
vim-full 1:7.1-056+2ubuntu1
vim-gnome 1:7.1-056+2ubuntu1
vim-gui-common 1:7.1-056+2ubuntu1
vim-latexsuite 20060325-3
vim-runtime 1:7.1-056+2ubuntu1
vim-scripts 7.1.2
vim-tiny 1:7.1-056+2ubuntu1

And my .{,g}vimrc shouldn't be doing anything weird related to this.

Jos Dehaes (jos-dehaes) wrote :

confirming. It was working before.

Jos Dehaes (jos-dehaes) wrote :

jos@duet ~ $ sudo aptitude -F '%p %20v' search '~ivim'
vim 1:7.1-056+2ubuntu1
vim-common 1:7.1-056+2ubuntu1
vim-full 1:7.1-056+2ubuntu1
vim-gnome 1:7.1-056+2ubuntu1
vim-gui-common 1:7.1-056+2ubuntu1
vim-latexsuite 20060325-3
vim-runtime 1:7.1-056+2ubuntu1
vim-scripts 7.1.2

Jos Dehaes (jos-dehaes) wrote :

It works when I install manually in .vim, so not a problem with my .vimrc.

Morten Siebuhr (msiebuhr) wrote :

When I look at where vim searches for plugins, I get

:set runtimepath
runtimepath=~/.vim,/var/lib/vim/addons,/usr/share/vim/vimfiles,/usr/share/vim/vim71,/usr/share/vim/vimfiles/after,/var/lib/vim/addons/after,~/.vim/after

While, in a shell, it seems vim-latexsuite is not installed in a path searched by vim:
# locate latex-suite
...
/usr/share/vim/addons/ftplugin/latex-suite
...

AFAIK, to find vim-latexsuite, vim should look in /usr/share/vim/addons/, which it does not. OR vim-latexsuite should be installed in /var/lib/vim/addons/, which it is not...

Continuing this reasoning, adding the following to my .vimrc should fix it:
set runtimepath+=/usr/share/vim/addons/

Opening a .tex-file after making this modification, things now work...

(Oh, and I had vim-full installed, but vim-latexsuite still did not work for me...)

Dan Drake (ddrake) wrote :

I can also confirm this. Adding /usr/share/vim/addons/ to the runtimepath did not help.
However, using the vim-addon-manager package to install latex-suite into my ~/.vim directory fixed the problem.

vim-related packages via "sudo aptitude -F '%p %20v' search '~ivim'":

vim 1:7.1-056+2ubuntu2
vim-addon-manager 0.2
vim-common 1:7.1-056+2ubuntu2
vim-gnome 1:7.1-056+2ubuntu2
vim-gui-common 1:7.1-056+2ubuntu2
vim-latexsuite 20060325-3
vim-runtime 1:7.1-056+2ubuntu2
vim-tiny 1:7.1-056+2ubuntu2

Hannes (hannesl-web) wrote :

I can also confirm this. For me, msiebuhr's solution did the trick: I added the line

"set runtimepath+=/usr/share/vim/addons/"

to my vimrc.

Before that I had tried a complete deinstallation of all vim-related packages, and then apt-getted vim-latexsuite pulling in vim etc. That did not help. Now, after inserting above line in vimrc it launches the Latex-Suite automatically upon opening a .tex-file.

Hannes

Hannes (hannesl-web) wrote :

I have to correct my entry of 2007-10-15:
While adding "set runtimepath+=/usr/share/vim/addons/" to .vimrc did fire up the Latex-Suite-menus when loading .tex-files it did not give me a fully functional suite. F5, F7 and F9 autocompletion etc. worked, but the suite neither compiled nor showed output.
So, I tried Dan Drake's tip and installed and ran vim-addon-manager. The output of "vim-addons list" showed an entry for latexsuite, but "vim-addons status" showed it was not installed. "vim addons install latexsuite" finally did the trick. (I then removed "set runtimepath+=/usr/share/vim/addons/" from the vimrc again.)

 Everything is working as it should now. I can recommend trying vim-addon-manager. To get the manpages type "man vim-addons" in a terminal.

Tobias Wolf (towolf) wrote :

To enale the package system-wide, as before, this command is needed:

sudo vim-addons -w install latex-suite

It is detailed in the NEWS file of vim-full.

Wouter Horré (wouterh) wrote :

The solution in comment #8 worked for me. Running 'sudo vim-addons -w install latex-suite' made the latex-suite work again.

z-bot (robotics-csu) wrote :

One more user confirming that the 'sudo vim-addons -w install latex-suite' solution works.

Note: I did not have the 'vim-addons' command in my system, so I thought that it was part of the vim-full version, so I did:

'sudo apt-get install vim-full'

Close, but no cigar, still didn't have the command so I did:

'sudo apt-get install vim-addon-manager'

(Drumroll)... And now, lads and gents:

'sudo vim-addons -w install latex-suite'

Fixed the problems... vim-latex is back to it glorious beauty.

You guys rock! Long live Linux!

-zbot

Vesal Vojdani (vesal) wrote :

Yes, thanks everyone!

'sudo apt-get install vim-addon-manager'
'sudo vim-addons -w install latex-suite'

Hannes (hannesl-web) wrote :

Now that the solution for firing up latexsuite is found: does anybody else experience trouble with the integration of xdvi inverse-search? On Feisty I had the entry
  xdvi.editor: gvim --remote
in ~/ .Xdefaults so that xdvi knew which editor to invoke. This does not work for on Gutsy (setup: cli-install, added xfce4 and gdm.)
My hunch: got something to do with https://bugs.launchpad.net/ubuntu/+source/texlive-bin/+bug/137258
"xdvi alternative is broken in gutsy"?

 Does anybody else experience this problem?
Thanks,
 Hannes

LaserJock (laserjock) wrote :

Well that's not cool. I'll look into fixing this for Hardy anyway, I'm not sure if it's big enough for a gutsy-update.

Changed in vim-latexsuite:
assignee: nobody → laserjock
importance: Undecided → Medium
status: New → Triaged

I have the same problem, but using vim-addons install latex-suite now works. The only problem I had before this patch is that xdvi is not working, but I have changed it to evince, and now everything looks better ;)

Cya!

lorubenet (lorubenet) wrote :

Thanks for the tip! the addon thing worked for me as well. It should be done automatically by apt-get when installing the vim-latexsuite... whatever...

On the xdvi stuff, my solution is having the following tex.vim in the ~/.vim/ftplugin directory:
" Increasing search, finds occurrences when typing
set incsearch
" TIP: if you write your \label's as \label{fig:something}, then if you
" type in \ref{fig: and press <C-n> you will automatically cycle through
" all the figure labels. Very useful!
set iskeyword+=:
setlocal sw=2
"setlocal formatoptions+=a
setlocal spell
vmap ,b "zdi\textbf{<C-R>z}<ESC>
vmap ,e "zdi\emph{<C-R>z}<ESC>
vmap ,t "zdi\texttt{<C-R>z}<ESC>

func WriteLatex()
        :w
        :call Tex_RunLaTeX()
endfunc

 " Latex-Suite
let g:Tex_CompileRule_dvi = 'latex -interaction=nonstopmode -src-specials $*'
if v:servername != ""
        let g:Tex_ViewRule_dvi = 'xdvi -editor "gvim --servername '.v:servername.' --remote +\%l \%f"'
endif

cmap we :call WriteLatex()

Happy latex/vimming!
Rub

LaserJock (laserjock) wrote :

Well, I dug around on this and it's actually the intended behavior. The Debian VIM policy (http://pkg-vim.alioth.debian.org/vim-policy.html/) is now that addons should *not* be enabled systemwide by default. This is to avoid file collisions and to make it so that addons don't affect other users when installed on a multi-user system. So addons need to be turned on via vim-addons (from vim-addon-manager) on a per user basis.

I'm closing the bug now. If you don't like this policy or behavior the appropriate place discuss it is the pkg-vim-maintainers list on http://lists.alioth.debian.org but latexsuite is installing the correction location according to the policy. Thanks and sorry for the confusion.

Changed in vim-latexsuite:
assignee: laserjock → nobody
status: Triaged → Invalid
chastell (chastell) wrote :

One more comment for whan Jordan said: the policy basically means that such add-ons should be triggered ‘by hand’, on either system-wide basis or a per-user basis.

As a result, the above-mentioned `sudo vim-addons -w install latex-suite` will install VIM-LaTeX for all users, but if you want to install it just for yourself, a simple `vim-addons install latex-suite` will do.

Chris Lasher (chris.lasher) wrote :

Could this information about `vim-addons install latex-suite` (with an install of vim-addon-manager) please be added to a README file distributed with this package? Had there been one simple line about this at the top of the README.Debian it would have saved me a lot of time trying to track down this solution. It is not obvious that this information is in the vim-full documentation.

chastell (chastell) wrote :

Chris: This approach would mean all the packages shipping Vim scripts should get updated with such info. (I’m not saying this is a bad idea, I’m just pointing out this should be done in unison.)

Laurie Savage (savage-laurie) wrote :

I've tried this in Hardy - no luck.

Output of "vim-addons satus" is
# Name User Status System Status
latex-suite installed removed
matchit removed installed

doing "gvim newfile.tex" as user results in no LaTeX-suite menus in Gvim.
I had vim-rails installed but the Rails menu always came up when I was opening a .tex file.

flo-54321 (flo-54321) wrote :

The vim-addons solution does not work on hardy:

After

sudo aptitude install vim-latexsuite
sudo vim-addons -w install latex-suite

I get:

vim-addons status
# Name User Status System Status
latex-suite broken broken
matchit removed removed

Albrecht Mühlenschulte (a7p) wrote :

Take a look at lp:25411

This bug is a duplicate - the bug is fixed, but the fix is not yet released - just a matter of time *g*.

Simon Ruggier (simon80) wrote :

deeflex, you should take the time to read the rest of the comments, since adding that directory to the runtimepath is apparently a hack that the package maintainer doesn't support. I don't think it was ever a good idea to install plugins disabled by default, but it's also not a good idea to do something that will break in some situations.

Daniel Germer (daniel-triple5) wrote :

I added a new bug on this issue #382253
because none of the suggestions here worked in my current jaunty install. There is a suggestion that there was a bug introduced in vim itself under: #42283

panter24 (hercekuros) wrote :

user@user:~$ vim
Error detected while processing /var/lib/vim/addons/plugin/remoteOpen.vim:
line 37:
E174: Command already exists: add ! to replace it
line 38:
E174: Command already exists: add ! to replace it
Press ENTER or type command to continue

where is the problem?

Rodolfo (rodolfojandrade) wrote :

panter24, did you remove the line "set runtimepath+=/usr/share/vim/addons/" from ~/.vimrc after installing the latex-suite through the addon manager?

panter24 (hercekuros) wrote :

Rodolfo
no.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers