[MIR] vgabios

Bug #181876 reported by Soren Hansen on 2008-01-10
4
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
High
Dustin Kirkland 
vgabios (Ubuntu)
High
Unassigned

Bug Description

Related branches

Matthias Klose (doko) wrote :

the package is ok for inclusion in main. I didn't look at the bios code itself. Is there a way to keep the copies in kvm an qemu in sync?

Changed in vgabios:
status: New → In Progress
Martin Pitt (pitti) wrote :

Promoted.

Changed in vgabios:
status: In Progress → Fix Released

On Thu, Feb 07, 2008 at 10:13:43PM -0000, Matthias Klose wrote:
> the package is ok for inclusion in main. I didn't look at the bios code
> itself. Is there a way to keep the copies in kvm an qemu in sync?

Last I checked there were kvm specific changes in the bios that made
this quite non-trivial.

I can look into it, though.

--
Soren Hansen
Virtualisation specialist
Ubuntu Server Team
http://www.ubuntu.com/

Reopening this bug, as vgabios is currently in Universe.

I'm working on the merge of qemu-kvm-0.12.1.2, from which the vgabios code has been removed from the release tarball.

We should instead depend on the the vgabios package for installation.

Please let me know if you need anything else from me to update to the MIR, itself. As far as I can see, this should be relatively straightforward, as nearly identical code has been in Main within kvm and qemu-kvm for several years now.

Changed in vgabios (Ubuntu):
status: Fix Released → Confirmed
importance: Undecided → High
milestone: none → lucid-alpha-3
Changed in qemu-kvm (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Dustin Kirkland (kirkland)
summary: - Main inclusion request
+ [MIR] vgabios
Loïc Minier (lool) wrote :

Are there large differences between vgabios and the vgabios which lived in qemu-kvm?

Hrm, well...

There are some differences, I don't know if it's large. The diffstat
looks like this:

 BUGS | 3
 COPYING | 504 ++++++
 ChangeLog | 1311 ++++++++++++++++
 Makefile | 87 +
 Notes | 11
 README | 226 ++
 TODO | 26
 biossums.c | 282 +++
 clext.c | 1641 ++++++++++++++++++++
 dataseghack | 23
 tests/lfbprof/Makefile | 5
 tests/lfbprof/lfbprof.c | 594 +++++++
 tests/lfbprof/lfbprof.h | 149 +
 tests/testbios.c | 353 ++++
 vbe.c | 1452 +++++++++++++++++
 vbe.h | 315 +++
 vbe_display_api.txt | 237 ++
 vbetables-gen.c | 261 +++
 vgabios.c | 3913 ++++++++++++++++++++++++++++++++++++++++++++++++
 vgabios.h | 47
 vgafonts.h | 784 +++++++++
 vgatables.h | 622 +++++++
 31 files changed, 12975 insertions(+)

This is the diffstat of the vgabios in karmic's qemu-kvm, which is a
bit older than the vgabios I merged from (latest upstream).

I can try to analyze it a bit more closely.

:-Dustin

Martin Pitt (pitti) wrote :

Matthias already ack'ed it in the past, and it's always good to replace copies in upstream tarballs with an explicit package. Matthias' original question "Is there a way to keep the copies in kvm an qemu in sync?" seems to have a proper answer now, since it's now just one source package for both.

Changed in vgabios (Ubuntu):
status: Confirmed → Fix Committed
Steve Kowalik (stevenk) wrote :

Based on Martin's ack of Matthias's ack, I have promoted vgabios source and binary from universe to main.

Changed in vgabios (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 0.12.1.2-0ubuntu1

---------------
qemu-kvm (0.12.1.2-0ubuntu1) lucid; urgency=low

  * Merge from upstream
    - debian/rules:
      + drop bios hacks, as we now depend on vgabios
      + align our configure line more closely with fedora, preferring pa
        for audio (let's give this another try, might need to revert by
        Lucid Beta), and accepting the project defaults for audio hw
    - debian/control: depend on vgabios, LP: #181876
    - debian/patches/*: drop patches now included upstream
      + 02_extboot_build_fixes.patch
      + 05_improve-qemu-img-errors.patch
      + 06_set_sdl_title.patch
      + 07_right_ctrl_grab.patch
      + 08_fix_qemu-ifup.patch
      + 09_qemu-fix-qcow2-backing-file-with-virtio.patch
      + 10_fix_scsi_hotplug.patch
      + 11_fix_virtio-blk_hot_add_after_remove.patch
      + 12_whitelist_host_virtio_networking_features.patch
      + 60_armv4l-typo.patch
    - debian/patches/*: apply two patches from Loic Minier, both submitted
      and acked by upstream (should be dropped in a future merge)
      + 0001-linux-user-adapt-uname-machine-to-emulated-CPU.patch
      + 0001-Fix-missing-symbols-in-.rela.plt-sections.patch
    - debian/install, debian/links: install the necessary bios roms;
      when seabios gets promoted to main, we should depend on it, and use
      its bios.bin instead of this one
 -- Dustin Kirkland <email address hidden> Wed, 20 Jan 2010 17:54:24 +1300

Changed in qemu-kvm (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers