vdr-sxfe segmentation fault on key press

Bug #232241 reported by Robert Schneider on 2008-05-20
10
Affects Status Importance Assigned to Milestone
vdr-plugin-xineliboutput (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vdr-plugin-xineliboutput

Using vdr-sxfe on 8.04 causes a segmentation fault whenever one presses any key other than ESC. I have reproduced this on five different machines. Some were newly installed Ubuntu 8.04 some were upgraded from 7.x.

This seems not to be related to bug 197400.

Here is a backtrace of the bug

It seems to crash here, but now I am lost.

1146 LOGDBG("Keypress: %s %s %s %s",
(gdb) s
1148 if(input) {
(gdb) s
1150 if(input_vdr->f.input_control) {
(gdb) s
1151 input_vdr->f.input_control(input, map, key, repeat, release);
(gdb) s

Program received signal SIGSEGV, Segmentation fault.
0x00000035 in ?? ()
list

Can someone help?

Is there anything I can do to have some body look after that? This bug prevents a lot of machine upgrades here at my end for me and friends. Unfortunately, I cannot fix the bug myself and I would really appreciate if somebody could look into that?

Timo Aaltonen (tjaalton) wrote :

Sorry for the late reply, but could you try building the version in Intrepid? This might be a duplicate of bug 197400.

Changed in vdr-plugin-xineliboutput:
status: New → Incomplete
Javier Jardón (jjardon) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Javier Jardón schrieb:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering is this still an issue
> for you? Can you try with latest Ubuntu release? Thanks in advance.
>
>
Hi,

i have switched to another repository for these packages and I am sorry,
but I can't test with the Ubuntu packages any longer.

Best regards,

Robert

Javier Jardón (jjardon) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in vdr-plugin-xineliboutput:
status: Incomplete → Invalid
Stefan (s-launchpad-infocrew) wrote :

Recompiling the version from intrepid, vdr-plugin-xineliboutput_1.0.1-5.dsc, makes it work on Hardy for me (resolving the problem with crashing on the first keypress).
However I needed to use dpkg-buildpackage -uc -us -d to override the dependencies on vdr-dev (>= 1.6.0-5) and libxine-dev (>= 1.1.12).

Changed in vdr-plugin-xineliboutput (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers