VA API is missing Radeon support (r600_drv_video.so missing; also radeonsi and nouveau)

Bug #964040 reported by Jaime Alberto Silva on 2012-03-24
102
This bug affects 20 people
Affects Status Importance Assigned to Milestone
vdpau-video (Baltix)
High
Unassigned
vdpau-video (Debian)
Fix Released
Unknown
vdpau-video (Ubuntu)
Wishlist
Unassigned
Trusty
Low
Unassigned

Bug Description

When i run vainfo I get:

libva: VA-API version 0.32.0
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/r600_drv_video.so
libva: va_openDriver() returns -1

I have looked for this library in other packages and can't find any libva radeon package, seems like this library is missing from the ati drivers.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-radeon 1:6.14.99~git20111219.aacbd629-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-19.31-generic 3.2.12
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Sat Mar 24 12:56:55 2012
InstallationMedia: Xubuntu 12.04 "Precise Pangolin" - Beta amd64 (20120228)
SourcePackage: xserver-xorg-video-ati
UpgradeStatus: No upgrade log present (probably fresh install)

Timo Aaltonen (tjaalton) wrote :

there is no VAAPI support for radeon..

Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2012-04-03
summary: - /usr/lib/dri/r600_drv_video.so missing
+ no vaapi support (/usr/lib/*/dri/r600_drv_video.so missing)

Radeon does support VDPAU though, on Ubuntu 13.10 "Saucy Salamander" and later.

Mathew Hodson (mathew-hodson) wrote :

The package vdpau-va-driver provides nvidia_drv_video.so, s3g_drv_video.so, and vdpau_drv_video.so, so I think that is where this needs to be fixed.

affects: xserver-xorg-video-ati (Ubuntu) → vdpau-video (Ubuntu)
tags: added: trusty
summary: - no vaapi support (/usr/lib/*/dri/r600_drv_video.so missing)
+ VA API is missing Radeon support (/usr/lib/*/dri/r600_drv_video.so
+ missing)

You can work around by setting LIBVA_DRIVER_NAME=vdpau.

$ LIBVA_DRIVER_NAME=vdpau vainfo
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'vdpau'
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/vdpau_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.35 (libva 1.3.0)
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.3
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple : VAEntrypointVLD
      VAProfileMPEG2Main : VAEntrypointVLD
      VAProfileH264Baseline : VAEntrypointVLD
      VAProfileH264Main : VAEntrypointVLD
      VAProfileH264High : VAEntrypointVLD
      VAProfileVC1Simple : VAEntrypointVLD
      VAProfileVC1Main : VAEntrypointVLD
      VAProfileVC1Advanced : VAEntrypointVLD

summary: - VA API is missing Radeon support (/usr/lib/*/dri/r600_drv_video.so
- missing)
+ VA API is missing Radeon support (r600_drv_video.so missing; also
+ radeonsi and nouveau)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vdpau-video - 0.7.4-3

---------------
vdpau-video (0.7.4-3) unstable; urgency=medium

  * debian/patches/mesa-drivers.patch: Enable drivers for nouveau, radionsi
    and r600. (Closes: #757370) (LP: #964040)

 -- Sebastian Ramacher <email address hidden> Thu, 07 Aug 2014 20:40:19 +0200

Changed in vdpau-video (Ubuntu):
status: Confirmed → Fix Released

Having this fix backported to trusty would be nice ;)

Changed in vdpau-video (Ubuntu Trusty):
status: New → Confirmed
importance: Undecided → Low
frankster (wtfrank) wrote :

It looks like you may need the fixed vdpau-video for in-home-streaming to work in steam with certain ATI cards

Changed in vdpau-video (Ubuntu Trusty):
status: Confirmed → Triaged
Changed in vdpau-video (Debian):
status: Unknown → Fix Released
Changed in vdpau-video (Ubuntu Trusty):
milestone: none → trusty-updates
Alecz20 (alexguzu) wrote :

I was able to download the vdpau-va-driver_0.7.4-3_amd64.deb and install it in Trusty (14.04) without issues from here:
http://packages.ubuntu.com/utopic/amd64/vdpau-va-driver/download

vainfo now works :)

Changed in vdpau-video (Baltix):
importance: Undecided → High
Angel Guzman Maeso (shakaran) wrote :
Download full text (4.3 KiB)

I have 0.7.4-6 under Ubuntu 17.10 and it seems not fixed to me

$ vainfo
libva info: VA-API version 0.40.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/r600_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

$ vdpauinfo
display: :0 screen: 0
API version: 1
Information string: G3DVL VDPAU Driver Shared Library version 1.0

Video surface:

name width height types
-------------------------------------------
420 16384 16384 NV12 YV12
422 16384 16384 UYVY YUYV
444 16384 16384 Y8U8V8A8 V8U8Y8A8

Decoder capabilities:

name level macbs width height
----------------------------------------------------
MPEG1 --- not supported ---
MPEG2_SIMPLE 3 9216 2048 1152
MPEG2_MAIN 3 9216 2048 1152
H264_BASELINE 41 9216 2048 1152
H264_MAIN 41 9216 2048 1152
H264_HIGH 41 9216 2048 1152
VC1_SIMPLE 1 9216 2048 1152
VC1_MAIN 2 9216 2048 1152
VC1_ADVANCED 4 9216 2048 1152
MPEG4_PART2_SP --- not supported ---
MPEG4_PART2_ASP --- not supported ---
DIVX4_QMOBILE --- not supported ---
DIVX4_MOBILE --- not supported ---
DIVX4_HOME_THEATER --- not supported ---
DIVX4_HD_1080P --- not supported ---
DIVX5_QMOBILE --- not supported ---
DIVX5_MOBILE --- not supported ---
DIVX5_HOME_THEATER --- not supported ---
DIVX5_HD_1080P --- not supported ---
H264_CONSTRAINED_BASELINE 0 9216 2048 1152
H264_EXTENDED --- not supported ---
H264_PROGRESSIVE_HIGH --- not supported ---
H264_CONSTRAINED_HIGH --- not supported ---
H264_HIGH_444_PREDICTIVE --- not supported ---
HEVC_MAIN --- not supported ---
HEVC_MAIN_10 --- not supported ---
HEVC_MAIN_STILL --- not supported ---
HEVC_MAIN_12 --- not supported ---
HEVC_MAIN_444 --- not supported ---

Output surface:

name width height nat types
----------------------------------------------------
B8G8R8A8 16384 16384 y NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8 A4I4 I4A4 A8I8 I8A8
R8G8B8A8 16384 16384 y NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8 A4I4 I4A4 A8I8 I8A8
R10G10B10A2 16384 16384 y NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8 A4I4 I4A4 A8I8 I8A8
B10G10R10A2 16384 16384 y NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8 A4I4 I4A4 A8I8 I8A8

Bitmap surface:

name width height
------------------------------
B8G8R8A8 16384 16384
R8G8B8A8 16384 16384
R10G10B10A2 16384 16384
B10G10R10A2 16384 16384
A8 16384 16384

Video mixer:

feature name sup
------------------------------------
DEINTERLACE_TEMPORAL y
DEINTERLACE_TEMPORAL_SPATIAL -
INVERSE_TELECINE -
NO...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.