[SRU] vblade discovery doesn't work

Bug #223440 reported by J. Bruce Fields on 2008-04-28
6
Affects Status Importance Assigned to Milestone
vblade (Ubuntu)
Undecided
Unassigned
Declined for Dapper by Thierry Carrez
Declined for Gutsy by Luca Falavigna
Hardy
Undecided
Chuck Short
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: vblade

Starting vblade, then running aoe-discover and aoe-stat on the client produces no output. (Using vblade 14-1ubuntu1 from Hardy Heron and, on the client, aoetools 21-1 from debian sid).

Watching the traffic in wireshark reveals that the client is sending a broadcast packet, and an strace of vblade shows it is reading this packet, but immediately dropping it without responding.

Inspection of the code shows that this is due to an incorrect length check which causes vblade to drop requests (such as this one) which are less than 60 bytes. The best solution is probably to upgrade to version 15, but I believe the attached patch is the relevant fix.

By "https://wiki.ubuntu.com/Bugs/HowToTriage", I figure if there's a patch available (and the same bug has been fixed upstream) then it's clearly confirmed....

Changed in vblade:
status: New → Confirmed
Chuck Short (zulcss) wrote :

This is fixed for karmic.

Changed in vblade (Ubuntu Karmic):
status: Confirmed → Fix Released
Chuck Short (zulcss) on 2009-08-11
Changed in vblade (Ubuntu Hardy):
assignee: nobody → Chuck Short (zulcss)
Chuck Short (zulcss) on 2009-08-11
summary: - vblade discovery doesn't work
+ [SRU] vblade discovery doesn't work
Chuck Short (zulcss) wrote :

Description: vblade-14 was released with a bug that prevents it from discovering properly. This was fixed in vblade-15 and is working for later version of Ubuntu.

The patch that fixes this issue is already attached to this bug. There should not be any regressions using this patch.

How to reproduce:

Install vblade from hardy and see if the vblade is discoverable.

If you have any questions please let me know.

Regards
chuck

Steve Langasek (vorlon) wrote :

Accepted into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in vblade (Ubuntu Hardy):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Anyone who can test the update in hardy-proposed?

Jamie Strandboge (jdstrand) wrote :

I ran into this bug recently while doing regression testing and can confirm that upgrading to 14-1ubuntu1.1 fixes this for me.

Martin Pitt (pitti) on 2009-10-20
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vblade - 14-1ubuntu1.1

---------------
vblade (14-1ubuntu1.1) hardy-proposed; urgency=low

  * debian/vblade.init: init.d script fails to start because
    pid file is not created properly. Thanks to J. Bruce Fields (LP: #223387)
  * Backported fix from vblade-15 for vblade discovery bug. Thanks to J. Bruce
    Fields (LP: #223440)

 -- Chuck Short <email address hidden> Tue, 11 Aug 2009 14:53:36 -0400

Changed in vblade (Ubuntu Hardy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers